LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-05-2008, 04:25 PM   #1
Stephan_Craft
Member
 
Registered: Jul 2008
Posts: 184

Rep: Reputation: 30
HELP No default editor has been set or filetype association is missing or incorrect


i use "filezilla" ftp soft... when i try to edit file, i get this error

"No default editor has been set or filetype association is missing or incorrect."

how can i solve this?
 
Old 09-05-2008, 05:07 PM   #2
Kahless
Member
 
Registered: Jul 2003
Location: Pennsylvainia
Distribution: Slackware / Debian / *Ubuntu / Opensuse / Solaris uname: Brian Cooney
Posts: 503

Rep: Reputation: 30
what are you trying to edit, a config file for the program?

you could just open the file with gedit, vi, or whatever you want from a command line, or set an association


Somthing like vi filename or gedit filename
 
Old 09-05-2008, 05:19 PM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
The answer is ... $ export EDITOR=vim
... or whatever editor you want for the default.

But I don't think you know what the question is.

Last edited by rickh; 09-05-2008 at 05:22 PM.
 
Old 09-05-2008, 07:01 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Quote:
Originally Posted by Stephan_Craft View Post
i use "filezilla" ftp soft... when i try to edit file, i get this error

"No default editor has been set or filetype association is missing or incorrect."

how can i solve this?
In FileZilla's menu: Edit -> Settings -> Remote Fille Editing, there is a line were you can enter the default editor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wine filetype association with linux application simone.garza Linux - Software 0 07-23-2007 08:55 AM
How to set a default text editor carlsonultimate SUSE / openSUSE 2 04-26-2007 03:52 PM
firefox filetype association budword Linux - Desktop 3 02-10-2007 04:00 AM
Missing grub-set-default? LasseBob Linux - Software 2 03-08-2006 10:12 PM
grub-set-default missing Paulsuk Linux - Software 3 02-08-2006 08:18 PM


All times are GMT -5. The time now is 07:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration