LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-29-2011, 12:53 PM   #1
Lorderok
LQ Newbie
 
Registered: May 2011
Posts: 3

Rep: Reputation: Disabled
Help mounting hard drive in knoppix


Hello, I have been running a computer under Windows XP for years, and recently it stopped booting unexpectedly. It tries to load windows, but partway though loading a BSOD flashes and it shuts down. To remedy this and hopefully fix this, my frined lent me some Knoppix CDs that I could boot from. He also lent me some external hard drives. I want to be able to access my files on my old hard drive.
Here's the problem: (in Knoppix 6) When I try to mount my main partition of my hard drive, which shows as sda2 (sda1 is an old recovery partition left over from when I ran vista), the following message pops up: "A job is pending on dev/sda2" A little later another error window pops up: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." I want to be able to mount my hard drive in Knoppix 6. Can anyone help?

Last edited by Lorderok; 05-29-2011 at 01:38 PM.
 
Old 05-29-2011, 01:17 PM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
#su
<enter for passwd>
#mkdir /bli
#mount -t ntfs /dev/sda2 /bli

/bli has your files
vfat is fat32

#mount

lists mounted devices

#umount /abc

unmounts /abc

---------- Post added May 29th, 2011 at 22:48 ----------

parted magic cd will be better suited for your purpose
 
Old 05-29-2011, 01:30 PM   #3
Lorderok
LQ Newbie
 
Registered: May 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
I tried the commands you suggested,and I went to the /bli folder. It was empty. What should I try next?

I also got an error report:

ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Last edited by Lorderok; 05-29-2011 at 01:36 PM.
 
Old 05-29-2011, 01:37 PM   #4
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
From a little Googling, I suspect that your error message may be "A job is pending on dev/sda2". The cause of this may be that Knoppix has already found the partition and tried to mount it. Before you try to mount the partition, run mount to see what partitions are already mounted. If you see your Windows partition in the list, simply use the existing mountpoint to access your files.

--- rod.
 
Old 05-29-2011, 01:41 PM   #5
Lorderok
LQ Newbie
 
Registered: May 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by theNbomr View Post
From a little Googling, I suspect that your error message may be "A job is pending on dev/sda2". The cause of this may be that Knoppix has already found the partition and tried to mount it. Before you try to mount the partition, run mount to see what partitions are already mounted. If you see your Windows partition in the list, simply use the existing mountpoint to access your files.

--- rod.
Thank you, I didn't catch that typo. Unfortunately, i put in "mount" and /dev/sda2 was not listed. I ahev one more thing that may be useful. When I mount it in Knoppix 5, It says it needed to "force" mount because the "volume was dirty" Regardless, what is my next course of action?
 
Old 05-29-2011, 02:39 PM   #6
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
A little more Googling, and I find that it appears that there is no Linux remedy for clearing the dirty volume status. The NTFS driver relies on running Windows' chkdsk to fix the corrupted disk. Are you able to mount the disk? Read files? If so, I would try to mount it read-only, and copy as much as possible from it.
If you have access to a bootable Windows system, you might be able to put the drive in it, and use Windows to fix it, if it is fixable. Does Windows still use recue floppies? If so, maybe that is an option for repair.
--- rod.

Last edited by theNbomr; 05-29-2011 at 02:40 PM.
 
Old 06-02-2011, 12:15 PM   #7
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
Quote:
Originally Posted by theNbomr View Post
A little more Googling, and I find that it appears that there is no Linux remedy for clearing the dirty volume status.
ntfsfix does that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help on mounting Hard Disk Drive and CD-ROM drive in Dapper. ussr_1991 Ubuntu 2 08-19-2007 12:33 AM
Copy Fedora 5 Hard Drive to another Hard Drive Using Knoppix 5.1.1 lud477 Linux - Software 2 03-17-2007 06:06 PM
Using hard drive in knoppix Blackwolf189 Other *NIX 3 05-27-2006 12:17 PM
cd-rom drive working in knoppix Hard drive installation dj_dubbbz Linux - Newbie 5 03-02-2004 11:58 AM
Knoppix to hard drive joe83 Linux - Newbie 1 10-22-2003 06:08 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration