LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2003, 09:22 AM   #1
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Rep: Reputation: 30
HELP! mounted hard drive's read only system?


hey im really stressed with this is it actualy posible to actualy write to an ntfs of fat32 hard drive from linux? because ive tried making the mounted hard drive mount folder to 777 rebooted but yet it still dont work can you please tell me howto do this?
 
Old 07-28-2003, 09:26 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you can write to fat32 if you mount it correctly i.e. setting umask=000 will let *anyone* write to it. write support for ntfs is too dangerous to advocate, don't do it.
 
Old 07-28-2003, 09:49 AM   #3
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
for fat 32 drive or partision

mount -t vfat /dev/hda1 /mnt/hdd
hda1 is first fat32 partison of first ide disk and u will have to creat your target directory

for NTFS use thses 3 command with urs requiements
1-mount /dev/hda1 /mnt/windows -t ntfs -r
2-mount /dev/hda1 /mnt/windows -t ntfs -r -o umask=0222
3-mount /dev/hda1 /mnt/windows -t ntfs -r -o umask=0222,uid=flatcap,gid=winuser
visit this usefull site
1-http://linux-ntfs.sourceforge.net/info/redhat.html


2-Using Linux in a Microsoft Environment
http://mailman.linuxtag.org/~spindler/talks/Stormacq/

i have done with these good sites
enjoy
 
Old 07-28-2003, 09:50 AM   #4
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Original Poster
Rep: Reputation: 30
cheers! aslong as i can write to the fat32 thats the main fhing.
 
Old 07-28-2003, 10:00 AM   #5
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Original Poster
Rep: Reputation: 30
humm still wont let me write to it.

LABEL=/ / ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hdk1 /mnt/installedgames ntfs defaults,owner,ro,umask=222,gid=100 0 0
/dev/hda1 /mnt/win2k ntfs defaults,owner,ro,umask=002,gid=100 0 0
/dev/hdb5 /mnt/downloads vfat defaults,owner,ro,umask=000,gid=100 0 0
/dev/hde1 /mnt/120gb ntfs defaults,owner,ro,umask=222,gid=100 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
#


see:

/dev/hdb5 /mnt/downloads vfat defaults,owner,ro,umask=000,gid=100 0 0

im sure thats write but when i say create a new folder it says:

Error "Read only file system" creating new folder.

when i try: mount /dev/hda1 /mnt/windows -t ntfs -r -o umask=0222,uid=flatcap,gid=winuser

i get error:
mount: wrong fs type, bad option, bad superblock on /dev/hde1,
or too many mounted file systems

Last edited by Devboy; 07-28-2003 at 10:03 AM.
 
Old 07-28-2003, 10:01 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
what do you think "ro" stands for?
 
Old 07-28-2003, 10:04 AM   #7
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Original Poster
Rep: Reputation: 30
read only? dam!
 
Old 10-12-2003, 08:23 AM   #8
goodwellbest
LQ Newbie
 
Registered: Oct 2003
Location: Vietnam
Posts: 1

Rep: Reputation: 0
I see in my hardware browser : hda1(fat32),hda3(fat32),hda4(fat32),hda6(Linux ext3),...
but i don't see hda... in /dev/
how can i mount hda1?
please help me!!
 
Old 10-12-2003, 08:39 AM   #9
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Original Poster
Rep: Reputation: 30
Humm, can you take a SS of your hardware browser showing this info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 01:17 PM
Hard drive's not working for knoppix hdinstall gravy Linux - Newbie 1 11-20-2005 12:40 PM
Filesystems always mounted as read-only on boot after recent system freeze brookepb Fedora 20 04-08-2005 11:58 AM
NFS: a mounted to b, b mounted to c, c can't read a? Steve Cronje Linux - Networking 9 10-25-2004 10:51 AM
Hard drive mounted in read only (After long uptime...) otjervaag Linux - Laptop and Netbook 10 10-04-2003 09:34 PM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration