LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-04-2009, 11:06 PM   #1
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Rep: Reputation: 15
Help me to resolve the issue


Hi


I am using Linux RHEL ES 4.When i trying to install my new version of gcc, getting the following error.

Code:
[root@localhost rpms]# rpm -ivh gcc-3.4.6-3.i386.rpm
warning: gcc-3.4.6-3.i386.rpm: V3 DSA signature: NOKEY, key ID 443e1821
error: Failed dependencies:
        cpp = 3.4.6-3 is needed by gcc-3.4.6-3.i386
        libgcc >= 3.4.6-3 is needed by gcc-3.4.6-3.i386
[root@localhost rpms]#
Further when i going for install cpp new version again i am getting the following error.

Code:
[root@localhost rpms]# rpm -ivh cpp-3.4.6-3.i386.rpm
warning: cpp-3.4.6-3.i386.rpm: V3 DSA signature: NOKEY, key ID 0c98ff9d
Preparing...                ########################################### [100%]
        file /usr/bin/cpp from install of cpp-3.4.6-3 conflicts with file from package cpp-3.4.3-9.EL4
        file /usr/libexec/gcc/i386-redhat-linux/3.4.3/cc1 from install of cpp-3.4.6-3 conflicts with file from package cpp-3.4.3-9.EL4
        file /usr/share/man/man1/cpp.1.gz from install of cpp-3.4.6-3 conflicts with file from package cpp-3.4.3-9.EL4
[root@localhost rpms]#

Please help me.

wbr

shibu.
 
Old 03-04-2009, 11:08 PM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,111

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
try rpm -Uvh cpp-3.4.6-3.i386.rpm
 
Old 03-05-2009, 01:03 AM   #3
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Thank you for quick answer and when i try as you said i am getting the following error

Quote:
[root@localhost rpms]# rpm -Uvh cpp-3.4.6-3.i386.rpm
warning: cpp-3.4.6-3.i386.rpm: V3 DSA signature: NOKEY, key ID 0c98ff9d
error: Failed dependencies:
cpp = 3.4.3-9.EL4 is needed by (installed) gcc-3.4.3-9.EL4.i386
[root@localhost rpms]#
please help me.

shibu
 
Old 03-05-2009, 03:26 AM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,257

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
when was the last time that the rpm data base was cleaned
Code:
su 
rpm --rebuilddb
and the old legacy gcc3.4 should be in a yum repo for RH4 why not use that one .

Last edited by John VV; 03-05-2009 at 03:28 AM.
 
Old 03-05-2009, 03:37 AM   #5
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,111

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by shibu_sp View Post
Thank you for quick answer and when i try as you said i am getting the following error


please help me.

shibu
[sarcasm]ah, good ol' dependency hell [/sarcasm]

that's why tools like yum annd apt-get were created in the first place,

it means you are gonna have to download the proper version of gcc to match the version of cpp you are trying to install and run rpm -Uvh with that, and then see what dependencies it comes up with and download and try and install those with rpm -Uvh package.rpm etc..

yum and apt-get were created to automate this process to make updating as painless as possible...

Last edited by frieza; 03-05-2009 at 03:38 AM.
 
Old 03-05-2009, 05:08 AM   #6
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Original Poster
Rep: Reputation: 15
here I am trying using yum

Quote:
[root@localhost rpms]# yum install gcc-3.4.6-3.i386.rpm
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Examining gcc-3.4.6-3.i386.rpm: gcc - 3.4.6-3.i386
Marking gcc-3.4.6-3.i386.rpm as an update to gcc - 3.4.3-9.EL4.i386
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.i386 0:3.4.6-3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.3-9.EL4 for package: gcc-g77
--> Processing Dependency: cpp = 3.4.6-3 for package: gcc
--> Processing Dependency: gcc = 3.4.3-9.EL4 for package: gcc-c++
--> Processing Dependency: gcc = 3.4.3-9.EL4 for package: gcc-gnat
--> Processing Dependency: gcc = 3.4.3-9.EL4 for package: gcc-java
--> Processing Dependency: gcc = 3.4.3-9.EL4 for package: gcc-objc
--> Processing Dependency: libgcc >= 3.4.6-3 for package: gcc
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-g77
Error: Missing Dependency: cpp = 3.4.6-3 is needed by package gcc
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-c++
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-gnat
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-java
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-objc
Error: Missing Dependency: libgcc >= 3.4.6-3 is needed by package gcc
[root@localhost rpms]#
please help me how to solve

shibu
 
Old 03-05-2009, 05:16 AM   #7
fatra2
Member
 
Registered: Feb 2004
Location: Switzerland
Distribution: Fedora - RedHat - Mandrake - OpenSuse
Posts: 214

Rep: Reputation: 35
Hi there,

From my experience, you don't need to tell yum the complete package name you want to install. In that sense, you should try to install gcc like this
Code:
yum install gcc
This will let yum take the latest version of the package, and the dependencies should follow without to many problems.

Cheers
 
Old 03-05-2009, 05:28 AM   #8
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Original Poster
Rep: Reputation: 15
hi
still im getting the following error

Quote:
[root@localhost rpms]# yum install gcc
Setting up Install Process
Setting up repositories
rpmforge 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: gcc
Nothing to do
[root@localhost rpms]#
shibu
 
Old 03-05-2009, 12:33 PM   #9
John VV
Guru
 
Registered: Aug 2005
Posts: 13,257

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
what repos do you have installed on that old rhel 4 ( you do know that rhel 5.2 is the current)
yes 4 is still supported , just like win 98 was still supported for a long time after xp came out .
can you post the output of
Code:
yum repolist all
 
Old 03-05-2009, 09:51 PM   #10
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by
[code
yum repolist all
[/code]

Code:
[oracle@localhost etc]$ yum repolist all

usage: yum [options] < update | install | info | remove | list |
    clean | provides | search | check-update | groupinstall |
    groupupdate | grouplist | groupinfo | groupremove |
    makecache | localinstall | erase | upgrade | whatprovides |
    localupdate | resolvedep | shell | deplist >

options:
  -h, --help            show this help message and exit
  -t, --tolerant        be tolerant of errors
  -C                    run entirely from cache, don't update cache
  -c [config file]      config file location
  -R [minutes]          maximum command wait time
  -d [debug level]      debugging output level
  -e [error level]      error output level
  -y                    answer yes for all questions
  --version             show Yum version and exit
  --installroot=[path]  set install root
  --enablerepo=[repo]   enable one or more repositories (wildcards allowed)
  --disablerepo=[repo]  disable one or more repositories (wildcards allowed)
  --exclude=[package]   exclude package(s) by name or glob
  --obsoletes           enable obsoletes processing during updates
  --noplugins           disable Yum plugins
[oracle@localhost etc]$
 
Old 03-05-2009, 11:38 PM   #11
John VV
Guru
 
Registered: Aug 2005
Posts: 13,257

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
ok then the old yum on rhel 4 dose not have "repolist"
have you installed any 3d party reops for rhel4
Have you looked through the red hat docs for 4
http://www.redhat.com/docs/manuals/enterprise/#RHEL4
http://www.redhat.com/docs/manuals/e...anagement.html

you might want to see what ( if any) gcc is installed already with
Code:
rpm -qa | grep gcc
the current compiler is gcc 4.3 , but rhel4 3.4.3
also i would NOT BOTHER trying to do such a small upgrade
from gcc 3.4.3 to gcc 3.4.6 on that old of a operating system
 
Old 03-06-2009, 12:10 AM   #12
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Quote:
[acclsys@localhost ~]$ rpm -qa | grep gcc
gcc4-c++-4.0.0-0.14.EL4
gcc-g77-3.4.3-9.EL4
gcc4-4.0.0-0.14.EL4
libgcc-3.4.3-9.EL4
compat-gcc-32-c++-3.2.3-47.3
gcc-3.4.3-9.EL4
gcc-java-3.4.3-9.EL4
compat-gcc-32-3.2.3-47.3
gcc-c++-3.4.3-9.EL4
gcc-objc-3.4.3-9.EL4
gcc4-gfortran-4.0.0-0.14.EL4
compat-libgcc-296-2.96-132.7.2
gcc-gnat-3.4.3-9.EL4
[acclsys@localhost ~]$

shibu
 
Old 03-06-2009, 12:15 AM   #13
John VV
Guru
 
Registered: Aug 2005
Posts: 13,257

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
with gcc 4 installed why do you want to install 3.4.6 .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can 'dpkg -i' resolve dependency issue automatically? Akhran Debian 13 01-04-2010 10:54 PM
Is Aptitude capable of installing local .deb package and resolve dependency issue? Akhran Debian 3 07-06-2009 06:05 PM
DNS (and Postfix) Issue ('Domain doesn't resolve') zokken Linux - Networking 2 10-29-2008 02:10 PM
Unable to resolve 915GM resolution issue samjaynes Ubuntu 18 03-11-2007 11:07 PM
How to resolve automount issue in KDE 3.5? depam Linux - Software 1 10-18-2006 01:31 AM


All times are GMT -5. The time now is 05:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration