LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-08-2006, 12:40 AM   #1
alaios
Senior Member
 
Registered: Jan 2003
Location: Aachen
Distribution: Opensuse 11.2 (nice and steady)
Posts: 2,133

Rep: Reputation: 45
Help me install kde rpm packages


Hi i am using kde 3.4 and i want to upgrade it to kde 3.5.1
I have downloaded all the kde rpm packages and i have tried to do the upgrade

error: Failed dependencies:
glib2-devel is needed by arts-devel-1.5.1-4
jack-devel is needed by arts-devel-1.5.1-4
libogg-devel is needed by arts-devel-1.5.1-4
libvorbis-devel is needed by arts-devel-1.5.1-4
audiofile-devel is needed by arts-devel-1.5.1-4
alsa-devel is needed by arts-devel-1.5.1-4
libruby.so.1.8 is needed by kdebindings3-ruby-3.5.1-5
libpoppler-qt.so.0 is needed by kdegraphics3-3.5.1-6
povray is needed by kdegraphics3-3D-3.5.1-6
tetex is needed by kdegraphics3-tex-3.5.1-6
libvorbis-devel is needed by kdelibs3-devel-3.5.1-15
autoconf is needed by kdelibs3-devel-3.5.1-15
automake is needed by kdelibs3-devel-3.5.1-15
libxslt-devel is needed by kdelibs3-devel-3.5.1-15
libxml2-devel is needed by kdelibs3-devel-3.5.1-15
libart_lgpl-devel is needed by kdelibs3-devel-3.5.1-15
libjpeg-devel is needed by kdelibs3-devel-3.5.1-15
libtiff-devel is needed by kdelibs3-devel-3.5.1-15
unsermake is needed by kdelibs3-devel-3.5.1-15
update-desktop-files is needed by kdelibs3-devel-3.5.1-15
libattr-devel is needed by kdelibs3-devel-3.5.1-15
libacl-devel is needed by kdelibs3-devel-3.5.1-15
fam-devel is needed by kdelibs3-devel-3.5.1-15
pcre-devel is needed by kdelibs3-devel-3.5.1-15
libidn-devel is needed by kdelibs3-devel-3.5.1-15
perl-IO-Socket-SSL is needed by kdenetwork3-IRC-3.5.1-4
kdelibs3-devel-doc is needed by kdevelop3-3.3.1-5
graphviz is needed by kdevelop3-3.3.1-5
doxygen is needed by kdevelop3-3.3.1-5
libdb-4.1.so is needed by kdevelop3-3.3.1-5
tidy is needed by kdewebdev3-3.5.1-5
freetype2-devel is needed by qt3-devel-3.3.5-28
libmng-devel is needed by qt3-devel-3.3.5-28
libpng-devel is needed by qt3-devel-3.3.5-28
zlib-devel is needed by qt3-devel-3.3.5-28
xorg-x11-Mesa-devel is needed by qt3-devel-3.3.5-28
freeglut-devel is needed by qt3-devel-3.3.5-28
xorg-x11-devel is needed by qt3-devel-3.3.5-28


But so many packages seem to be missing.. What i need is to give me a yast source so i can install the missing packages from there..
Thx a lot
 
Old 03-08-2006, 01:47 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
I found it easier to update KDE through YaST. The first thing you need is to make sure you have an online source (instead of the CD/DVD). I use this (change to suit your location / version). Then add a source for KDE like this (again change as required).

Go to the install and remove software in YaST, select Package Groups, navigate to the bottom and click zzz All. Then on the right hand side, right-click select All in This List | Update if Newer Version Available. This should pull the latest version of KDE and all the required updates from the online source.

Hope this helps a bit.

Baldrick

Last edited by Baldrick65; 03-08-2006 at 01:51 AM.
 
Old 03-08-2006, 08:49 AM   #3
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
If you don't intent to compile stuff from sources, you don't need the *-devel rpm packages. This should eliminate many dependencies problems.
 
Old 03-11-2006, 09:48 AM   #4
alaios
Senior Member
 
Registered: Jan 2003
Location: Aachen
Distribution: Opensuse 11.2 (nice and steady)
Posts: 2,133

Original Poster
Rep: Reputation: 45
Thx a lot after removing the packages i receive the following messages..
error: Failed dependencies:
libruby.so.1.8 is needed by kdebindings3-ruby-3.5.1-5
libpoppler-qt.so.0 is needed by kdegraphics3-3.5.1-6
povray is needed by kdegraphics3-3D-3.5.1-6
tetex is needed by kdegraphics3-tex-3.5.1-6
perl-IO-Socket-SSL is needed by kdenetwork3-IRC-3.5.1-4
The problem is that i cant find these packages in Yast!! My installation sources are


akroneiro:/home/alaios/Desktop/kde3.5.1 # installation_sources -s
Installation Sources:
SUSE LINUX Version 10.0 (ftp://ftp.ntua.gr/pub/linux/suse/i38...x10.0-GM-Extra)
SUSE LINUX Version 10.0 (ftp://ftp.ntua.gr/pub/linux/suse/i38...t-source-extra)
Packman (SuSE LINUX 10.0) (ftp://ftp.gwdg.de/pub/linux/misc/packman/suse/10.0)
supplementary KDE 3.5 update (ftp://ftp.gwdg.de/pub/linux/suse/ftp....0/yast-source)
Packman (SuSE LINUX 10.0) (http://packman.inode.at/suse/10.0/)
guru (SUSE LINUX 10.0) (http://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.0/)
SUSE LINUX Version 10.0 (http://suse.mirrors.tds.net/pub/open...t-source-java/)
SUSE LINUX Version 10.0 (cd:///;devices=/dev/hdc,/dev/hdd)

What am i doing wrong?
 
Old 03-12-2006, 12:55 PM   #5
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Is the source
Quote:
SUSE LINUX Version 10.0 (cd:///;devices=/dev/hdc,/dev/hdd)
enabled?
and the installation CD ready in the CD reader?

You should also add:
supplementary GNOME 2.12 update (ftp://ftp.gwdg.de/pub/linux/suse/ftp....0/yast-source)
to your list.
Because even if you don't use the Gnome WM, you still need some packages from there (gtk, ...).

Otherwise you may search for rpm packages using http://rpm.pbone.net/
Be in the 'Advanced RPM Search'
Click 'Uncheck All' then check only the OpenSuSE box
Check 'Search for rpms which contain given file name (1) e.g. libhistory.so'
And give the library you want to get and click the 'SEARCH' button
Wait for the answser (sometimes takes a few minutes).
You will find links to download the missing packages.

For example I made the search for the library libpoppler-qt.so.0
and I got
This result

But first look if the packages are not already on the installation CD.
Maybe everything you need is already there.
Good luck.

Last edited by berbae; 03-12-2006 at 01:07 PM.
 
Old 03-12-2006, 01:42 PM   #6
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
If you are using Suse, take a look at my post in this thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install rpm packages in RedHat shahrokhnikou Linux - Software 1 07-28-2005 02:50 PM
How do I install .rpm packages using RH9? ScottyKUtah Linux - Newbie 3 08-08-2004 08:09 AM
RPM 'failed dependencies': Why can I not install any rpm packages? leontini Linux - Newbie 7 09-16-2003 12:44 AM
can RPM removing all packages I have install? Embeder Linux - General 4 06-13-2003 10:37 AM
How to install rpm packages recursively? concoran Linux - General 4 12-20-2001 09:42 AM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration