LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2004, 11:41 PM   #1
snip128
Member
 
Registered: Jan 2004
Location: Delaware
Distribution: gentoo
Posts: 96

Rep: Reputation: 15
help me config my res?


well...slackware set the resolution good (dunno what it was...) after i installed my nvidia drivers...but i just HAD to mess with the xorg.conf file....to try to get my mouse to use its middle wheel (which i failed at by the way) and now im stuck at this terrible either 640x480 or 800x600(dunno either...i dunno how to check res)...its low, and hard to work with....i tried killing x and running xorgconfig, but whenever i run through that, x wont start up again, so i use xorgsetup and i get back where i started ctrl, alt, + just lowers the resolution, then if u hit it again, it goes back....ehehe, i even tried reinstalling slack hoping it would make the res better after i installed nvidia drivers, but no such luck.....i will get my linux up and working if its the last thing i do!!! lol -_-
 
Old 11-06-2004, 12:01 AM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
Look for "Modes" lines in your X config file. Under mine (XFree86-4.3), they look like
Code:
Modes       "1024x768" "800x600" "640x480"
Add the resolutions you need there, the first should be the default. Multiple lines may be set for multiple color depths.
 
Old 11-06-2004, 12:05 AM   #3
snip128
Member
 
Registered: Jan 2004
Location: Delaware
Distribution: gentoo
Posts: 96

Original Poster
Rep: Reputation: 15
mine doesnt have that....or at least i didt see it...its xorg.conf

heh...heres my whole file =P help me if ya can plz :)

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "glx"
Load "xtrap"
Load "freetype"
Load "type1"
Load "freetype"
Load "speedo"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV34 [GeForce FX 5200]"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 11-06-2004, 12:09 AM   #4
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 33
You have to add them with an editor to look something like this...

Section "Screen"
Identifier "Screen 1"
Device "NVIDIA GeForce"
Monitor "My Monitor"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "800x600"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "800x600"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "800x600"
ViewPort 0 0
EndSubsection
EndSection
 
Old 11-06-2004, 12:22 AM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
Yeah, having the lines missing might also do that Didn't even think about that.
 
Old 11-06-2004, 12:29 AM   #6
snip128
Member
 
Registered: Jan 2004
Location: Delaware
Distribution: gentoo
Posts: 96

Original Poster
Rep: Reputation: 15
=/

still doesnt work... maybe i added them in wrong? i also tried replacing 800x600 with 1024x768, still no go

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
modes "800x600"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Last edited by snip128; 11-06-2004 at 12:51 AM.
 
Old 11-06-2004, 09:04 AM   #7
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
The file is, most likely, case sensitive... "Modes" instead of "modes"
 
Old 11-06-2004, 09:42 AM   #8
snip128
Member
 
Registered: Jan 2004
Location: Delaware
Distribution: gentoo
Posts: 96

Original Poster
Rep: Reputation: 15
changed it to "Modes"....still nothing =/ (i restarted x)
 
Old 11-06-2004, 10:42 AM   #9
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 33
you're missing the 24 depth... add this to the bottom..

Depth 24
Modes "800x600"
ViewPort 0 0
EndSubsection
 
Old 11-06-2004, 10:47 AM   #10
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 33
you're missing the 24 depth options... add this to the bottom of the Section "Screen".. right now you have it set to defaut to the 24 depth...

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24 <--- right here "this is from your post above"

and you don't have anything under the Depth 24. So add the lines to the bottom part of the Section "Screen" between -- Depth 24 and EndSection --

Depth 24
Modes "800x600" <--- add this
ViewPort 0 0 <--add this
EndSubsection <--and this line add
EndSection

Oops... didn't mean to double post like that. Was trying to edit instead.

Last edited by Linux~Powered; 11-06-2004 at 10:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant Change Res dj9928 Linux - Hardware 2 08-12-2005 02:49 PM
Screen Res AGilley007 Debian 3 09-17-2004 07:00 PM
Screen Res. KarmaKill Slackware 4 07-04-2004 07:18 AM
changing res dfownz Linux - Software 1 01-31-2004 08:31 PM
Screen Res c4t Linux - Newbie 7 07-12-2002 04:00 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration