LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2008, 02:38 AM   #1
fastzip2003
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Unhappy "Help Me!!"


Hello all. I installed linux ubuntu for the first time yesterday. Before installing the linux OS on my computer I added a second hard drive that showed up on my computer as local disc(f). My intentions were to boot linux from this drive only. After installing the OS the second hard drive stopped showing up in my computer. The new OS booted fine a few times,so I did the updates. After all the updates were finished I cranked up the monitor resolution. Now when I boot linux the boot screen appears but after that the screen go blank. Can someone direct me on how to fix this problem
 
Old 12-02-2008, 03:31 AM   #2
zeno0771
Member
 
Registered: Jun 2006
Location: Northern IL
Distribution: Arch64
Posts: 106

Rep: Reputation: 19
The second hard drive stopped showing up in Windows because, once you installed Ubuntu, it became a foreign drive with a filesystem that Windows doesn't recognize/tolerate/care about.

You don't mention which version of Ubuntu you installed or what video card (if any) you're using, so with what you've said I can only surmise that either:
1. You set the monitor resolution higher than the monitor was designed to go with that refresh rate (the "out of range" error), or
2. Your drivers and/or Xorg were updated and are now incompatible with your video hardware.
In either case the boot screen will show up because it's set to display at a certain resolution at install regardless what the monitor is set to. You'll have to edit your xorg.conf by starting in runlevel 3/single-user mode to bring the settings back into spec. Barring that, you may have to roll the video driver back.
 
Old 12-02-2008, 07:22 PM   #3
fastzip2003
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Hello,thank you for the quick response. The version of ubuntu I installed is 8.0.4.1 Kernel 2.6.24-22-generic. The video card I run is a Radeon X1300 series. Would you be able to tell me how to edit my xorg.conf? Ive started in runlevel 3/single-user mode but I don't know what to do to bring the settings back into spec. Also do I roll the video driver back in my windows OS? Would wiping my added hard drive and starting over be a better option to keeping my new hard drive were Windows will recognize it? Thank you so much for all your help.
 
Old 12-03-2008, 01:13 AM   #4
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 37
1. The easiest way to reset video mode is to reinstall ubuntu.
2. You must always backup a file before editing it.
3. Harder way: Run the ubuntu disk as a live cd.
Do the following with the live cd.

fdisk -l #Determine which /dev/sd??? your root directory is on
mkdir /myhdd
mount /dev/sd??? /myhdd #mount the hard drive from the ram disk
cd /myhdd/etc/X11/
ls
#Since you edited xorg.conf, you might have xorg.conf~
mv xorg.conf~ xorg.conf
#That should solve your video issue.
#If not...
vim (or any text editor you want) xorg.conf
#edit the xorg.conf back to original settings.

4. Do not erase your second harddrive.
How is your second hdd formatted?
fdisk -l will show how it is formatted.
If it ntfs you will need the ntfs-3g and fuse programs.

[edit] You can also copy the xorg.conf from your ramdisk from the livecd to your harddrive.
cp /etc/X11/xorg.conf /myhdd/etc/X11/xorg.conf [/edit]

Let me know how things work out.

Last edited by okos; 12-03-2008 at 01:05 PM.
 
Old 12-03-2008, 01:56 AM   #5
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
Quote:
Originally Posted by fastzip2003 View Post
Hello,thank you for the quick response. The version of ubuntu I installed is 8.0.4.1 Kernel 2.6.24-22-generic. The video card I run is a Radeon X1300 series. Would you be able to tell me how to edit my xorg.conf? Ive started in runlevel 3/single-user mode but I don't know what to do to bring the settings back into spec. Also do I roll the video driver back in my windows OS? Would wiping my added hard drive and starting over be a better option to keeping my new hard drive were Windows will recognize it? Thank you so much for all your help.
Windows is not going to recognise that drive if you use it to install linux and use the entire drive. While Linux can access Windows partitions, Windows cannot access Linux partitions. There are a few programs that will allow access to Linux filesystems from within Windows, but I have not used them and cannot comment on the reliability or safety of such programs.

You shouldn't have to do anything with your drivers in Windows, Linux hasn't touched them, nor does it use the Windows drivers.

One question is what size is the 2nd hard drive you got? Do you know what a partition is? If you still want to use that drive in Windows, you can. Say the new drive is 160 GB. When you install Linux, you can tell it to, for example, take 58 GB for the / partition and 2 GB for the swap partition. That would mean Linux is using 60 GB of that drive. In Windows, that drive would show up (as long as you format the partition) as a 100 GB F drive. Windows can use the 100 GB while Linux is stored in 60 GB that Windows cannot see.

When and if you do reinstall Ubunutu, make sure you enable the drivers for your video card. You can go to System -> Administration -> Hardware Drivers to enable any proprietary drivers that Ubuntu finds for your hardware.

Good Luck.
 
Old 12-03-2008, 03:41 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Please use descriptive thread titles in future (i.e. ones that say something about the problem you're having). You are told to do this when you post a thread, so there's no real excuse for using a bad title like "help me".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can I "cat" or "grep" a file to ignore lines starting with "#" ??? callagga Linux - Newbie 7 08-16-2013 07:58 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 08:11 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM
Any way to get "Alice"; "Call of Duty" series and "Descent 3" to work? JBailey742 Linux - Games 13 06-23-2006 02:34 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration