LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2007, 02:24 AM   #1
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Rep: Reputation: 0
Unhappy help me!


my problem is this, that no linux works on my system
my system config is dual core 2.8(intel),motherboard by asus,1 gb ram,250 hd.
when i installed fedora core 7 is stops with the msg system panic kill init...
does linux not work on dual core??????
 
Old 12-14-2007, 02:54 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Use better thread titles!

Post complete messages error messages please.
 
Old 12-14-2007, 03:09 AM   #3
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,036

Rep: Reputation: 96
Is this a "Core 2 Duo" processor?

If so which version of Fedora are you installing?

The Unofficial Fedora FAQ page:
http://www.fedorafaq.org/

States that if you are installing on a Core 2 Duo machine, you need to use the x86_64 version




The ubunto wiki shows that there are a number of issues being reported with Core 2 Duo machines, and has workarounds (with varying degrees of success)

https://wiki.ubuntu.com/Core_2_Duo_Support
 
Old 12-14-2007, 03:17 AM   #4
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 182

Rep: Reputation: 21
Linux does work with dual Core.

You probably need to add some boot option(s) to your system, like disabling acpi and/or apic.
 
Old 12-14-2007, 04:19 AM   #5
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by roy_lt_69 View Post
Linux does work with dual Core.

You probably need to add some boot option(s) to your system, like disabling acpi and/or apic.


whats acpi/or apic and from where can i toggle these option
 
Old 12-14-2007, 04:37 AM   #6
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
32 bit Fedora 8 working great here on a Toshiba laptop, Core 2 Duo. Awesome distro. Fedora 7 was equally perfecto.
 
Old 12-14-2007, 08:20 AM   #7
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
I would try booting from live-evaluation CDs to see if you hardware works well. I heard Fedora might be live-evaluation by now. If not, perhaps you could try

PCLinuxOS or
SimplyMepis

Both of these are great first distributions.
 
Old 12-14-2007, 08:36 AM   #8
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Glennzo View Post
32 bit Fedora 8 working great here on a Toshiba laptop, Core 2 Duo. Awesome distro. Fedora 7 was equally perfecto.
my prob is with dual core not core 2 duo
 
Old 12-14-2007, 08:39 AM   #9
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Disillusionist View Post
Is this a "Core 2 Duo" processor?

If so which version of Fedora are you installing?

The Unofficial Fedora FAQ page:
http://www.fedorafaq.org/

States that if you are installing on a Core 2 Duo machine, you need to use the x86_64 version




The ubunto wiki shows that there are a number of issues being reported with Core 2 Duo machines, and has workarounds (with varying degrees of success)

https://wiki.ubuntu.com/Core_2_Duo_Support
sir used fedora core 7 and i have a dual core not core 2 duo
 
Old 12-14-2007, 08:42 AM   #10
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Quote:
Originally Posted by malayletsrock View Post
my prob is with dual core not core 2 duo
Hey, you're right. Didn't pay close enough attention. There are 2 Fedora 8 Live CD's. I'd say that they are 'evaluation' distros. http://fedoraproject.org/get-fedora
 
Old 12-14-2007, 10:08 AM   #11
jayaprakash
LQ Newbie
 
Registered: Nov 2007
Posts: 20

Rep: Reputation: 0
malayletsrock seems to be a friend of mine. I must hve seen that message a hundred times whenecver I tried to install a different version of linux on any of my ancient systems . ( yes I do have ancient systems starting from a 386 based pc running at 33 Mhz ( now dont laugh or sneer) with 32 Mb ( ther, dont laugh again, you are permitted to guffaw) ram and no onboard video, running through 486, P1, PII, PIII and now a PIV on a 945 mother board with 1 Gb ram. And talking about distros has anybody kept count of their no. I myself have more than a dozen. coming to malay's problem, I think his DVD writer or combo (fedora 7 comes on a DVD)is playing tricks. The message he is getting should probabaly read "kernel panic. Trying to kill initiate.This is either fallowed or precededby a series of hex codes. (hex codes are dangerous. let's leave them to the geeks). and the system message usually appears after acpi initiation( It is acpi advanced configuration and power interface). when the system begins to continuosly load the disk to ram. with a 1 Gb ram it tries to load as much as possible which prolongs the running of the CD. this may cause a drop in the supply rails to the ram powerbus. I would suggest malay to check his SMPS or ram ( trying to remove and reinsert the may also help) Justifying that windows XP or vista runs on the same machine may not carry much weight as windows uses a different installation method. Yes On all those systems I encountered this problem but I could load windows ( 98, 2000, XP) without any problem. Except the very old ones of course).Again suggesting that the system is brand new would also be hallow. even the best boards and SMPSes have their limitations. in the worst cas ( ihope it is not,) there may be a memory hole in his ram. This does happen. Only a full memory check can reveal this.
As for ------ suggestion of trying from a live distro, I fail to understand, how it can be done when the system refuses to initiate . In all probabality he may get the same message. Another method which he can try is to copy the linux to another partition ( only if he has another OS on his system of course)and boot from that partition from his bios. This has worked with win 98 on some of my older systems, but I have not tried it with linux yet. may be I should. Another problem he may encounter is after installation his graphics may not work and he may see a lot of gibberish instead of the login screen. So it would be advisible to test the video card for compatibility before installation. Or simply choose vesa mode installation. The screen resolution may be set later under configuration agfter installation. Hope malay will be able to see his first ? linux after all.
so friends, I am not a geek. And I am new to linux. But I tried to share my own experiences and how I got around this problem. no offence meant to anybody.
 
Old 12-15-2007, 03:39 PM   #12
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jayaprakash View Post
malayletsrock seems to be a friend of mine. I must hve seen that message a hundred times whenecver I tried to install a different version of linux on any of my ancient systems . ( yes I do have ancient systems starting from a 386 based pc running at 33 Mhz ( now dont laugh or sneer) with 32 Mb ( ther, dont laugh again, you are permitted to guffaw) ram and no onboard video, running through 486, P1, PII, PIII and now a PIV on a 945 mother board with 1 Gb ram. And talking about distros has anybody kept count of their no. I myself have more than a dozen. coming to malay's problem, I think his DVD writer or combo (fedora 7 comes on a DVD)is playing tricks. The message he is getting should probabaly read "kernel panic. Trying to kill initiate.This is either fallowed or precededby a series of hex codes. (hex codes are dangerous. let's leave them to the geeks). and the system message usually appears after acpi initiation( It is acpi advanced configuration and power interface). when the system begins to continuosly load the disk to ram. with a 1 Gb ram it tries to load as much as possible which prolongs the running of the CD. this may cause a drop in the supply rails to the ram powerbus. I would suggest malay to check his SMPS or ram ( trying to remove and reinsert the may also help) Justifying that windows XP or vista runs on the same machine may not carry much weight as windows uses a different installation method. Yes On all those systems I encountered this problem but I could load windows ( 98, 2000, XP) without any problem. Except the very old ones of course).Again suggesting that the system is brand new would also be hallow. even the best boards and SMPSes have their limitations. in the worst cas ( ihope it is not,) there may be a memory hole in his ram. This does happen. Only a full memory check can reveal this.
As for ------ suggestion of trying from a live distro, I fail to understand, how it can be done when the system refuses to initiate . In all probabality he may get the same message. Another method which he can try is to copy the linux to another partition ( only if he has another OS on his system of course)and boot from that partition from his bios. This has worked with win 98 on some of my older systems, but I have not tried it with linux yet. may be I should. Another problem he may encounter is after installation his graphics may not work and he may see a lot of gibberish instead of the login screen. So it would be advisible to test the video card for compatibility before installation. Or simply choose vesa mode installation. The screen resolution may be set later under configuration agfter installation. Hope malay will be able to see his first ? linux after all.
so friends, I am not a geek. And I am new to linux. But I tried to share my own experiences and how I got around this problem. no offence meant to anybody.
sir first of all thanks for your reply
you told that it might be due to smps prob.my smps's fan is not working can this be the cause of prob...cause i think my ram is fine
and sir do give me detail how to boot after copying the linux on hard disk...plzzzz
 
Old 12-15-2007, 04:12 PM   #13
whk
Member
 
Registered: Jun 2005
Posts: 202

Rep: Reputation: 35
BTW, I'm pretty sure you burned .iso
 
Old 12-16-2007, 04:44 AM   #14
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 182

Rep: Reputation: 21
Going back to one of the early posts, you can add boot options to /boot/grub/men.lst if using grub or /etc/lilo.conf if using lilo (see man lilo.conf).

Acpi is a specification for power management, choices are acpi=off or acpi=force.
As for apic, it is Advanced Programmable Interrupt Controller, and has something to do with getting around the limited available IRQs problem and for supporting interrupts on SMP systems (or some such thing); choices are apic=off or lapic=off.

Have you tried a non-FC Live-CD like Knoppix (which I believe has one of the best HW detection mechanism)?
 
Old 12-16-2007, 10:46 AM   #15
malayletsrock
LQ Newbie
 
Registered: Dec 2007
Distribution: fedora core
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by roy_lt_69 View Post
Going back to one of the early posts, you can add boot options to /boot/grub/men.lst if using grub or /etc/lilo.conf if using lilo (see man lilo.conf).

Acpi is a specification for power management, choices are acpi=off or acpi=force.
As for apic, it is Advanced Programmable Interrupt Controller, and has something to do with getting around the limited available IRQs problem and for supporting interrupts on SMP systems (or some such thing); choices are apic=off or lapic=off.

Have you tried a non-FC Live-CD like Knoppix (which I believe has one of the best HW detection mechanism)?
i have even tried Knoppix but it doesnt work

do tell me from where to change acpi options
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration