LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2006, 11:43 PM   #1
pm010537
LQ Newbie
 
Registered: Aug 2006
Posts: 25

Rep: Reputation: 15
Help Me!


I have installed CentOS 4.4 on dell 2850. I have been logged in as root; the prompt was "[root@localhost/]#" . I rebooted the server and the prompt got changed to "[root@kilimanjaro/] #". All I was trying to do was install drivers for one of the serial port and I did access ftp sites for that. so the change of prompt has something to do with that? Is something malicious going on with my dell server?

I am a newbie to LINUX and hence was worried at this unusual change.

All your help is greatly appreciated

Thanks
 
Old 12-12-2006, 11:47 PM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Please help us help you - use better thread subjects.

Without more detail about what you did it's hard to say why this changed. Did you follow some instructions to install these "drivers"? Please describe exactly what you did.
 
Old 12-12-2006, 11:52 PM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Generally on CentOS the word after the "@" sign in the prompt is the host name of the machine. Is the host name supposed to be kilimanjaro? Did you change any network settings or anything like that? Like matthewg42 said, more info on what exactly you did is necessary.
 
Old 12-13-2006, 02:09 AM   #4
pm010537
LQ Newbie
 
Registered: Aug 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Sorry about the confusing subject!

I have been using the machine for last couple of days and it was working fine meaning had the prompt [root@localhost/]. No; I have not changed the name of the machine. I did not do anything else other then trying to install the drivers today; here is a brief description of what I did:

1)drivers are for RocketPort card (RocketPort uPCI) from Comtrol.
2)copied the pkgname.tar.gz to /usr/src from the installation CD
3)untar the file using "tar xzvf pkgname.tar.gz"
4)it created a folder by the name comtrol under /usr/src
5)cd comtrol
6)make clean
7)make
8)after executing make I got errors specific to drivers nothing else.
9)still went ahead and tried installing the drivers by using "make install"
10)was not successful.
11)removed everything using the "rm -r comtrol" and repeated steps 1-10 for for different versions of the driver.

The process that I followed was as per the manual from comtrol.

At one point I noticed that I was not able to get outside of my subnet; I tried to reconfigure the ethernet cards but was not successful so decided to reboot the server; when I issued the command reboot every thing was OK except "irq balance" failed.

It booted up and when I opened the terminal the prompt was changed to [root@kilimanjaro/]. Nothing else seemed to be changed; and this time even the network was up after reconfiguring the card. I again rebooted the server after 15 minutes or so and the prompt was changed back to [root@localhost/]. That is when I felt like something is wrong.

I hope I was able to give more details this time.

Thanks
 
Old 12-13-2006, 06:23 AM   #5
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Quote:
I tried to reconfigure the ethernet cards
This seems a likely suspect to me...
Quote:
... the network was up after reconfiguring the card ...
... after 15 minutes or so and the prompt was changed back ...
Most likely, the reconfiguration caused the prompt to revert back.

Please also post the outputs of:
Code:
hostname
ifconfig
and give the details of your network card configuration/reconfiguration steps.
 
Old 12-13-2006, 07:14 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
also,
cat /etc/hosts
 
Old 12-13-2006, 08:53 PM   #7
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 23, 24, RHL 5.2
Posts: 560

Rep: Reputation: 56
Good advice from both timmeke and chrism01. That will help us to see what is causing the change to your hostname. Another file that could have been written to is in /etc/sysconfig/networking/devices. Chances are you're using ethernet and posting the contents of ifcfg-eth0 will give us some additional information to help.

Here is my guess on what happened. Normally when installing a package from source you need to use the ./configure before performing make. This should have been done between steps 5 and 6. Review the README or INSTALL instructions in the comtrol directory. My guess is that there was an old configuration file present. When you ran the make and make install you picked up the old settings and it rewrote a file with what the configuration file from the package. Chances are we will need to make changes to your system before you can run configure otherwise you will get the same name again.

Bill

Last edited by wmakowski; 12-13-2006 at 08:55 PM.
 
Old 12-14-2006, 12:26 PM   #8
pm010537
LQ Newbie
 
Registered: Aug 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks for the responses!

I did try to do some troubleshoot and with the help of all your repsonses what I observed was it gets the different host name for a DNS server. That is what I am assuming. I have configured DNS entries and it then automatical goes to a DNS search path and gets a different host name from there.

When I cleared that DNS search path it gave me the default localhost. Here are the ifcfg-eth0 details:

DEVICE=eth0
BOOTPROTO=none
BROADCAST=X.X.X.X
HWADDR=00:11:43:30:BE:0E
IPADDR=X.X.X.X
NETMASK=255.255.255.128
NETWORK=X.X.X.X
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=X.X.X.X

Thanks
pm010537
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration