LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-23-2013, 02:42 PM   #1
luisvidal
LQ Newbie
 
Registered: Apr 2008
Location: Miami, USA
Distribution: SLES 10/11
Posts: 5

Rep: Reputation: 0
Unhappy Help: Mail Issue


Having an issue with one of my SLES 10 sp3 servers. I am able to email within the company, but unable to email outside. Already checked with the network team, and no firewall is blocking mail from this data center. I tried emailing to my Gmail account, but never got the emails.

What steps do I need to take to troubleshoot this?
 
Old 04-23-2013, 03:39 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
What do your maillogs say it is doing with the emails? Tail -f your mail log file while attempting to send one to see what is going on. Without that info its kind of hard to tell you where to start.
 
Old 04-24-2013, 11:21 AM   #3
luisvidal
LQ Newbie
 
Registered: Apr 2008
Location: Miami, USA
Distribution: SLES 10/11
Posts: 5

Original Poster
Rep: Reputation: 0
As I said above, email works fine when it is sent within the company, however, here is last few lines from /vat/log/mail when sending outside:

Apr 24 11:50:10 SERVER1 postfix/smtp[28951]: connect to alt1.gmail-smtp-in.l.google.com[173.194.75.26]:25: Connection refused
Apr 24 11:50:10 SERVER1 postfix/smtp[28951]: connect to alt2.gmail-smtp-in.l.google.com[2a00:1450:400c:c00::1b]:25: Network is unreachable
Apr 24 11:50:10 SERVER1 postfix/smtp[28951]: 79DAA84062: to=<my-email@gmail.com>, relay=none, delay=4722, delays=4717/0.03/5.4/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[2a00:1450:400c:c00::1b]:25: Network is unreachable)
Apr 24 12:00:05 SERVER1 postfix/qmgr[6867]: D3C6084060: from=<root@SERVER1.SITE.COMPANY.COM>, size=1538, nrcpt=4 (queue active)
Apr 24 12:00:05 SERVER1 postfix/qmgr[6867]: 0A83084064: from=<root@SERVER1.SITE.COMPANY.COM>, size=1113, nrcpt=4 (queue active)
Apr 24 12:00:05 SERVER1 postfix/qmgr[6867]: 4FDA88406C: from=<root@SERVER1.SITE.COMPANY.COM>, size=6804, nrcpt=4 (queue active)
Apr 24 12:00:05 SERVER1 postfix/smtp[10274]: connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused
Apr 24 12:00:05 SERVER1 postfix/smtp[10276]: connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused
Apr 24 12:00:05 SERVER1 postfix/smtp[10275]: connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused
Apr 24 12:00:06 SERVER1 postfix/smtp[10274]: D3C6084060: to=<vaultcsr@archivecorp.com>, relay=none, delay=17214, delays=17214/0.18/0.13/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:00:06 SERVER1 postfix/smtp[10276]: 4FDA88406C: to=<vaultcsr@archivecorp.com>, relay=none, delay=17214, delays=17214/0.02/0.12/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:00:06 SERVER1 postfix/smtp[10275]: 0A83084064: to=<vaultcsr@archivecorp.com>, relay=none, delay=17214, delays=17214/0.01/0.12/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:00:06 SERVER1 postfix/smtp[10274]: D3C6084060: to=<vaultmain@archivecorp.com>, relay=none, delay=17214, delays=17214/0.18/0.13/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:00:06 SERVER1 postfix/smtp[10275]: 0A83084064: to=<vaultmain@archivecorp.com>, relay=none, delay=17214, delays=17214/0.01/0.12/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:00:06 SERVER1 postfix/smtp[10276]: 4FDA88406C: to=<vaultmain@archivecorp.com>, relay=none, delay=17214, delays=17214/0.02/0.12/0, dsn=4.4.1, status=deferred (connect to mail.archivecorp.com[71.101.204.50]:25: Connection refused)
Apr 24 12:12:48 SERVER1 postfix/pickup[20765]: D230C8406B: uid=0 from=<root>
Apr 24 12:12:48 SERVER1 postfix/cleanup[28521]: D230C8406B: message-id=<20130424161248.D230C8406B@SERVER1.SITE.COMPANY.COM>
Apr 24 12:12:48 SERVER1 postfix/qmgr[6867]: D230C8406B: from=<root@SERVER1.SITE.COMPANY.COM>, size=22758, nrcpt=1 (queue active)
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: connect to gmail-smtp-in.l.google.com[2607:f8b0:4002:c04::1b]:25: Network is unreachable
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: connect to gmail-smtp-in.l.google.com[74.125.140.27]:25: Connection refused
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: connect to alt1.gmail-smtp-in.l.google.com[2607:f8b0:400c:c03::1b]:25: Network is unreachable
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: connect to alt1.gmail-smtp-in.l.google.com[74.125.131.27]:25: Connection refused
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: connect to alt2.gmail-smtp-in.l.google.com[2a00:1450:400c:c05::1a]:25: Network is unreachable
Apr 24 12:12:49 SERVER1 postfix/smtp[28523]: D230C8406B: to=<my-email@gmail.com>, relay=none, delay=1.4, delays=0.38/0.01/0.99/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[2a00:1450:400c:c05::1a]:25: Network is unreachable)
 
Old 04-25-2013, 01:29 PM   #4
luisvidal
LQ Newbie
 
Registered: Apr 2008
Location: Miami, USA
Distribution: SLES 10/11
Posts: 5

Original Poster
Rep: Reputation: 0
Solved the issue. I was missing the mail relay entry in my /etc/postfix/main.cf file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't relay mail: did not issue MAIL/EXPN/VRFY/ETRN JimmyTheSaint Linux - Server 20 12-17-2012 11:00 PM
mail loops back to me (MX problem?) OR did not issue MAIL/EXPN/VRFY/ETRN skc Linux - Server 6 07-09-2011 09:18 PM
mail issue sparkshankar Linux - Server 1 09-01-2009 06:58 AM
Sendmail issue (did not issue MAIL/EXPNVRFY/ETRN ...) Blackout_08 Linux - Server 0 08-08-2007 01:10 PM
Mail Issue sachinh Linux - Software 1 02-23-2005 08:28 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration