LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-24-2002, 12:40 PM   #1
bladewalker
Member
 
Registered: Nov 2002
Location: UK
Distribution: Redhat 8
Posts: 30

Rep: Reputation: 15
Help installing LAMPS


Oh now Im getting p****d off!

I have tried to install LAMPS now 23 times...:'(

I install Linux Redhat 8 without a problem
I install mySQL and set it up, test it all works fine
Then I install SSL using OpenSSL and ModSSL
Woohoo still working
Then PHP, either PHP doesn't work with mySQL commands or most recently I have the following message in Netscape trying to get to my test page test.php

-----------------
You have chosen to download a file of type: application/x-httpd-php from http://localhost/

What should Mozilla do with this file?
Open etc...
-----------------

WTF should Mozilla do - I tell you you **$%^& piece of "^% you should open it and let me read the damn file

Am I right in thinking that this is a configuration problem with PHP or is it Apache, does anyone know af a simple rpm file I can install to do the lot coz I am begining to hate Linux with a vicious passion
 
Old 11-24-2002, 01:29 PM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Well, in your apache conf file httpd.conf you should have
LoadModule php4_module libexec/libphp4.so
and
AddType application/x-httpd-php .php
in appropriate sections, the second is going into mod_mime.c section the first one into DSO (dynamic shared object) section if it apache was compiled with DSO enabled (by default it is)
 
Old 11-24-2002, 06:55 PM   #3
bladewalker
Member
 
Registered: Nov 2002
Location: UK
Distribution: Redhat 8
Posts: 30

Original Poster
Rep: Reputation: 15
Hrm

Ok I tried adding te line to my conf file now it says:


[root@irongate apache_1.3.27]# /usr/local/apache/bin/apachectl start
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: cannot open shared object file: No such file or directory
/usr/local/apache/bin/apachectl start: httpd could not be started

when i try to start my server - does this mean that PHP was not installed correctly?
SSL and mysql seem to be working fine its just php that doesnt want to work

Last edited by bladewalker; 11-24-2002 at 06:56 PM.
 
Old 11-24-2002, 11:53 PM   #4
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
That was a while when I used RH, I prefer compiling everything from source, but I still believe there is a package called mod_php or something along these lines what it does it installs precompiled libs with apache in mind, I assume you are installing from rpm otherwise shame on you for not reading README and INSTALL files if you do install PHP and Apache from tarballs
Here is the link for mod_php http://www.rpmfind.net/linux/rpm2htm...&system=&arch=
 
Old 11-25-2002, 03:14 AM   #5
bladewalker
Member
 
Registered: Nov 2002
Location: UK
Distribution: Redhat 8
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks for all help - success

Woohoo finally I did it - I ended up using a package called Apachetoolbox.

I was using the tarbulls (not sure if that was correct) and doing the installs/configs manually was using readme files but was having problems think I cracked it with last piece of advice using PHP plugin but didnt specify I wanted to add mod_php - doh!

Thanks for all the help guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LAMPS server c0c0deuz Linux - Software 0 05-07-2003 07:28 PM
Linux Admin/Security/LAMPS/Develop Books jonconley Linux - Newbie 1 04-29-2003 03:28 PM
lamps server $#@!??? c0c0deuz Linux - Newbie 2 03-30-2003 08:36 AM
LAMPS on RH8 c0c0deuz Linux - General 1 03-29-2003 03:47 PM
LAMPS php+ssl radnix Linux - Networking 0 03-21-2003 07:39 PM


All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration