LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help installing dependencies for mysql-workbench on RedHat 5 Desktop (http://www.linuxquestions.org/questions/linux-newbie-8/help-installing-dependencies-for-mysql-workbench-on-redhat-5-desktop-819833/)

asaint 07-14-2010 03:34 PM

help installing dependencies for mysql-workbench on RedHat 5 Desktop
 
I'm very new to all this so I apologize for being captain obvious with any of my questions.

I'm trying to install mysql-workbench on RedHat 5 Desktop - this is what I was given, didn't pick it.

I found an appropriate RPM that I downloaded from the MySQL site, but it's asking for several dependencies that I don't know how to track down.


Here's the error message I get:

Code:

]# rpm -ivh /home/confluence/Desktop/mysql-workbench-oss-5.1.18a-1fc11.x86_64.rpm
error: Failed dependencies:
        libatkmm-1.6.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libcairomm-1.0.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libcrypto.so.8()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libgdkmm-2.4.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libgio-2.0.so.0()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libgiomm-2.4.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libglibmm-2.4.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libgtkmm-2.4.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        liblua-5.1.so()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libmysqlclient_r.so.16()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libpangomm-1.4.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libsigc-2.0.so.0()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libssl.so.8()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libstdc++.so.6(GLIBCXX_3.4.10)(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64
        libzip.so.1()(64bit) is needed by mysql-workbench-oss-5.1.18-1fc11.x86_64

I tried using yum to retrieve some of the dependencies and in some cases it says they are already installed:

Code:

[root@localhost ~]# yum install glibc
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Package glibc-2.5-49.el5_5.2.x86_64 already installed and latest version
Package glibc-2.5-49.el5_5.2.i686 already installed and latest version
Nothing to do

The packages that aren't installed, I'm just not sure what aI should be looking for to install them.

Has anyone else had this problem? If so, how EXACTLY would you suggest I fix this? By exactly I mean, the dependency you are missing is part of the following package, type yum install "packagename" to fix this.

Something like that would be super helpful.
Thanks in advance.

John VV 07-14-2010 05:15 PM

on RHEL DO NOT USE rpm unless you MUST

rpm is not recommended!!!
use " yum "
call red hat and buy a license
install the RHN repo -- from red hat
then use yum it install mysql.

#####################
in yum do a search
Code:

yum search mysql

also
Quote:

mysql-workbench-oss-5.1.18a-1fc11.x86_64.rpm
that IS NOT a red hat rpm it is a old and DEAD fedora 11 rpm( fedora 11 is no longer supported-- hence DEAD )

you can NOT install fedora 11 rpms on RHEL 5.?
some ( very few) fedora 6 rpms can be installed BUT NOT mysql

gsomin 10-14-2010 12:45 PM

Sorry, could you clarify where exactly to get those dependencies for RHEL5?

TB0ne 10-14-2010 01:25 PM

Quote:

Originally Posted by gsomin (Post 4127454)
Sorry, could you clarify where exactly to get those dependencies for RHEL5?

From the RedHat network, which you pay for access to with your RHEL subscription.

John VV 10-14-2010 02:18 PM

Quote:

Sorry, could you clarify where exactly to get those dependencies for RHEL5?
red hat enterprise linux IS NOT FREE
you NEED to buy a license for it !
This license gets you software updates, security fixes , and the ability to install software .
It also gets you tech support !

FuRoSh 10-20-2010 01:16 AM

Quote:

red hat enterprise linux IS NOT FREE
you NEED to buy a license for it !
I don't think this person asked if it was free or not,.

Quote:

[root@localhost ~]# yum install glibc
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Package glibc-2.5-49.el5_5.2.x86_64 already installed and latest version
Package glibc-2.5-49.el5_5.2.i686 already installed and latest version
Nothing to do
From looking at this, I think he has used YUM, and is already registered since he didn't receive the famous: Please run rhn_register.

It is true you shouldn't use the fc6 rpm package you downloaded on rhel5. I have been trying to rpmbuild mysql-workbench-gpl-5.2.29-1el6.src.rpm but i'm having tons of dependency problems that I have already installed and even compiled to try to install this but still not there yet.

ax8l 10-20-2010 02:01 AM

Download the mysql workbench binaries from here http://dev.mysql.com/downloads/mirror.php?id=395386
After you try to install it from that package come back and post the errors (if you have).
Good Luck

TB0ne 10-20-2010 07:29 AM

Quote:

Originally Posted by ax8l (Post 4133210)
Download the mysql workbench binaries from here http://dev.mysql.com/downloads/mirror.php?id=395386
After you try to install it from that package come back and post the errors (if you have).
Good Luck

He did...that was his first post.

ax8l 10-21-2010 07:50 AM

One more thing, are you sure that you have a 64 bit architecture ?

Quote:

Originally Posted by TB0ne (Post 4133447)
He did...that was his first post.

The link I gave him is for the updated redhat binaries...

asaint 10-22-2010 12:14 AM

Sorry for not responding sooner, but thanks LQ for the help. I was in a bit of a rush and ended up loading workbench on a different machine (non-RedHat) and then connecting to the dbhost from there. For the record, as someone else pointed out, I purchased a subscription, confirm that I did have the 64bit architecture as the box has 8GB RAM. At this point, it's a non-issue for me, but I appreciate the input. If anyone else figures it out, I'd love to hear though.

Thanks,
Adam

zaken5000 04-14-2012 07:40 AM

Quote:

Originally Posted by gsomin (Post 4127454)
Sorry, could you clarify where exactly to get those dependencies for RHEL5?

You have to get a license for it !
This license becomes anyone computer software changes, stability repairs , and also the capability to deploy application .
Additionally, it becomes anyone technical support !

TB0ne 04-14-2012 04:04 PM

Quote:

Originally Posted by zaken5000 (Post 4652478)
You have to get a license for it !
This license becomes anyone computer software changes, stability repairs , and also the capability to deploy application .
Additionally, it becomes anyone technical support !

No idea what you're trying to say here, but this thread has been closed for TWO YEARS now....


All times are GMT -5. The time now is 04:54 AM.