LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2015, 12:41 PM   #31
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled

You do not need to build a new kernel, you barely need to modify one driver. Just make sure you install kernel sources that match exactly the version of kernel you are running. This is important!
And yes, every time there is a kernel upgrade you need to repeat fixing the module for you. Unless they include it in the kernel officially, it is not in 4.2.3 yet.
 
Old 10-28-2015, 04:37 PM   #32
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Alright, you need to cd into your kernel sources directory, usually /usr/src/linux. While there use your editor to edit drivers/usb/misc/sisusbvga/sisusb.c. At the very bottom of this file is this (yours may differ a bit):
Code:
static const struct usb_device_id sisusb_table[] = {
        { USB_DEVICE(0x0711, 0x0550) },
        { USB_DEVICE(0x0711, 0x0900) },
        { USB_DEVICE(0x0711, 0x0901) },
        { USB_DEVICE(0x0711, 0x0902) },
        { USB_DEVICE(0x0711, 0x0903) },
        { USB_DEVICE(0x0711, 0x0918) },
        { USB_DEVICE(0x0711, 0x0920) },
        { USB_DEVICE(0x0711, 0x0950) },
        { USB_DEVICE(0x0711, 0x5100) },
        { USB_DEVICE(0x0711, 0x5200) },
        { USB_DEVICE(0x182d, 0x021c) },
        { USB_DEVICE(0x182d, 0x0269) },
        { }
};
You need to add the line in red.

Save and exit your editor, next run make modules followed by make modules_install.

Done. If you are lucky it will work. No guarantees.
 
1 members found this post helpful.
Old 10-28-2015, 05:47 PM   #33
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Emerson View Post
Alright, you need to cd into your kernel sources directory, usually /usr/src/linux. While there use your editor to edit drivers/usb/misc/sisusbvga/sisusb.c. At the very bottom of this file is this (yours may differ a bit):
Code:
static const struct usb_device_id sisusb_table[] = {
        { USB_DEVICE(0x0711, 0x0550) },
        { USB_DEVICE(0x0711, 0x0900) },
        { USB_DEVICE(0x0711, 0x0901) },
        { USB_DEVICE(0x0711, 0x0902) },
        { USB_DEVICE(0x0711, 0x0903) },
        { USB_DEVICE(0x0711, 0x0918) },
        { USB_DEVICE(0x0711, 0x0920) },
        { USB_DEVICE(0x0711, 0x0950) },
        { USB_DEVICE(0x0711, 0x5100) },
        { USB_DEVICE(0x0711, 0x5200) },
        { USB_DEVICE(0x182d, 0x021c) },
        { USB_DEVICE(0x182d, 0x0269) },
        { }
};
You need to add the line in red.

Save and exit your editor, next run make modules followed by make modules_install.

Done. If you are lucky it will work. No guarantees.
Okay, I think I may be able to do it, but I couldn't get off the ground. Here's what I did:

Code:
gregg@LG:~/Desktop$ cd usr/src/linux
bash: cd: usr/src/linux: No such file or directory
gregg@LG:~/Desktop$ cd usr/src/linux
bash: cd: usr/src/linux: No such file or directory
gregg@LG:~/Desktop$ cd/usr/src/linux
bash: cd/usr/src/linux: No such file or directory
gregg@LG:~/Desktop$ cd /usr/src/linux
bash: cd: /usr/src/linux: No such file or directory
gregg@LG:~/Desktop$
See, I don't usually do much in the terminal. And I know there's a Nano editor in the terminal somewhere but I don't really know how to access it or use it. So if I can get to that point of insertion, I just hit the Enter key on the previous line and insert { USB_DEVICE(0x0711, 0x5100) }, ? If I could get to that point I could do that and then run the two commands.

Maybe you could give me step-by-step (sorry) instructions to get to that point (including how to access and use the editor--I have used it once, but it was years ago)?
 
Old 10-28-2015, 06:55 PM   #34
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Do
Code:
ls -l /usr/src/
to see where your source is.
 
Old 10-28-2015, 11:36 PM   #35
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Emerson View Post
Do
Code:
ls -l /usr/src/
to see where your source is.
Okay. Ran it. What's next?

Code:
gregg@LG:~/Desktop$ ls -l /usr/src/
total 72
drwxr-xr-x 24 root root 4096 May  5 12:43 linux-headers-3.19.0-16
drwxr-xr-x  7 root root 4096 May  5 12:43 linux-headers-3.19.0-16-generic
drwxr-xr-x 24 root root 4096 May 23 14:50 linux-headers-3.19.0-18
drwxr-xr-x  7 root root 4096 May 23 14:51 linux-headers-3.19.0-18-generic
drwxr-xr-x 24 root root 4096 Jun 11 03:57 linux-headers-3.19.0-20
drwxr-xr-x  7 root root 4096 Jun 11 03:57 linux-headers-3.19.0-20-generic
drwxr-xr-x 24 root root 4096 Jun 20 14:30 linux-headers-3.19.0-21
drwxr-xr-x  7 root root 4096 Jun 20 14:30 linux-headers-3.19.0-21-generic
drwxr-xr-x 24 root root 4096 Jul 27 23:54 linux-headers-3.19.0-25
drwxr-xr-x  7 root root 4096 Jul 27 23:54 linux-headers-3.19.0-25-generic
drwxr-xr-x 24 root root 4096 Aug 17 23:01 linux-headers-3.19.0-26
drwxr-xr-x  7 root root 4096 Aug 17 23:01 linux-headers-3.19.0-26-generic
drwxr-xr-x 24 root root 4096 Sep  9 23:32 linux-headers-3.19.0-28
drwxr-xr-x  7 root root 4096 Sep  9 23:32 linux-headers-3.19.0-28-generic
drwxr-xr-x 24 root root 4096 Oct  6 02:10 linux-headers-3.19.0-30
drwxr-xr-x  7 root root 4096 Oct  6 02:11 linux-headers-3.19.0-30-generic
drwxr-xr-x 24 root root 4096 Oct 21 20:42 linux-headers-3.19.0-31
drwxr-xr-x  7 root root 4096 Oct 21 20:42 linux-headers-3.19.0-31-generic
gregg@LG:~/Desktop$
 
Old 10-28-2015, 11:38 PM   #36
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
I do not see kernel sources installed. You must install kernel sources and GCC to proceed.
 
Old 10-29-2015, 12:39 PM   #37
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Emerson View Post
I do not see kernel sources installed. You must install kernel sources and GCC to proceed.
Thanks Emerson.

I'm Googling around trying to figure out how to do this stuff but not finding much. (And I'm pretty concerned about screwing things up by running the wrong commands.)

Eg. on installing GCC.

Do I just run:

Code:
sudo apt-get install gcc
?

And I could find nothing on how to install kernel sources. Building a kernel, yes, but not installing kernel sources.

Step-by-step (omitting not the slightest step) instructions would probably be the best way for my newbieness to get this done.
 
Old 10-29-2015, 12:55 PM   #38
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
You had a good link in post #30.
 
Old 10-29-2015, 01:18 PM   #39
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Copied from Build Your Own Kernel.
Code:
sudo apt-get build-dep linux-image-$(uname -r)
 
Old 10-29-2015, 05:01 PM   #40
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Emerson View Post
Copied from Build Your Own Kernel.
Code:
sudo apt-get build-dep linux-image-$(uname -r)
Okay. Ran it. Now what?
Code:
gregg@LG:~/Desktop$ sudo apt-get build-dep linux-image-$(uname -r)
[sudo] password for gregg: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'linux' as source package instead of 'linux-image-3.19.0-31-generic'
The following NEW packages will be installed:
  asciidoc autoconf automake autotools-dev debhelper dh-apparmor dh-systemd
  docbook-dsssl docbook-utils jadetex kernel-wedge libaudit-dev libdw-dev
  libdw1 libelf-dev libexpat1-dev libiberty-dev libnewt-dev libosp5
  libostyle1c2 libpci-dev libpng12-dev libpotrace0 libptexenc1 libpython-dev
  libpython2.7-dev libsgmls-perl libslang2-dev libsp1c2 libsynctex1 libtool
  libudev-dev libunwind-dev libunwind8 libunwind8-dev libzzip-0-13 lynx
  lynx-cur makedumpfile openjade po-debconf python-dev python2.7-dev sgmlspl
  sharutils sp tex-common texlive-base texlive-binaries
  texlive-fonts-recommended texlive-generic-recommended texlive-latex-base
  texlive-latex-recommended tipa transfig xmlto xsltproc zlib1g-dev
0 upgraded, 58 newly installed, 0 to remove and 1 not upgraded.
Need to get 75.6 MB of archives.
After this operation, 213 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ vivid/main libdw1 amd64 0.160-0ubuntu3 [176 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ vivid-updates/main libexpat1-dev amd64 2.1.0-6ubuntu1.1 [115 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ vivid/main libpython2.7-dev amd64 2.7.9-2ubuntu3 [18.6 MB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ vivid/main libunwind8 amd64 1.1-3.2 [48.4 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ vivid/main libzzip-0-13 amd64 0.13.62-3 [26.1 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ vivid/main asciidoc all 8.6.9-3 [704 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ vivid/main autoconf all 2.69-8 [321 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu/ vivid/main autotools-dev all 20140911.1 [39.6 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ vivid/main automake all 1:1.14.1-3ubuntu1 [510 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ vivid/main po-debconf all 1.0.16+nmu3 [207 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ vivid/main dh-apparmor all 2.9.1-0ubuntu9 [11.1 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ vivid/main debhelper all 9.20150101ubuntu1 [727 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ vivid/main libosp5 amd64 1.5.2-11ubuntu2 [599 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu/ vivid/main libostyle1c2 amd64 1.4devel1-21.1 [595 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu/ vivid/main openjade amd64 1.4devel1-21.1 [239 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu/ vivid/main docbook-dsssl all 1.79-7ubuntu1 [350 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu/ vivid/main tex-common all 5.03 [606 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu/ vivid/main libptexenc1 amd64 2014.20140926.35254-6build1 [33.9 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu/ vivid/main libpotrace0 amd64 1.12-1 [17.8 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu/ vivid/main libsynctex1 amd64 2014.20140926.35254-6build1 [40.8 kB]
Get:21 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-binaries amd64 2014.20140926.35254-6build1 [9,199 kB]
Get:22 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-base all 2014.20141024-2ubuntu1 [17.7 MB]
Get:23 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-latex-base all 2014.20141024-2ubuntu1 [839 kB]
Get:24 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-fonts-recommended all 2014.20141024-2ubuntu1 [5,663 kB]
Get:25 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-latex-recommended all 2014.20141024-2ubuntu1 [7,601 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu/ vivid/main texlive-generic-recommended all 2014.20141024-2ubuntu1 [2,115 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu/ vivid/main tipa all 2:1.3-20 [2,978 kB]
Get:28 http://us.archive.ubuntu.com/ubuntu/ vivid/main jadetex all 3.13-14 [240 kB]
Get:29 http://us.archive.ubuntu.com/ubuntu/ vivid/main lynx-cur amd64 2.8.9dev1-2 [968 kB]
Get:30 http://us.archive.ubuntu.com/ubuntu/ vivid/main lynx all 2.8.9dev1-2 [4,332 B]
Get:31 http://us.archive.ubuntu.com/ubuntu/ vivid/main libsp1c2 amd64 1.3.4-1.2.1-47.3ubuntu1 [1,026 kB]
Get:32 http://us.archive.ubuntu.com/ubuntu/ vivid/main sp amd64 1.3.4-1.2.1-47.3ubuntu1 [124 kB]
Get:33 http://us.archive.ubuntu.com/ubuntu/ vivid/main libsgmls-perl all 1.03ii-33 [24.9 kB]
Get:34 http://us.archive.ubuntu.com/ubuntu/ vivid/main sgmlspl all 1.03ii-33 [6,244 B]
Get:35 http://us.archive.ubuntu.com/ubuntu/ vivid/main docbook-utils all 0.6.14-3ubuntu1 [68.0 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu/ vivid/main kernel-wedge all 2.89ubuntu1 [20.0 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu/ vivid/main libelf-dev amd64 0.160-0ubuntu3 [48.4 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu/ vivid/main libdw-dev amd64 0.160-0ubuntu3 [142 kB]
Get:39 http://us.archive.ubuntu.com/ubuntu/ vivid/main libiberty-dev amd64 20141014-1 [144 kB]
Get:40 http://us.archive.ubuntu.com/ubuntu/ vivid/main zlib1g-dev amd64 1:1.2.8.dfsg-2ubuntu1 [169 kB]
Get:41 http://us.archive.ubuntu.com/ubuntu/ vivid/main libpng12-dev amd64 1.2.51-0ubuntu3 [208 kB]
Get:42 http://us.archive.ubuntu.com/ubuntu/ vivid/main libslang2-dev amd64 2.3.0-2ubuntu1 [383 kB]
Get:43 http://us.archive.ubuntu.com/ubuntu/ vivid/main libnewt-dev amd64 0.52.15-3ubuntu1 [68.9 kB]
Get:44 http://us.archive.ubuntu.com/ubuntu/ vivid/main libpci-dev amd64 1:3.2.1-1ubuntu10 [44.5 kB]
Get:45 http://us.archive.ubuntu.com/ubuntu/ vivid/main libpython-dev amd64 2.7.9-1 [7,836 B]
Get:46 http://us.archive.ubuntu.com/ubuntu/ vivid/main libtool all 2.4.2-1.11 [180 kB]
Get:47 http://us.archive.ubuntu.com/ubuntu/ vivid-updates/main libudev-dev amd64 219-7ubuntu6 [25.0 kB]
Get:48 http://us.archive.ubuntu.com/ubuntu/ vivid/main libunwind-dev amd64 1.1-3.2 [348 kB]
Get:49 http://us.archive.ubuntu.com/ubuntu/ vivid/main libunwind8-dev amd64 1.1-3.2 [2,668 B]
Get:50 http://us.archive.ubuntu.com/ubuntu/ vivid/main makedumpfile amd64 1:1.5.7-5 [131 kB]
Get:51 http://us.archive.ubuntu.com/ubuntu/ vivid/main python2.7-dev amd64 2.7.9-2ubuntu3 [270 kB]
Get:52 http://us.archive.ubuntu.com/ubuntu/ vivid/main python-dev amd64 2.7.9-1 [1,220 B]
Get:53 http://us.archive.ubuntu.com/ubuntu/ vivid/main sharutils amd64 1:4.14-2 [146 kB]
Get:54 http://us.archive.ubuntu.com/ubuntu/ vivid/main transfig amd64 1:3.2.5.e-4 [608 kB]
Get:55 http://us.archive.ubuntu.com/ubuntu/ vivid/main xsltproc amd64 1.1.28-2build2 [13.9 kB]
Get:56 http://us.archive.ubuntu.com/ubuntu/ vivid/main xmlto amd64 0.0.25-2 [30.4 kB]
Get:57 http://us.archive.ubuntu.com/ubuntu/ vivid/main dh-systemd all 1.22ubuntu11 [17.1 kB]
Get:58 http://us.archive.ubuntu.com/ubuntu/ vivid/main libaudit-dev amd64 1:2.3.7-1ubuntu2 [60.5 kB]
Fetched 75.6 MB in 33s (2,228 kB/s)                                            
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package libdw1:amd64.
(Reading database ... 394018 files and directories currently installed.)
Preparing to unpack .../libdw1_0.160-0ubuntu3_amd64.deb ...
Unpacking libdw1:amd64 (0.160-0ubuntu3) ...
Selecting previously unselected package libexpat1-dev:amd64.
Preparing to unpack .../libexpat1-dev_2.1.0-6ubuntu1.1_amd64.deb ...
Unpacking libexpat1-dev:amd64 (2.1.0-6ubuntu1.1) ...
Selecting previously unselected package libpython2.7-dev:amd64.
Preparing to unpack .../libpython2.7-dev_2.7.9-2ubuntu3_amd64.deb ...
Unpacking libpython2.7-dev:amd64 (2.7.9-2ubuntu3) ...
Selecting previously unselected package libunwind8.
Preparing to unpack .../libunwind8_1.1-3.2_amd64.deb ...
Unpacking libunwind8 (1.1-3.2) ...
Selecting previously unselected package libzzip-0-13:amd64.
Preparing to unpack .../libzzip-0-13_0.13.62-3_amd64.deb ...
Unpacking libzzip-0-13:amd64 (0.13.62-3) ...
Selecting previously unselected package asciidoc.
Preparing to unpack .../asciidoc_8.6.9-3_all.deb ...
Unpacking asciidoc (8.6.9-3) ...
Selecting previously unselected package autoconf.
Preparing to unpack .../autoconf_2.69-8_all.deb ...
Unpacking autoconf (2.69-8) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../autotools-dev_20140911.1_all.deb ...
Unpacking autotools-dev (20140911.1) ...
Selecting previously unselected package automake.
Preparing to unpack .../automake_1%3a1.14.1-3ubuntu1_all.deb ...
Unpacking automake (1:1.14.1-3ubuntu1) ...
Selecting previously unselected package po-debconf.
Preparing to unpack .../po-debconf_1.0.16+nmu3_all.deb ...
Unpacking po-debconf (1.0.16+nmu3) ...
Selecting previously unselected package dh-apparmor.
Preparing to unpack .../dh-apparmor_2.9.1-0ubuntu9_all.deb ...
Unpacking dh-apparmor (2.9.1-0ubuntu9) ...
Selecting previously unselected package debhelper.
Preparing to unpack .../debhelper_9.20150101ubuntu1_all.deb ...
Unpacking debhelper (9.20150101ubuntu1) ...
Selecting previously unselected package libosp5.
Preparing to unpack .../libosp5_1.5.2-11ubuntu2_amd64.deb ...
Unpacking libosp5 (1.5.2-11ubuntu2) ...
Selecting previously unselected package libostyle1c2.
Preparing to unpack .../libostyle1c2_1.4devel1-21.1_amd64.deb ...
Unpacking libostyle1c2 (1.4devel1-21.1) ...
Selecting previously unselected package openjade.
Preparing to unpack .../openjade_1.4devel1-21.1_amd64.deb ...
Unpacking openjade (1.4devel1-21.1) ...
Selecting previously unselected package docbook-dsssl.
Preparing to unpack .../docbook-dsssl_1.79-7ubuntu1_all.deb ...
Unpacking docbook-dsssl (1.79-7ubuntu1) ...
Selecting previously unselected package tex-common.
Preparing to unpack .../tex-common_5.03_all.deb ...
Unpacking tex-common (5.03) ...
Selecting previously unselected package libptexenc1.
Preparing to unpack .../libptexenc1_2014.20140926.35254-6build1_amd64.deb ...
Unpacking libptexenc1 (2014.20140926.35254-6build1) ...
Selecting previously unselected package libpotrace0.
Preparing to unpack .../libpotrace0_1.12-1_amd64.deb ...
Unpacking libpotrace0 (1.12-1) ...
Selecting previously unselected package libsynctex1.
Preparing to unpack .../libsynctex1_2014.20140926.35254-6build1_amd64.deb ...
Unpacking libsynctex1 (2014.20140926.35254-6build1) ...
Selecting previously unselected package texlive-binaries.
Preparing to unpack .../texlive-binaries_2014.20140926.35254-6build1_amd64.deb ...
Unpacking texlive-binaries (2014.20140926.35254-6build1) ...
Selecting previously unselected package texlive-base.
Preparing to unpack .../texlive-base_2014.20141024-2ubuntu1_all.deb ...
Unpacking texlive-base (2014.20141024-2ubuntu1) ...
Selecting previously unselected package texlive-latex-base.
Preparing to unpack .../texlive-latex-base_2014.20141024-2ubuntu1_all.deb ...
Unpacking texlive-latex-base (2014.20141024-2ubuntu1) ...
Selecting previously unselected package texlive-fonts-recommended.
Preparing to unpack .../texlive-fonts-recommended_2014.20141024-2ubuntu1_all.deb ...
Unpacking texlive-fonts-recommended (2014.20141024-2ubuntu1) ...
Selecting previously unselected package texlive-latex-recommended.
Preparing to unpack .../texlive-latex-recommended_2014.20141024-2ubuntu1_all.deb ...
Unpacking texlive-latex-recommended (2014.20141024-2ubuntu1) ...
Selecting previously unselected package texlive-generic-recommended.
Preparing to unpack .../texlive-generic-recommended_2014.20141024-2ubuntu1_all.deb ...
Unpacking texlive-generic-recommended (2014.20141024-2ubuntu1) ...
Selecting previously unselected package tipa.
Preparing to unpack .../tipa_2%3a1.3-20_all.deb ...
Unpacking tipa (2:1.3-20) ...
Selecting previously unselected package jadetex.
Preparing to unpack .../jadetex_3.13-14_all.deb ...
Unpacking jadetex (3.13-14) ...
Selecting previously unselected package lynx-cur.
Preparing to unpack .../lynx-cur_2.8.9dev1-2_amd64.deb ...
Unpacking lynx-cur (2.8.9dev1-2) ...
Selecting previously unselected package lynx.
Preparing to unpack .../lynx_2.8.9dev1-2_all.deb ...
Unpacking lynx (2.8.9dev1-2) ...
Selecting previously unselected package libsp1c2.
Preparing to unpack .../libsp1c2_1.3.4-1.2.1-47.3ubuntu1_amd64.deb ...
Unpacking libsp1c2 (1.3.4-1.2.1-47.3ubuntu1) ...
Selecting previously unselected package sp.
Preparing to unpack .../sp_1.3.4-1.2.1-47.3ubuntu1_amd64.deb ...
Unpacking sp (1.3.4-1.2.1-47.3ubuntu1) ...
Selecting previously unselected package libsgmls-perl.
Preparing to unpack .../libsgmls-perl_1.03ii-33_all.deb ...
Unpacking libsgmls-perl (1.03ii-33) ...
Selecting previously unselected package sgmlspl.
Preparing to unpack .../sgmlspl_1.03ii-33_all.deb ...
Unpacking sgmlspl (1.03ii-33) ...
Selecting previously unselected package docbook-utils.
Preparing to unpack .../docbook-utils_0.6.14-3ubuntu1_all.deb ...
Unpacking docbook-utils (0.6.14-3ubuntu1) ...
Selecting previously unselected package kernel-wedge.
Preparing to unpack .../kernel-wedge_2.89ubuntu1_all.deb ...
Unpacking kernel-wedge (2.89ubuntu1) ...
Selecting previously unselected package libelf-dev:amd64.
Preparing to unpack .../libelf-dev_0.160-0ubuntu3_amd64.deb ...
Unpacking libelf-dev:amd64 (0.160-0ubuntu3) ...
Selecting previously unselected package libdw-dev:amd64.
Preparing to unpack .../libdw-dev_0.160-0ubuntu3_amd64.deb ...
Unpacking libdw-dev:amd64 (0.160-0ubuntu3) ...
Selecting previously unselected package libiberty-dev:amd64.
Preparing to unpack .../libiberty-dev_20141014-1_amd64.deb ...
Unpacking libiberty-dev:amd64 (20141014-1) ...
Selecting previously unselected package zlib1g-dev:amd64.
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu1_amd64.deb ...
Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu1) ...
Selecting previously unselected package libpng12-dev:amd64.
Preparing to unpack .../libpng12-dev_1.2.51-0ubuntu3_amd64.deb ...
Unpacking libpng12-dev:amd64 (1.2.51-0ubuntu3) ...
Selecting previously unselected package libslang2-dev:amd64.
Preparing to unpack .../libslang2-dev_2.3.0-2ubuntu1_amd64.deb ...
Unpacking libslang2-dev:amd64 (2.3.0-2ubuntu1) ...
Selecting previously unselected package libnewt-dev:amd64.
Preparing to unpack .../libnewt-dev_0.52.15-3ubuntu1_amd64.deb ...
Unpacking libnewt-dev:amd64 (0.52.15-3ubuntu1) ...
Selecting previously unselected package libpci-dev.
Preparing to unpack .../libpci-dev_1%3a3.2.1-1ubuntu10_amd64.deb ...
Unpacking libpci-dev (1:3.2.1-1ubuntu10) ...
Selecting previously unselected package libpython-dev:amd64.
Preparing to unpack .../libpython-dev_2.7.9-1_amd64.deb ...
Unpacking libpython-dev:amd64 (2.7.9-1) ...
Selecting previously unselected package libtool.
Preparing to unpack .../libtool_2.4.2-1.11_all.deb ...
Unpacking libtool (2.4.2-1.11) ...
Selecting previously unselected package libudev-dev:amd64.
Preparing to unpack .../libudev-dev_219-7ubuntu6_amd64.deb ...
Unpacking libudev-dev:amd64 (219-7ubuntu6) ...
Selecting previously unselected package libunwind-dev.
Preparing to unpack .../libunwind-dev_1.1-3.2_amd64.deb ...
Unpacking libunwind-dev (1.1-3.2) ...
Selecting previously unselected package libunwind8-dev.
Preparing to unpack .../libunwind8-dev_1.1-3.2_amd64.deb ...
Unpacking libunwind8-dev (1.1-3.2) ...
Selecting previously unselected package makedumpfile.
Preparing to unpack .../makedumpfile_1%3a1.5.7-5_amd64.deb ...
Unpacking makedumpfile (1:1.5.7-5) ...
Selecting previously unselected package python2.7-dev.
Preparing to unpack .../python2.7-dev_2.7.9-2ubuntu3_amd64.deb ...
Unpacking python2.7-dev (2.7.9-2ubuntu3) ...
Selecting previously unselected package python-dev.
Preparing to unpack .../python-dev_2.7.9-1_amd64.deb ...
Unpacking python-dev (2.7.9-1) ...
Selecting previously unselected package sharutils.
Preparing to unpack .../sharutils_1%3a4.14-2_amd64.deb ...
Unpacking sharutils (1:4.14-2) ...
Selecting previously unselected package transfig.
Preparing to unpack .../transfig_1%3a3.2.5.e-4_amd64.deb ...
Unpacking transfig (1:3.2.5.e-4) ...
Selecting previously unselected package xsltproc.
Preparing to unpack .../xsltproc_1.1.28-2build2_amd64.deb ...
Unpacking xsltproc (1.1.28-2build2) ...
Selecting previously unselected package xmlto.
Preparing to unpack .../xmlto_0.0.25-2_amd64.deb ...
Unpacking xmlto (0.0.25-2) ...
Selecting previously unselected package dh-systemd.
Preparing to unpack .../dh-systemd_1.22ubuntu11_all.deb ...
Unpacking dh-systemd (1.22ubuntu11) ...
Selecting previously unselected package libaudit-dev:amd64.
Preparing to unpack .../libaudit-dev_1%3a2.3.7-1ubuntu2_amd64.deb ...
Unpacking libaudit-dev:amd64 (1:2.3.7-1ubuntu2) ...
Processing triggers for doc-base (0.10.6) ...
Processing 11 added doc-base files...
Registering documents with scrollkeeper...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for install-info (5.2.0.dfsg.1-6) ...
Processing triggers for sgml-base (1.26+nmu4ubuntu1) ...
Processing triggers for mime-support (3.58ubuntu1) ...
Processing triggers for fontconfig (2.11.1-0ubuntu6) ...
Setting up libdw1:amd64 (0.160-0ubuntu3) ...
Setting up libexpat1-dev:amd64 (2.1.0-6ubuntu1.1) ...
Setting up libpython2.7-dev:amd64 (2.7.9-2ubuntu3) ...
Setting up libunwind8 (1.1-3.2) ...
Setting up libzzip-0-13:amd64 (0.13.62-3) ...
Setting up asciidoc (8.6.9-3) ...
Setting up autoconf (2.69-8) ...
Setting up autotools-dev (20140911.1) ...
Setting up automake (1:1.14.1-3ubuntu1) ...
update-alternatives: using /usr/bin/automake-1.14 to provide /usr/bin/automake (automake) in auto mode
Setting up po-debconf (1.0.16+nmu3) ...
Setting up dh-apparmor (2.9.1-0ubuntu9) ...
Setting up debhelper (9.20150101ubuntu1) ...
Setting up libosp5 (1.5.2-11ubuntu2) ...
Setting up libostyle1c2 (1.4devel1-21.1) ...
Setting up openjade (1.4devel1-21.1) ...
Setting up tex-common (5.03) ...
Setting up libptexenc1 (2014.20140926.35254-6build1) ...
Setting up libpotrace0 (1.12-1) ...
Setting up libsynctex1 (2014.20140926.35254-6build1) ...
Setting up texlive-binaries (2014.20140926.35254-6build1) ...
update-alternatives: using /usr/bin/xdvi-xaw to provide /usr/bin/xdvi.bin (xdvi.bin) in auto mode
update-alternatives: using /usr/bin/bibtex.original to provide /usr/bin/bibtex (bibtex) in auto mode
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Done.
Building format(s) --refresh.
	This may take some time... done.
Setting up texlive-base (2014.20141024-2ubuntu1) ...
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Done.
/usr/bin/tl-paper: setting paper size for dvips to a4.
/usr/bin/tl-paper: setting paper size for dvipdfmx to a4.
/usr/bin/tl-paper: setting paper size for xdvi to a4.
/usr/bin/tl-paper: setting paper size for pdftex to a4.
/usr/bin/tl-paper: setting paper size for dvipdfmx to letter.
/usr/bin/tl-paper: setting paper size for dvips to letter.
/usr/bin/tl-paper: setting paper size for pdftex to letter.
/usr/bin/tl-paper: setting paper size for xdvi to letter.
Running mktexlsr. This may take some time... done.
Building format(s) --all.
	This may take some time... done.
Setting up lynx-cur (2.8.9dev1-2) ...
update-alternatives: using /usr/bin/lynx to provide /usr/bin/www-browser (www-browser) in auto mode
Setting up lynx (2.8.9dev1-2) ...
Setting up libsp1c2 (1.3.4-1.2.1-47.3ubuntu1) ...
Setting up sp (1.3.4-1.2.1-47.3ubuntu1) ...
Setting up libsgmls-perl (1.03ii-33) ...
Setting up sgmlspl (1.03ii-33) ...
Setting up kernel-wedge (2.89ubuntu1) ...
Setting up libelf-dev:amd64 (0.160-0ubuntu3) ...
Setting up libdw-dev:amd64 (0.160-0ubuntu3) ...
Setting up libiberty-dev:amd64 (20141014-1) ...
Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu1) ...
Setting up libpng12-dev:amd64 (1.2.51-0ubuntu3) ...
Setting up libslang2-dev:amd64 (2.3.0-2ubuntu1) ...
Setting up libnewt-dev:amd64 (0.52.15-3ubuntu1) ...
Setting up libpci-dev (1:3.2.1-1ubuntu10) ...
Setting up libpython-dev:amd64 (2.7.9-1) ...
Setting up libtool (2.4.2-1.11) ...
Setting up libudev-dev:amd64 (219-7ubuntu6) ...
Setting up libunwind-dev (1.1-3.2) ...
Setting up libunwind8-dev (1.1-3.2) ...
Setting up makedumpfile (1:1.5.7-5) ...
Setting up python2.7-dev (2.7.9-2ubuntu3) ...
Setting up python-dev (2.7.9-1) ...
Setting up sharutils (1:4.14-2) ...
Setting up transfig (1:3.2.5.e-4) ...
Setting up xsltproc (1.1.28-2build2) ...
Setting up xmlto (0.0.25-2) ...
Setting up dh-systemd (1.22ubuntu11) ...
Setting up libaudit-dev:amd64 (1:2.3.7-1ubuntu2) ...
Processing triggers for tex-common (5.03) ...
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up texlive-latex-base (2014.20141024-2ubuntu1) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all --cnffile /etc/texmf/fmt.d/10texlive-latex-base.cnf.
	This may take some time... done.
Setting up texlive-fonts-recommended (2014.20141024-2ubuntu1) ...
Setting up texlive-generic-recommended (2014.20141024-2ubuntu1) ...
Processing triggers for tex-common (5.03) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up texlive-latex-recommended (2014.20141024-2ubuntu1) ...
Setting up tipa (2:1.3-20) ...
Processing triggers for sgml-base (1.26+nmu4ubuntu1) ...
Setting up docbook-dsssl (1.79-7ubuntu1) ...
Processing triggers for tex-common (5.03) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up jadetex (3.13-14) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all --cnffile /etc/texmf/fmt.d/40jadetex.cnf.
	This may take some time... done.
Processing triggers for sgml-base (1.26+nmu4ubuntu1) ...
Setting up docbook-utils (0.6.14-3ubuntu1) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...
gregg@LG:~/Desktop$
 
Old 10-29-2015, 06:11 PM   #41
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,324
Blog Entries: 1

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
If you want to build a distro package of the linux kernel.

# apt-get install build-essential devscripts kernel-package

Extract sources from kernel.org, then some configuration and:

$ make-kpkg --root-cmd fakeroot --initrd kernel_image kernel_headers -j3
# dpkg -i ../kernel_stuff*.deb

Paraphrased a little bit. Configuration for me is basically cp /boot/config .config && make oldconfig
But I need a newer kernel because touchpad support is 3.19+ and debians default kernel is 3.16. Plus wifi reasons.
 
1 members found this post helpful.
Old 10-29-2015, 07:21 PM   #42
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
OK I admit I really do not know how to install all that in Buntu and I have no time to study it. Discard my post #39.
 
Old 10-29-2015, 10:03 PM   #43
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Shadow_7 View Post
If you want to build a distro package of the linux kernel.

# apt-get install build-essential devscripts kernel-package

Extract sources from kernel.org, then some configuration and:

$ make-kpkg --root-cmd fakeroot --initrd kernel_image kernel_headers -j3
# dpkg -i ../kernel_stuff*.deb

Paraphrased a little bit. Configuration for me is basically cp /boot/config .config && make oldconfig
But I need a newer kernel because touchpad support is 3.19+ and debians default kernel is 3.16. Plus wifi reasons.
Thanks Shadow. I appreciate all the info but I really think I'm abandoning this effort. (It just seems too complicated.)
 
Old 10-29-2015, 10:06 PM   #44
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,470

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Emerson View Post
OK I admit I really do not know how to install all that in Buntu and I have no time to study it. Discard my post #39.
Okay, Emerson. Thanks for trying. One question though: As you can see I already ran the command in your post #39. Shouldn't I be trying to uninstall the things I installed with that command? (And of course the follow-up question is, How do I uninstall it?)
 
Old 10-29-2015, 10:33 PM   #45
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Leave it for now. I will install Mint in a virtual machine tomorrow and figure out how to install kernel source.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Dual monitor config problem on Xubuntu RayLui20 Linux - Newbie 2 01-30-2014 01:36 PM
Installing Xubuntu and then Linux Mint. Now my Xubuntu is gone! antonius0809 Linux - Laptop and Netbook 5 04-11-2013 05:10 AM
xubuntu 11.10 multi-monitor support? Ringmaster Linux - Newbie 2 04-17-2012 04:39 AM
[SOLVED] How would I set up a dual monitor setup in Xubuntu 11.10? ThatPerson Linux - Hardware 11 12-11-2011 04:39 AM
Xubuntu - monitor image is not centered - UomoApe Ubuntu 1 10-21-2009 12:20 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration