LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2002, 08:23 AM   #1
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Rep: Reputation: 15
Question help... I have 3 CD ROM Drives!


I'm using Mandrake 8.1 standard edition in a dual-boot configuration with Win98...

I have both a master and slave CDROM drive set up on my secondary IDE channel. The master drive is a Ricoh CD-R/RW and the slave drive is a standard CD-ROM unit.
They work perfectly well together in Windows 98 but for some reason Mandrake has set me up with *two* Ricoh drives plus the other CD-ROM drive, thus giving me 3 drives!!

In HardDrake the Ricoh drive is identified as both a SCSI device and an ATAPI/IDE device. I have no SCSI devices or any SCSI host adapter in my PC. The main problem is that the Ricoh CD-R/RW will not work at all but the other CD-ROM drive does work! Perhaps Mandrake is looking for a non-existent SCSI device and is just going round in circles.

I have tried to use HardDrake to modify the settings but there is no obvious way to get rid of the SCSI reference and leave me with just the correct ATAPI/IDE settings for the Ricoh Drive.

How do I set this up correctly?

Happy New Year!
Alan
 
Old 01-01-2002, 08:49 AM   #2
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
that's set up properly. cdrw's use scsi emulation to enable them to work properly. look at /etc/lilo.conf and there will be a line saying hdc=ide-scsi, which is required to use the burner at all.

what do you mean by the cdrw not working? will it not mount on a console? what error messages do you get?
 
Old 01-01-2002, 12:48 PM   #3
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Original Poster
Rep: Reputation: 15
Trevor,

Thanks for your reply. So far I have tried to play an audio CD with the KDE CD player using the Ricoh drive. Nothing happens when the CD is placed in the Ricoh Drive and there is no recognition that there is even a CD in there! But if I put the same CD in the other drive it will play with no problems. I know there is nothing wrong with the Ricoh drive because it works fine in Windows.

I went into HardDrake and got the following settings for the CD drives which may give you a clue....

Vendor : RICOH
Model : CD-R/RW MP7060A on bus 0 id 0
Device : /dev/scd0
Mount Point : /mnt/cdrom
Bus Type : SCSI
File System Type : auto
Options : iocharset=iso8859-1,umask=0,codepage=850,ro,noauto

Vendor : Unknown
Model : RICOH CD-R/RW MP7060A
Device : /dev/hdc
Mount Point : (none specified)
Bus Type : ATAPI/IDE
File System Type : (none specified)
Options : (none specified)

Vendor : Unknown
Model : ATAPI 52x CDROM on bus 1 id 1
Mount Point : /mnt/cdrom2
Device : /dev/hdd
Bus Type : ATAPI/IDE
File System Type : auto
Options : iocharset=iso8859-1,umask=0,codepage=850,ro,noauto

I can't understand why Mandrake references the Ricoh drive as "bus 0 id 0". Surely "bus 0" refers to the primary IDE channel which has both my hard drives on it. Presumably the Ricoh drive should appear as "bus 1 id 0" as it is the master device on the secondary IDE drive?

So far there are no error messages that come up on screen when trying to access the Ricoh drive.

Appreciate any further advice!

Best wishes,
Alan
 
Old 01-01-2002, 01:24 PM   #4
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
i don't use KDE, cos it's pants, so i don't know what's meant to happen with audio cd's... if you put a disk in the driev can you mount it on the command line? if you can then i'm sure all your problems are KDE's problem... Things like auto playing audio cd's aren't really up to scratch on linux yet, but not being stupid.. but if the other one plays cd's ok, then only use that one....

and the bus 0 thing.. that's the pretend scsi bus. it's set up as scsi device 0:0:0, like mine is.
 
Old 01-01-2002, 04:14 PM   #5
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Original Poster
Rep: Reputation: 15
hi Trevor,

I'm not too well up on Linux CLI stuff but after inserting the audio CD in the Ricoh drive I opened a terminal window as a superuser with root access and typed in...

mount /dev/scd0 /mnt/cdrom

it returned the messages...
/dev/scd0 : Input/output error
mount : block device /dev/scd0 is write-protected, mounting read-only

/dev/scd0 : Input/output error
mount : you must specify the filesystem type

I was still unable to access the audio CD.

Am I using the command properly or is there something else I should be doing?

How do I specify a filesystem type?

regards, Alan
 
Old 01-01-2002, 04:19 PM   #6
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
don't use the device name. if you specify just the mountpoint OR the device name then it looks up the entry in /etc/fstab.

mount /mnt/cdrom
 
Old 01-01-2002, 07:11 PM   #7
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Original Poster
Rep: Reputation: 15
I typed in the command as you indicated and got the following results....

mount /mnt/cdrom

response...

/dev/scd0 : Input/output error
mount : you must specify the filesystem type

The interesting thing was that when I applied this command to the working CD drive I got a similar message!

mount /mnt/cdrom2

response...

/dev/hdd : Input/output error
mount : you must specify the filesystem type

Am I making progress?

Alan
 
Old 01-02-2002, 12:54 AM   #8
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
shiatsu, I don't think you can mount an audio cd. Try using a regular cd. Then enter mount /mnt/cdrom2 and see what happens. If that works, then unmount ( umount /mnt/cdrom2 ) and insert the disk into the Ricoh drive and enter mount /mnt/cdrom. If both of them worked, then they have entries in the fstab file.

From the info you gave, it looks like you have only one entry for your Ricoh drive. I believe that you need two. One for the cd-rw part and one for the cdrom part. You have the cd-rw entry so I think you need one for the cdrom part. Try this first. Insert the non audio disk into the Ricoh and enter
mount -t iso9660 /dev/hdc /mnt/cdrom. If it works, then you probably need an entry in the fstab file. Could post a copy of your fstab file?

Last edited by linuxcool; 01-02-2002 at 12:55 AM.
 
Old 01-02-2002, 03:52 AM   #9
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
sorry, i meant to just try a standard cdrom. not an audio cd.

you do not need two entries for the Ricoh drive. your fstab file is fine.
 
Old 01-02-2002, 01:15 PM   #10
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Original Poster
Rep: Reputation: 15
hi guys,

I used the mount /mnt/cdrom command with a data CD in the Ricoh drive and it certainly did something as there were no error messages!

I then typed in the "ls" command thinking this would result in a directory listing for the CD and it did produce what looked like a directory of folders.

So I then typed in the unmount /mnt/cdrom command as suggested but this only resulted in a message that there was no "unmount" command!!

I placed another data CD in the second CD-ROM drive and typed in the mount /mnt/cdrom2 command. This produced exactly the same results as for the Ricoh drive.

Incidentally I tried to eject the data CD manually but in both cases the drive was completely locked and the CD could only be removed after using the shutdown command and leaving Linux!

It seems like I am getting somewhere but have I cracked it?

To linuxcool :

I do have 2 enties for my Ricoh drive in HardDrake. They are....

Vendor : RICOH
Model : CD-R/RW MP7060A on bus 0 id 0
Device : /dev/scd0
Mount Point : /mnt/cdrom
Bus Type : SCSI
File System Type : auto
Options : iocharset=iso8859-1,umask=0,codepage=850,ro,noauto

Vendor : Unknown
Model : RICOH CD-R/RW MP7060A
Device : /dev/hdc
Mount Point : (none specified)
Bus Type : ATAPI/IDE
File System Type : (none specified)
Options : (none specified)

Is that what you were looking for?

I understand that it is possible for a drive to be mounted and unmounted by using the mouse in KDE rather than typing in commands. There are no icons for a cdrom drive on my KDE Desktop. Should there be one (or two) and if so how do I get it/them on the desktop?

Best wishes,
Alan
 
Old 01-02-2002, 10:44 PM   #11
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
bluecadet, I've seen people's fstab files with two entries for one cd-rw drive. One is scsi and the other atapi. I don't know the reason for it.

shiatsu, it looks like you were successful in mounting the Ricoh cd-rw and your other cdrom drive. To unmount, you use the umount command. Note that there is no ' n ' between the ' u ' and ' m '. Common mistake everyone makes at one time or another.

Looking at your HardDrake output, I believe that I can tell you what the two fstab file entries probably look like.

For the cd-rw:
/dev/scd0 /mnt/cdrom auto iocharset=iso8859-1,umask=0,codepage=850,ro,noauto 0 0

Other cdrom:
/dev/hdd /mnt/cdrom2 auto iocharset=iso8859-1,umask=0,codepage=850,ro,noauto 0 0

There is no entry for /dev/hdc ( which is your Ricoh as an atapi). You can add one to your fstab file if you want to. Your fstab file is in the /etc directory. If you want to see your fstab file, just run cat /etc/fstab. This will list it to your screen. The entry would look like this:

/dev/hdc /mnt/cdrom1 auto iocharset=iso8859-1,umask=0,codepage=850,ro,noauto 0 0

You'll have to check to see if the directory cdrom1 exists in the /mnt directory. If it doesn't, just run mkdir /mnt/cdrom1.

As for putting icons on kde's desktop, I know how to do it for an old version of kde that came with caldera edesktop. The version with md 8.1 probably has a better way of doing. Maybe someone will tell you how.

Last edited by linuxcool; 01-02-2002 at 10:46 PM.
 
Old 01-03-2002, 02:58 PM   #12
shiatsu
Member
 
Registered: Jan 2002
Location: U.K.
Distribution: Ubuntu 8.04 / SUSE 11.0
Posts: 50

Original Poster
Rep: Reputation: 15
Thanks - it worked!!

I also found that after setting up an icon for each CD drive on the KDE desktop is was dead easy to mount / unmount the drive, list the contents of a CD and run a file.

Well, much easier than typing in commands from the keyboard!

Thanks again for your help,
Alan
 
Old 01-03-2002, 06:05 PM   #13
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You're welcome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cd rom drives/burners dr_zayus69 Linux - Hardware 3 09-28-2004 06:54 PM
cd-rom and dvd-rom drives won't mount... :-( Ausar Linux - Newbie 12 09-01-2004 02:51 PM
XMMS + Sound + 2 x ROM drives deejayqf Linux - Newbie 5 01-24-2004 02:05 PM
CD-ROM drives not unmounting rehab junkie Debian 8 12-18-2003 03:09 PM
LG CD-ROM drives 74039186 Linux - Hardware 2 10-25-2003 02:17 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration