LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2003, 07:08 PM   #1
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Rep: Reputation: 30
Help I canīt change the resolution!


My resolution is stuck at something like 300X400 and i canīt change it.
Iīve tried damn near everything and Iīm getting fed up. Iīve ....
1) Tried to use Xconfigurator (found out it wasnīt installed on my comp.)
2) Tried redhat-config-xfree86 (didnīt work)
3) Edited /etc/X11/XF86Config (still no)
No matter what I set it to every single time after I reboot no change.
Whatīs wrong with it?
 
Old 06-13-2003, 07:15 PM   #2
nuzzy
Member
 
Registered: Aug 2001
Location: New Hampshire, USA
Distribution: Ubuntu 6.06 LTS
Posts: 204

Rep: Reputation: 31
It's likely that your card can't support the resolution you're trying to set. Try setting your color to 16 bit and then try your preferred resolution. If that doesn't work, try going a little smaller on the resolution.
 
Old 06-14-2003, 02:19 AM   #3
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
But have you tried editing /etc/X11/XF86Config-4? If you are using a reasonably new version of XFree, that is the name of the config file, NOT XF86Config.
 
Old 06-14-2003, 09:10 AM   #4
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
yeh, if you do have the xf86config-4 I would just remove it and then x will boot uses the stuff in xf86config which you said you already configured. Have you tried control-alt and plus or minus on the numpad, this cycles though resolution
 
Old 06-14-2003, 09:15 AM   #5
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
I have no XF86Config-4 file. And Cnrtl + Alt + Num(-)/(+) doesn't work for me. my color is already in 16 bit. Should I go to 15 bit?

Last edited by KptnKrill; 06-14-2003 at 09:16 AM.
 
Old 06-14-2003, 09:25 AM   #6
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
Now I got this from near the last half of my xf86config file
Code:
Section "Screen"
    Identifier "Screen 1"
    Device "* Generic VESA compatible"
    Monitor "My Monitor"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection

    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 32
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    DefaultDepth 24
EndSection
now you see that I have about 5 different resolutions for each depth. What you might want to do is get root permissions and go in and edit the xf86config file and under the 16 bit depth put this in.
Code:
Subsection "Display"
        Depth 16
        Modes "800x600"
    EndSubsection
so in this case in 16 bit it should be forced to go to the "800x600" parameter. Yeh, and also try just 8 bit for a little bit to see if that works with higher resolution because your monitor or graphics card might not be able to do over 300x400 on 16 bit.
Hope this helps,
 
Old 06-14-2003, 09:53 AM   #7
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
Okay I just tried setting the only resolution to 800X600 and Xwindows failed to start and I had to restore the backup file that I had cleverly thought of in advance . Anyways I'm beginning to think that the only resolution that it likes is 640X480. It doesnṫ make much sense to me. Under windows I could have my resolutions at 1400X? and still have 16 million colors. Kinda disappointing
Does anyone else have anymore suggestions? Because I intend to fix this problem even if I have to ask Robert Scheifler himself.
And thanks everyone for the advice thus far.

Last edited by KptnKrill; 06-14-2003 at 10:59 AM.
 
Old 06-14-2003, 11:16 AM   #8
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
Hey all,
I just thought of something. If you notice in the screenshot below when I set my resolution to a desirable resolution a white box forms around a black area and then my desktop. I thinking that if I could get rid of that black area then my screen will be normal. Maybe? Anyone know how this might be acomplished?
Thanks in advance.

http://members.lycos.co.uk/coma0/configd.png
 
Old 06-14-2003, 11:37 AM   #9
nuzzy
Member
 
Registered: Aug 2001
Location: New Hampshire, USA
Distribution: Ubuntu 6.06 LTS
Posts: 204

Rep: Reputation: 31
can you post your display settings from XF86Config? Also, what type of vid card is it?
 
Old 06-14-2003, 11:49 AM   #10
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
No problem.
Graphics Card: IntelŪ 82845G Graphics Controller
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 70.0
VertRefresh 47.0 - 120.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "Intel 845"
Driver "i810"
VendorName "Intel 845"
BoardName "Intel 845"
VideoRam 32768
EndSection

Section "Screen"
Identifier "Screen0"
Device "Intel 845"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 06-14-2003, 11:55 AM   #11
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
wow, if I wasn't already confused enough, thanks for the screenshot . Can you move you mouse to the edge of the screen and the screen moves?
 
Old 06-14-2003, 12:03 PM   #12
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
No the screen doesnṫ scroll. Should it?
 
Old 06-14-2003, 12:22 PM   #13
nuzzy
Member
 
Registered: Aug 2001
Location: New Hampshire, USA
Distribution: Ubuntu 6.06 LTS
Posts: 204

Rep: Reputation: 31
hmm...did you see if you can config your brand of monitor? It looks like a generic monitor setup. Also, see if you can change the line

Modes "640x480"

to

Modes "1024x768"

If that doesn't work you can try and download Intel's video driver for your card:

http://downloadfinder.intel.com/scri...ux*&submit=Go!


Oh yeah..did you try:

modprobe -l \* | grep i830.o ? I found it in the README:

ftp://aiedownload.intel.com/df-suppo...ENG/readme.txt

Last edited by nuzzy; 06-14-2003 at 12:27 PM.
 
Old 06-14-2003, 01:00 PM   #14
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
still no. I think that I'm going to report this to the people over at xfree86. This should definitely not be happening. But thanks everyone who contributed.
 
Old 07-14-2003, 09:00 AM   #15
PiscisBos
LQ Newbie
 
Registered: Jul 2003
Distribution: Gentoo
Posts: 12

Rep: Reputation: 0
5 posts

Sorry, but i need to post 5 posts b4 i can paste my config files that i guess look suspiciously like url's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Text Resolution, Graphic resolution. Change from prompt dlublink SUSE / openSUSE 2 01-28-2005 11:50 AM
Can't change my resolution! Nolem SUSE / openSUSE 4 12-23-2004 07:45 AM
change resolution abs Slackware 8 03-11-2004 07:44 PM
change resolution Longinus Linux - Newbie 4 12-13-2003 02:11 PM
how to change resolution ? black Linux - Newbie 14 11-27-2003 11:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration