LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2002, 09:58 PM   #1
Red Guy
Member
 
Registered: May 2002
Location: Tampico, Tamaulipas, México
Distribution: Mandrake 9.0
Posts: 38

Rep: Reputation: 15
Unhappy Help!!, I can't connect to Internet


I have this problem, when I try to connect to Internet show me the next message:

Error: Couldn't find interface ppp0

I checked in the /dev directory and I not founded any file with this name, only a file named ppp

How can I to fix this problem???
 
Old 07-24-2002, 07:17 AM   #2
rverlander
Member
 
Registered: May 2002
Distribution: A few
Posts: 488

Rep: Reputation: 30
ppp0 is not a hard drive.

It should be tty01
 
Old 07-24-2002, 07:26 AM   #3
sarin
Member
 
Registered: May 2001
Location: India, Kerala, Thrissur
Distribution: FC 7-10
Posts: 354
Blog Entries: 2

Rep: Reputation: 34
What is the exact command that produces this error? Can you post o/p of ifconfig.
--Sarin
(And I think the inode that you will be interested in will be ttyS0 ).
 
Old 07-24-2002, 10:02 AM   #4
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Reinstall would be eaisest if you changed hardware. Did you go through the Internet wizard?
 
Old 07-24-2002, 11:41 PM   #5
Red Guy
Member
 
Registered: May 2002
Location: Tampico, Tamaulipas, México
Distribution: Mandrake 9.0
Posts: 38

Original Poster
Rep: Reputation: 15
Unhappy

when I write ifconfig the ppp0 interface not show in the list, I reinstalled the ppp program and its the same, makes the connectíon, but I can't receive or send anything.

Please help!!!

Last edited by Red Guy; 07-24-2002 at 11:44 PM.
 
Old 07-26-2002, 08:40 AM   #6
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
Mandrake tiene un menu especial para configurar el modem que estas utilisando. Hazlo que escanee todos los puertos de ttyxx, pero como dijo rverlander, debe de ser tty01. Que tipo de modem tienes? a que compañia te estas conectando? telmex?(espero que no). buena suerte.

zLinuxz
 
Old 07-27-2002, 01:37 AM   #7
Red Guy
Member
 
Registered: May 2002
Location: Tampico, Tamaulipas, México
Distribution: Mandrake 9.0
Posts: 38

Original Poster
Rep: Reputation: 15
Que bien!! alguien que habla español, lo que sucede es lo siguiente, tengo un modem interno Conexant SoftK56 (HSF), le instalé los drivers, y sí me lo detecta, de hecho crea un dispositivo extra que se llama /dev/cnxnt0, ya he hecho pruebas de comunicación y todo funciona perfecto, el problema está al querer hacer la conexión, según veo hace el marcado pero al teclear el ifconfig no me aparece la conexión ppp0 entre las conexiones activas, ya lo he intentado mediante los frontends kppp, gnome-ppp y por la forma manual de crear unos archivos y por ninguna forma me permite navegar en Internet, de hecho me bajé una nueva versión del demonio pppd, pero me sigue marcando el mismo problema.

He intentado con cuentas de diferentes ISP (incluyendo Prodigy) y con ninguna me permite conectarme

Ojalá y puedan ayudarme

PD. Tengo a Avantel como ISP

Last edited by Red Guy; 07-27-2002 at 01:40 AM.
 
Old 07-29-2002, 01:19 PM   #8
Red Guy
Member
 
Registered: May 2002
Location: Tampico, Tamaulipas, México
Distribution: Mandrake 9.0
Posts: 38

Original Poster
Rep: Reputation: 15
This is my log file, I tried in manual form but I can't connect, what is the mistake???, pppd never create the ppp0 interfase

---------------------------------------------------------------------

Jul 29 12:59:07 javh kernel: -=-=-=-=- DbgScr compiled on Aug 28 2001 16:11:13 -=-=-=-=-
Jul 29 12:59:07 javh kernel: DbgScr: not active
Jul 29 12:59:07 javh kernel: DbgScr: loaded.
Jul 29 12:59:07 javh kernel: -=-=-=-=- osspecific compiled on Aug 28 2001 16:10:39 -=-=-=-=-
Jul 29 12:59:07 javh kernel: -=-=-=-=- fsks compiled on Aug 23 2001 16:46:47 -=-=-=-=-
Jul 29 12:59:07 javh kernel: fsks: loaded.
Jul 29 12:59:07 javh kernel: -=-=-=-=- tones compiled on Aug 23 2001 16:46:36 -=-=-=-=-
Jul 29 12:59:07 javh kernel: tones: loaded.
Jul 29 12:59:08 javh kernel: -=-=-=-=- v90 compiled on Aug 23 2001 16:44:49 -=-=-=-=-
Jul 29 12:59:08 javh kernel: v90: loaded.
Jul 29 12:59:08 javh kernel: -=-=-=-=- Fbks compiled on Aug 23 2001 16:47:03 -=-=-=-=-
Jul 29 12:59:08 javh kernel: Fbks: loaded.
Jul 29 12:59:08 javh kernel: Test: device manager init_module!!
Jul 29 12:59:08 javh kernel: serial init_module
Jul 29 12:59:08 javh kernel: compiled on Aug 28 2001 16:11:17
Jul 29 12:59:08 javh kernel: MemMgr_Init:: set InitFlag to TRUE
Jul 29 12:59:08 javh kernel: my_file 0xca900860
Jul 29 12:59:08 javh kernel: my_file->f_op->llseek 0x0
Jul 29 12:59:08 javh kernel: my_file->f_op->read 0xc0122df8
Jul 29 12:59:08 javh kernel: my_file->f_pos is 0
Jul 29 12:59:08 javh kernel: NumOfCodes 37
Jul 29 12:59:08 javh kernel: my_file->f_pos is 4
Jul 29 12:59:08 javh kernel: Total Offset 22671
Jul 29 12:59:08 javh kernel: my_file->f_pos is 8
Jul 29 12:59:08 javh kernel: MemMgrAllocWrap:: allocating new BaseLLHeapAddr 1
Jul 29 12:59:08 javh kernel: MemMgrAllocWrap:: LLNodeNum = 513.
Jul 29 12:59:08 javh kernel: LinuxGetHwPciRes 0x2013 0x14f1
Jul 29 12:59:08 javh kernel: LINUXRES:::: before pci_set_master
Jul 29 12:59:08 javh kernel: Found device !!!
Jul 29 12:59:08 javh kernel: Hardware base addr 0 : 0xf4100000
Jul 29 12:59:08 javh kernel: Hardware base addr 1 : 0x3400
Jul 29 12:59:08 javh kernel: Hardware interrupt line 0x3
Jul 29 12:59:08 javh kernel: LinuxSetGlobalISRFunc - pFunc = 0xd0ec9080
Jul 29 12:59:08 javh kernel: SIGNALMGR::::::: SIGNAL_CONTROL_SWAP_SAMPLES 0
Jul 29 12:59:41 javh kernel: PPP generic driver version 2.4.1
Jul 29 12:59:41 javh pppd[1304]: pppd 2.4.0 started by root, uid 0
Jul 29 12:59:41 javh kernel: cnxt serial: rs_open
Jul 29 12:59:41 javh kernel: cnxt serial: figure_IRQ_timeout, irq=0
Jul 29 12:59:41 javh kernel: figure_IRQ_timeout, IRQ_timeout[0]=1
Jul 29 12:59:42 javh kernel: cnxt serial: rs_open
Jul 29 12:59:42 javh kernel: cnxt serial: startup error, info->flags & ASYNC_INITIALIZED cf9e2880
Jul 29 12:59:42 javh kernel: cnxt serial: rs_close
Jul 29 12:59:42 javh kernel: cnxt serial: run all th etasts before closing...
Jul 29 12:59:42 javh kernel: rs_close /dev/cnxt0, count=2 (tty->count=2)
Jul 29 12:59:42 javh kernel: before DEC-2
Jul 29 12:59:42 javh kernel: cnxt serial: rs_open
Jul 29 12:59:42 javh kernel: cnxt serial: startup error, info->flags & ASYNC_INITIALIZED cf9e2880
Jul 29 12:59:42 javh kernel: cnxt serial: rs_close
Jul 29 12:59:42 javh kernel: cnxt serial: run all th etasts before closing...
Jul 29 12:59:42 javh kernel: rs_close /dev/cnxt0, count=2 (tty->count=2)
Jul 29 12:59:42 javh kernel: before DEC-2
Jul 29 12:59:42 javh chat[1306]: send (atdt2411200^M)
Jul 29 12:59:42 javh chat[1306]: expect (CONNECT)
Jul 29 12:59:42 javh kernel: ********* DEVMGR_SET_CALL_MODE **********
Jul 29 12:59:42 javh kernel: LinuxScrWakeup =======================
Jul 29 12:59:55 javh kernel: MemMgrAllocWrap:: allocating new BaseLLHeapAddr 2
Jul 29 12:59:55 javh kernel: MemMgrAllocWrap:: LLNodeNum = 1025.
Jul 29 13:00:00 javh CROND[1308]: (root) CMD ( /sbin/rmmod -as)
Jul 29 13:00:14 javh chat[1306]: atdt2411200^M^M
Jul 29 13:00:14 javh chat[1306]: CONNECT
Jul 29 13:00:14 javh chat[1306]: -- got it
Jul 29 13:00:14 javh chat[1306]: send (^M)
Jul 29 13:00:14 javh pppd[1304]: Serial connection established.
Jul 29 13:01:00 javh CROND[1332]: (root) CMD (run-parts /etc/cron.hourly)
Jul 29 13:01:00 javh su(pam_unix)[1336]: session opened for user news by (uid=0)
Jul 29 13:01:01 javh su(pam_unix)[1336]: session closed for user news
---------------------------------------------------------------

Help me please!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 12:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 06:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 07:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 07:58 PM
Can't connect to Internet Galphar Linux - Newbie 13 08-24-2003 03:14 PM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration