LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-28-2006, 08:45 PM   #1
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Rep: Reputation: 30
Help.. I am stuck...NO GUI login


MEPIS 3.4_3

New installation. All went well; I choose to install using VESA settings, because the earlier install (normal) gave booted into a CL login.

This time around I could get into the GUI, and tried to set my screen res ib OS center, I chose the DELL 1280 screen;
now I cant get a GUI login,

$startx

gives
Fatal error message; VESA(0): No matching modes
Screen(s) found, but none have usable configuration

I am in desparate need to get this resolution sorted out.

I am reading around this topic in these forums, but I need a baby step guide to get res sorted out.

I beleive it has to do with editing the Xfree86-4 file. Can some one help me thru this process

I appreciate this a lot!
 
Old 01-28-2006, 09:43 PM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
Try running XF86Config as root. It should prompt for your mouse, keyboard, and monitor resolution and refresh rates. You should then have a useable monitor configuaration, so you can startx.

--Ian
 
Old 01-28-2006, 10:03 PM   #3
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Thanks, BTW how do I run this as root. it command not found.

U cant inagine what hell I have gone thru. I have reinstalled this like 3 times already. What I noticed it that when I go to OS center and chhose a display type (Dell, 1024-), and reboot, it freaking shuts me out; startx give a fatal error.

Mepis KDe has what I need, it seems to be just right; now this. I sound a bit frantic.sorry. I have even tried booting using boot options to ask xres to use 800x600 at least can get in there and reset my display; but even this does not work.

Man is this hard.

This is what I am reading:
http://forums.fedoraforum.org/archiv...p/t-22526.html

http://www.cs.cornell.edu/~scs49/ins...#destHeader108

I realize that this is not related to mepis, but i could not finda stepbystep one for dell 700m on mepis.

Thanks,

I hope this scan be resolved.
 
Old 01-29-2006, 03:51 AM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
I am not familiar with Mepis, but any instructions on setting up X should work. I may have got the command name wrong, have a look in /usr/X11R6/bin and do a ls to see whats there. It should be called xf86config, or something like that.

Make sure that you have the refresh rate and resolutions for your monitor. It sounds to me that X is trying to start with a refresh rate and/or resolution that your monitor doesn't support.

I take it that X is trying to start automatically when you boot up. As root, edit /etc/inittab, and find the line
Code:
id:5:initdefault:
Change the 5 to a 3, and reboot. This should stop X starting automatically, and you can change it back when X is working properly.

I hope this helps
--Ian
 
Old 01-29-2006, 03:56 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Are you sure that MEPIS is using XFree86 and not X.org? If it is using X.org, then try "xorgcfg" as root (without quotes of course).
 
Old 01-29-2006, 08:59 AM   #6
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by IBall
I am not familiar with Mepis, but any instructions on setting up X should work. I may have got the command name wrong, have a look in /usr/X11R6/bin and do a ls to see whats there. It should be called xf86config, or something like that.

Make sure that you have the refresh rate and resolutions for your monitor. It sounds to me that X is trying to start with a refresh rate and/or resolution that your monitor doesn't support.

I take it that X is trying to start automatically when you boot up. As root, edit /etc/inittab, and find the line
Code:
id:5:initdefault:
Change the 5 to a 3, and reboot. This should stop X starting automatically, and you can change it back when X is working properly.

I hope this helps
--Ian
IBALL

Thnks for the the help. I an very green behind the ears; I tried your suggestion, but could not get to do what u asked: edit the initab file using CL (syntax error). This may sould really rediculous: I reinstalled MEPIS, and am living with a suboptimal resolution (1024x800). I can now login using GUI. So now I am in, and here is what my initab file looks like:

# Default runlevel. The runlevels used by Mandrake Linux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:
So does this mean that MEPIS uses X11 as a default login pathway?

Now that I am in, I am scared to even select in OS center, the Brand and Model, just in case I get into trouble.

How do I get my screen resoultion to be what is it is supposed to be?
 
Old 01-29-2006, 09:05 AM   #7
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Nylex
Are you sure that MEPIS is using XFree86 and not X.org? If it is using X.org, then try "xorgcfg" as root (without quotes of course).
Nylex,

In my previous post to IBALL, I put the initab options. I am not sure whether MEPIS is using X.orf or XFree86.

But when I start Konsole with su, and insert
Code:
#xorgcfg
this is what I get:
Code:
root@1[linuser]# xorgcfg
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  833
  Current serial number in output stream:  837
I am not familiar with the manner in which to go about rectifying the resolutin problem, so I rely on your suggstions, thanks,

SL
 
Old 01-29-2006, 11:08 AM   #8
caspervn
Member
 
Registered: Jul 2005
Location: Vietnam
Distribution: Fedora Core 2
Posts: 55

Rep: Reputation: 15
@smiley_lauf: Would you view your log file of X
 
Old 01-29-2006, 12:40 PM   #9
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Unhappy

Quote:
Originally Posted by caspervn
@smiley_lauf: Would you view your log file of X
Code:
Section "ServerLayout"
  Identifier "XFree86 Configured"
  Screen 0 "Screen0" 0 0
 #Screen 0 "ATIScreen" 0 0
  InputDevice "Keyboard0" "CoreKeyboard"
  InputDevice "PS/2 Mouse" "CorePointer"
 #InputDevice "USB Mouse" "CorePointer"
 #InputDevice "Touchpad" "CorePointer"
 #InputDevice "Stylus" "CorePointer"
 #InputDevice "Eraser" "CorePointer"
 #InputDevice "Cursor" "CorePointer"
 #InputDevice "Serial Mouse" "CorePointer"
EndSection

Section "ServerFlags"
  Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
  RgbPath "/usr/X11R6/lib/X11/rgb"
  ModulePath "/usr/X11R6/lib/modules"
# True type and type1 fonts

    FontPath 	"/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath 	"/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath 	"/usr/X11R6/lib/X11/fonts/PEX"
    FontPath 	"/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath 	"/usr/share/fonts/truetype/ttf-xfree86-nonfree"
    FontPath 	"/usr/share/fonts/truetype/java"
    FontPath 	"/usr/share/fonts/truetype/arphic"
    FontPath 	"/usr/share/fonts/truetype/freefont"
    FontPath 	"/usr/share/fonts/truetype/openoffice"
    FontPath 	"/usr/share/fonts/truetype/ttf-bitstream-vera"
    FontPath 	"/usr/share/fonts/ttf/western"
    FontPath 	"/usr/share/fonts/ttf/decoratives"
    FontPath 	"/usr/share/fonts/type1/gsfonts"
    FontPath 	"/usr/X11R6/lib/X11/fonts/Type1"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma/CID"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    FontPath 	"/usr/local/share/fonts"
    FontPath 	"/usr/share/fonts"
    FontPath 	"/usr/X11R6/lib/X11/fonts"
    FontPath 	"/usr/share/fonts/afms"
    FontPath 	"/usr/share/fonts/bitmap"
    FontPath 	"/usr/share/fonts/truetype"
    FontPath 	"/usr/share/fonts/ttf"
    FontPath 	"/usr/share/fonts/type1"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma"
EndSection

Section "Module"
  Load "GLcore"
  Load "bitmap"
  Load "dbe"
  Load "ddc"
  Load "dri"
  Load "extmod"
  Load "freetype"
  Load "glx"
  Load "int10"
  Load "record"
  Load "speedo"
  Load "type1"
  Load "vbe"
  Load "synaptics"
EndSection

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "keyboard"
  Option "CoreKeyboard"
  Option "XkbModel" "pc105"
  Option "XkbLayout" "us"
  Option "XKbOptions" ""
EndSection

Section "InputDevice"
  Identifier "Serial Mouse"
  Driver "mouse"
  Option  "Protocol" "Microsoft"
  Option  "Device" "/dev/ttyS0"
  Option  "Emulate3Buttons" "false"
  Option  "Emulate3Timeout" "70"
EndSection

Section "InputDevice"
 Identifier "Touchpad"
 Driver "synaptics"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "LeftEdge" "1700"
 Option "RightEdge" "5300"
 Option "TopEdge" "1700"
 Option "BottomEdge" "4200"
 Option "FingerLow" "25"
 Option "FingerHigh" "30"
 Option "MaxTapTime" "180"
 Option "MaxTapMove" "220"
 Option "VertScrollDelta" "100"
 Option "MinSpeed" "0.06"
 Option "MaxSpeed" "0.12"
 Option "AccelFactor" "0.0010"
 Option "SHMConfig" "on"
 Option "Repeater" "/dev/input/mice"
EndSection

Section "InputDevice"
  Identifier "PS/2 Mouse"
  Driver "mouse"
  Option "Protocol" "auto"
  Option "Device" "/dev/psaux"
  Option "Emulate3Buttons" "false"
  Option "Emulate3Timeout" "70"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "USB Mouse"
  Driver "mouse"
  Option "Device" "/dev/input/mice"
  Option "Protocol" "ExplorerPS/2"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "Stylus"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "stylus"
  Option "Device" "/dev/input/wacom"
Endsection

# Settings for wacom eraser
Section "InputDevice"
  Identifier "Eraser"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "eraser"
  Option "Device" "/dev/input/wacom"
Endsection
# Settings for wacom cursor (mouse)
Section "InputDevice"
  Identifier "Cursor"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "cursor"
  Option "Device" "/dev/input/wacom"
Endsection

Section "Monitor"
  Identifier "Monitor0"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 82.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
  Modeline "640x480"     25.175 640  664  760  800   480  491  493  525 #60Hz
  Modeline "800x600"     40.12  800  848  968 1056   600  601  605  628 #60Hz
  Modeline "1024x768"    75    1024 1048 1184 1328   768  771  777  806 -hsync -vsync
  Modeline "1024x768"    85    1024 1056 1152 1360   768  784  787  823
  ModeLine "1152x864"    65    1152 1168 1384 1480   864  865  875  985 Interlace
  Modeline "1152x864"    92    1152 1208 1368 1474   864  865  875  895
  Modeline "1152x864"   110    1152 1240 1324 1552   864  864  876  908
  Modeline "1152x864"   135    1152 1464 1592 1776   864  864  876  908
  Modeline "1152x864"   137.65 1152 1184 1312 1536   864  866  885  902 -HSync -VSync
  Modeline "1280x768"    80.14 1280 1344 1480 1680   768  769  772  795
  ModeLine "1280x800"    80.58 1280 1344 1480 1680   800  801  804  827 -HSync -VSync
  Modeline "1280x1024"   80    1280 1296 1512 1568  1024 1025 1037 1165 Interlace
  Modeline "1280x1024"  110    1280 1328 1512 1712  1024 1025 1028 1054
  Modeline "1280x1024"  126.5  1280 1312 1472 1696  1024 1032 1040 1068 -HSync -VSync
  Modeline "1280x1024"  135    1280 1312 1456 1712  1024 1027 1030 1064
  Modeline "1280x1024"  135    1280 1312 1416 1664  1024 1027 1030 1064
  Modeline "1280x1024"  157.5  1280 1344 1504 1728  1024 1025 1028 1072 +HSync +VSync
  Modeline "1280x1024"  181.75 1280 1312 1440 1696  1024 1031 1046 1072 -HSync -VSync
  Modeline "1440x900"   106.47 1440 1520 1672 1904   900  901  904  932 +HSync +VSync
  Modeline "1400x1050"  129    1400 1464 1656 1960  1050 1051 1054 1100 +HSync +VSync
  Modeline "1600x1200"  162    1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  189    1600 1664 1856 2160  1200 1201 1204 1250 -HSync -VSync
  Modeline "1600x1200"  202.5  1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  220    1600 1616 1808 2080  1200 1204 1207 1244 +HSync +VSync
  Modeline "1680x1050"  147.14 1680 1784 1968 2256  1050 1051 1054 1087
  ModeLine "1800x1440"  230    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  ModeLine "1800x1440"  250    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  Modeline "1920x1200"  230    1920 1936 2096 2528  1200 1201 1204 1250 +HSync +VSync
EndSection

Section "Monitor"
  Identifier  "ATIMonitor"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 82.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
EndSection

Section "Device"
  Identifier  "Card0"
  Driver "i810"
  BoardName "unknown"
  
 #BusID  "PCI:1:0:0"
 #Option "sw_cursor" # needed for some ati cards
 #Option "hw_cursor"
 #Option "NoAccel"
 #Option "ShowCache"
 #Option "ShadowFB"
 #Option "UseFBDev"
 #Option "Rotate"
 #Option "NoUseBios" # needed for some Savage cards
  Option "UseInternalAGPGART" "no"
  
# nvidia special options, use with care
  Option "CursorShadow" "1"
  Option "CursorShadowAlpha" "63"
  Option "CursorShadowYOffset" "2"
  Option "CursorShadowXOffset" "4"
  Option "FlatPanelProperties" "Scaling = native"
  Option "NoLogo" "false"
  Option "IgnoreEdid" "true" # needs to be true for some nvidia cards
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  DefaultColorDepth 16
  
  SubSection "Display"
  Depth 8
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 15
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 16
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 24
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 32
  Modes "1280x800"
  EndSubSection
  
  # Only the official NVIDIA driver supports twinview
  # these setting are an example
  Option "TwinView" "false"
  Option "SecondMonitorVendorName" "unknown"
  Option "SecondMonitorModelName" "unknown"
  Option "SecondMonitorHorizSync" "30-82"
  Option "SecondMonitorVertRefresh" "50-75"
  Option "MetaModes" "1024x768, 1024x768"
  Option "TwinViewOrientation" "RightOf"
  Option "ConnectedMonitor" "dfp,dfp"
EndSection

Section "Screen"
  Identifier "ATIScreen"
  Device "Card0"
  Monitor "ATIMonitor"
  DefaultColorDepth 24
  
  SubSection "Display"
  Depth 24
  Modes "1280x800"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection
This is my xorg.conf file

I am really lost now!
 
Old 01-29-2006, 01:14 PM   #10
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Solved

Quote:
Originally Posted by smiley_lauf
Code:
Section "ServerLayout"
  Identifier "XFree86 Configured"
  Screen 0 "Screen0" 0 0
 #Screen 0 "ATIScreen" 0 0
  InputDevice "Keyboard0" "CoreKeyboard"
  InputDevice "PS/2 Mouse" "CorePointer"
 #InputDevice "USB Mouse" "CorePointer"
 #InputDevice "Touchpad" "CorePointer"
 #InputDevice "Stylus" "CorePointer"
 #InputDevice "Eraser" "CorePointer"
 #InputDevice "Cursor" "CorePointer"
 #InputDevice "Serial Mouse" "CorePointer"
EndSection

Section "ServerFlags"
  Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
  RgbPath "/usr/X11R6/lib/X11/rgb"
  ModulePath "/usr/X11R6/lib/modules"
# True type and type1 fonts

    FontPath 	"/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath 	"/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath 	"/usr/X11R6/lib/X11/fonts/PEX"
    FontPath 	"/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath 	"/usr/share/fonts/truetype/ttf-xfree86-nonfree"
    FontPath 	"/usr/share/fonts/truetype/java"
    FontPath 	"/usr/share/fonts/truetype/arphic"
    FontPath 	"/usr/share/fonts/truetype/freefont"
    FontPath 	"/usr/share/fonts/truetype/openoffice"
    FontPath 	"/usr/share/fonts/truetype/ttf-bitstream-vera"
    FontPath 	"/usr/share/fonts/ttf/western"
    FontPath 	"/usr/share/fonts/ttf/decoratives"
    FontPath 	"/usr/share/fonts/type1/gsfonts"
    FontPath 	"/usr/X11R6/lib/X11/fonts/Type1"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma/CID"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    FontPath 	"/usr/local/share/fonts"
    FontPath 	"/usr/share/fonts"
    FontPath 	"/usr/X11R6/lib/X11/fonts"
    FontPath 	"/usr/share/fonts/afms"
    FontPath 	"/usr/share/fonts/bitmap"
    FontPath 	"/usr/share/fonts/truetype"
    FontPath 	"/usr/share/fonts/ttf"
    FontPath 	"/usr/share/fonts/type1"
    FontPath 	"/usr/X11R6/lib/X11/fonts/defoma"
EndSection

Section "Module"
  Load "GLcore"
  Load "bitmap"
  Load "dbe"
  Load "ddc"
  Load "dri"
  Load "extmod"
  Load "freetype"
  Load "glx"
  Load "int10"
  Load "record"
  Load "speedo"
  Load "type1"
  Load "vbe"
  Load "synaptics"
EndSection

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "keyboard"
  Option "CoreKeyboard"
  Option "XkbModel" "pc105"
  Option "XkbLayout" "us"
  Option "XKbOptions" ""
EndSection

Section "InputDevice"
  Identifier "Serial Mouse"
  Driver "mouse"
  Option  "Protocol" "Microsoft"
  Option  "Device" "/dev/ttyS0"
  Option  "Emulate3Buttons" "false"
  Option  "Emulate3Timeout" "70"
EndSection

Section "InputDevice"
 Identifier "Touchpad"
 Driver "synaptics"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "LeftEdge" "1700"
 Option "RightEdge" "5300"
 Option "TopEdge" "1700"
 Option "BottomEdge" "4200"
 Option "FingerLow" "25"
 Option "FingerHigh" "30"
 Option "MaxTapTime" "180"
 Option "MaxTapMove" "220"
 Option "VertScrollDelta" "100"
 Option "MinSpeed" "0.06"
 Option "MaxSpeed" "0.12"
 Option "AccelFactor" "0.0010"
 Option "SHMConfig" "on"
 Option "Repeater" "/dev/input/mice"
EndSection

Section "InputDevice"
  Identifier "PS/2 Mouse"
  Driver "mouse"
  Option "Protocol" "auto"
  Option "Device" "/dev/psaux"
  Option "Emulate3Buttons" "false"
  Option "Emulate3Timeout" "70"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "USB Mouse"
  Driver "mouse"
  Option "Device" "/dev/input/mice"
  Option "Protocol" "ExplorerPS/2"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "Stylus"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "stylus"
  Option "Device" "/dev/input/wacom"
Endsection

# Settings for wacom eraser
Section "InputDevice"
  Identifier "Eraser"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "eraser"
  Option "Device" "/dev/input/wacom"
Endsection
# Settings for wacom cursor (mouse)
Section "InputDevice"
  Identifier "Cursor"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "cursor"
  Option "Device" "/dev/input/wacom"
Endsection

Section "Monitor"
  Identifier "Monitor0"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 82.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
  Modeline "640x480"     25.175 640  664  760  800   480  491  493  525 #60Hz
  Modeline "800x600"     40.12  800  848  968 1056   600  601  605  628 #60Hz
  Modeline "1024x768"    75    1024 1048 1184 1328   768  771  777  806 -hsync -vsync
  Modeline "1024x768"    85    1024 1056 1152 1360   768  784  787  823
  ModeLine "1152x864"    65    1152 1168 1384 1480   864  865  875  985 Interlace
  Modeline "1152x864"    92    1152 1208 1368 1474   864  865  875  895
  Modeline "1152x864"   110    1152 1240 1324 1552   864  864  876  908
  Modeline "1152x864"   135    1152 1464 1592 1776   864  864  876  908
  Modeline "1152x864"   137.65 1152 1184 1312 1536   864  866  885  902 -HSync -VSync
  Modeline "1280x768"    80.14 1280 1344 1480 1680   768  769  772  795
  ModeLine "1280x800"    80.58 1280 1344 1480 1680   800  801  804  827 -HSync -VSync
  Modeline "1280x1024"   80    1280 1296 1512 1568  1024 1025 1037 1165 Interlace
  Modeline "1280x1024"  110    1280 1328 1512 1712  1024 1025 1028 1054
  Modeline "1280x1024"  126.5  1280 1312 1472 1696  1024 1032 1040 1068 -HSync -VSync
  Modeline "1280x1024"  135    1280 1312 1456 1712  1024 1027 1030 1064
  Modeline "1280x1024"  135    1280 1312 1416 1664  1024 1027 1030 1064
  Modeline "1280x1024"  157.5  1280 1344 1504 1728  1024 1025 1028 1072 +HSync +VSync
  Modeline "1280x1024"  181.75 1280 1312 1440 1696  1024 1031 1046 1072 -HSync -VSync
  Modeline "1440x900"   106.47 1440 1520 1672 1904   900  901  904  932 +HSync +VSync
  Modeline "1400x1050"  129    1400 1464 1656 1960  1050 1051 1054 1100 +HSync +VSync
  Modeline "1600x1200"  162    1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  189    1600 1664 1856 2160  1200 1201 1204 1250 -HSync -VSync
  Modeline "1600x1200"  202.5  1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  220    1600 1616 1808 2080  1200 1204 1207 1244 +HSync +VSync
  Modeline "1680x1050"  147.14 1680 1784 1968 2256  1050 1051 1054 1087
  ModeLine "1800x1440"  230    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  ModeLine "1800x1440"  250    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  Modeline "1920x1200"  230    1920 1936 2096 2528  1200 1201 1204 1250 +HSync +VSync
EndSection

Section "Monitor"
  Identifier  "ATIMonitor"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 82.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
EndSection

Section "Device"
  Identifier  "Card0"
  Driver "i810"
  BoardName "unknown"
  
 #BusID  "PCI:1:0:0"
 #Option "sw_cursor" # needed for some ati cards
 #Option "hw_cursor"
 #Option "NoAccel"
 #Option "ShowCache"
 #Option "ShadowFB"
 #Option "UseFBDev"
 #Option "Rotate"
 #Option "NoUseBios" # needed for some Savage cards
  Option "UseInternalAGPGART" "no"
  
# nvidia special options, use with care
  Option "CursorShadow" "1"
  Option "CursorShadowAlpha" "63"
  Option "CursorShadowYOffset" "2"
  Option "CursorShadowXOffset" "4"
  Option "FlatPanelProperties" "Scaling = native"
  Option "NoLogo" "false"
  Option "IgnoreEdid" "true" # needs to be true for some nvidia cards
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  DefaultColorDepth 16
  
  SubSection "Display"
  Depth 8
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 15
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 16
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 24
  Modes "1280x800"
  EndSubSection
  SubSection "Display"
  Depth 32
  Modes "1280x800"
  EndSubSection
  
  # Only the official NVIDIA driver supports twinview
  # these setting are an example
  Option "TwinView" "false"
  Option "SecondMonitorVendorName" "unknown"
  Option "SecondMonitorModelName" "unknown"
  Option "SecondMonitorHorizSync" "30-82"
  Option "SecondMonitorVertRefresh" "50-75"
  Option "MetaModes" "1024x768, 1024x768"
  Option "TwinViewOrientation" "RightOf"
  Option "ConnectedMonitor" "dfp,dfp"
EndSection

Section "Screen"
  Identifier "ATIScreen"
  Device "Card0"
  Monitor "ATIMonitor"
  DefaultColorDepth 24
  
  SubSection "Display"
  Depth 24
  Modes "1280x800"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection
This is my xorg.conf file

I am really lost now!

Thanks to this post, I figured out the solution. http://www.mepislovers.org/modules/n...forumpost96150
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck at Basilisk 1.4 login screen dr_zayus69 Linux - Distributions 0 12-17-2005 02:28 AM
Im stuck, with the login thing. sending_to_god Linux - Laptop and Netbook 9 06-28-2004 06:51 PM
Fedora 2 stuck on login hesher Fedora 0 06-04-2004 09:28 AM
stuck at redhat 9 login stanley_shilov Linux - Newbie 6 11-15-2003 03:04 AM
stuck when booting in the GUI niton Linux - Newbie 3 07-30-2002 02:10 AM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration