LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-07-2003, 04:15 AM   #1
mjk
LQ Newbie
 
Registered: Oct 2003
Location: brick, nj
Distribution: red hat 9
Posts: 3

Rep: Reputation: 0
Unhappy help - glib-2.0 not recognized?!


I would really appreciate anyhelp I can get on this....I'm new to linux, obviously as I'm using red hat 9 shrike. I have been trying to update gaim for the past few days and it's saying I don't have gtk+-2.0 or higher installed (which i do, I compiled it myself...no rpm) just to see if anything else was up, I went back to square one and even reinstalled the glib-2.0, however, gaim's config doesn't seem to recognize glib-2.0 and I can't figure out why? I made sure all was good in the pkg config script, and made sure it was in /usr/local/lib/glib-2.0...

I can't figure out for the life of me what the problem is :-\ can anyone help? I'd appreciate it a great deal...I don't want to get frustrated with linux and go back to winXP grr....
 
Old 10-07-2003, 04:20 AM   #2
mjk
LQ Newbie
 
Registered: Oct 2003
Location: brick, nj
Distribution: red hat 9
Posts: 3

Original Poster
Rep: Reputation: 0
btw, this is the error i get...

creating libtool
checking for Win32... no
checking for aclocal flags...
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the pkg-config script: /usr/bin/pkg-config
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
 
Old 10-07-2003, 01:51 PM   #3
mjk
LQ Newbie
 
Registered: Oct 2003
Location: brick, nj
Distribution: red hat 9
Posts: 3

Original Poster
Rep: Reputation: 0
i found the problem...the problem is that i have two versions of glib installed, 1.2.8 and 2.0...i have no idea how to completely cleanly remove 1.2.8, is there a way?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
glib wont be recognized pasalacqua128 Linux - Software 3 06-02-2004 01:25 PM
glib-2.3.3 not recognized by ./configure tektone Linux - Software 1 03-01-2004 05:16 PM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration