LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-09-2005, 07:47 PM   #1
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Rep: Reputation: 0
Help getting Linux to boot....


Ok heres the problem in a nut shell then I will copy the techno bable that my husband wrote up. Ok I instaled it just fine but it will not boot no matter what I try have reinstaled it 5times and still the same problem. This is the indepth stuff.

We are trying to set up the computer to dual boot windows XP and Fedora Core 4 (this combination was recommended by CF). First, we had an existing install of Windows XP on drive C: (hda1). All went well, we installed Fedora Core 4 to the second physical hard drive (it had previously been D in windows, the Linux installer detected it as hdb1). Along the way we chose to use Grub (as per CF's recommendation) and set it to be installed to the MBR of hda1.

Installation finishes properly with no errors, and prompts for a reboot.

Computer reboots to windows XP.

after poring over the net for tutorials the closest thing to a solution I'd found was: (Sorry can't post the link of what my husband found but it was from this site.)


but when I get to the following step it tells me that /dev/fd0 cannot be accessed:

"Type mcopy boot.lnx a:"

sorry I don't have the screen in front of me to get the exact error.

i've got some hunches about ways to get around this but could really use some advice here, any ideas?

So any advise you could give would be great.
 
Old 05-09-2005, 07:54 PM   #2
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I realy hope this is in the right spot. And I realy hope that someone can help. My husband will probely be replying to this latter with my user name.
 
Old 05-09-2005, 08:07 PM   #3
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I even tried no dule boot but that did not work eather.
 
Old 05-09-2005, 08:10 PM   #4
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
ok now I can post the link

http://www.linuxquestions.org/questi...a+4+windows+xp

maby this will help more with what we tried. And it still did not work.
 
Old 05-09-2005, 08:14 PM   #5
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,877

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Ignore. I didn't read far enough into this thread.

Last edited by bigrigdriver; 05-09-2005 at 08:23 PM.
 
Old 05-09-2005, 08:26 PM   #6
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
ack then what do I do. lol
 
Old 05-09-2005, 08:31 PM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,049

Rep: Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915Reputation: 1915
LadyGrelka how about you get rid of the sig ???.
So much crap it's hard to find your posts.

Those instructions seem reasonable.
Do you have an internal floppy drive ???. Or do you use a usb connected one ??.
 
Old 05-09-2005, 08:49 PM   #8
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I have an internal floppy drive but as far as linux is concerned I don't have a floppy.
 
Old 05-09-2005, 09:07 PM   #9
DeathWish
LQ Newbie
 
Registered: May 2005
Distribution: FC3
Posts: 1

Rep: Reputation: 0
Hi everyone, I'm the husband in question here.

the floppy is detected in bios (and windows) as A: but linux isn't seeing it for some reason when linux boots from the rescue CD it has no /dev/fd0 at all. When I try to mount the drive it says that it's missing from /etc/fstab and when I try to add it to fstab it seems to work just fine but isn't actually talking to the floppy at all. (I think it just creates a mount point on the hard drive?)

Anyway, this is all rather beside the point. During linux install we are selecting Grub as the boot manager. It defaults to the MBR of hda1, but some tutorials I found instructed that it be put in /boot/ on hdb1 instead. I've tried it both ways. When installing it to the MBR of hda1 nothing seems to happen. When installing it to /boot/ on hdb1 it at least boots to grub, but doesnt' give any options whatsoever and we cannot boot.

Any ideas? This really should "just work" when installing FC4, according to the documentation. It shouldn't need any of this messing around with windows, or floppies. It should install grub to the hda1 MBR and load up at next boot but it doesn't, and therein lies our real issue.
 
Old 05-09-2005, 10:07 PM   #10
LadyGrelka
LQ Newbie
 
Registered: May 2005
Posts: 20

Original Poster
Rep: Reputation: 0
So this is my question how do I get it working?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a file that Linux writes upon boot that is the EXACT text as the boot screen lostboy Linux - General 21 01-08-2008 03:10 PM
Cannot boot up on Linux, have to boot onto Linux-nonfb after installing nvidia driver /home/kyle Linux - Newbie 6 09-15-2004 12:23 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM
dual boot - XP and Linux - Need to reinstall XP without effecting linux -LILO boot godofmind Linux - General 1 05-05-2004 09:13 AM
Linux Boot Floppy Went Bad on W2K-Linux Dual Boot rzward Linux - General 2 01-15-2003 11:52 AM


All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration