LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2007, 01:01 PM   #1
fedoracjd
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Rep: Reputation: 0
Help get my Network Devices to Activate


I just installed Fedora 5 to my machine. There is a network card built-in, but it shows "inactive." When I attempt to activate it shows: "Determining IP information for eth0...failed."

I'm using a motorola surfboard cable modem to connect. Please help!
 
Old 01-04-2007, 06:19 AM   #2
anant
Member
 
Registered: Nov 2006
Distribution: Sles 10
Posts: 108

Rep: Reputation: 15
I have got the same error with FC6.
Any idea guys.....
 
Old 01-04-2007, 11:42 AM   #3
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
So sorry i am slightly confused are you trying to connect through an ethernet connection or through a cable modem ??
 
Old 01-04-2007, 02:31 PM   #4
fedoracjd
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
I have a network card attached to a cable modem.
 
Old 01-05-2007, 01:02 PM   #5
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
Ok what network card are you using ??
 
Old 01-06-2007, 12:02 PM   #6
fedoracjd
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Sorry if getting the right info is like pulling teeth.
I have 2 ethernet cards installed (mainly in an attempt to troubleshoot). The first is eth0 and is part of the Motherboard. It is a 3Com 3c905c-TX-TX-M Tornado. I set it up DHCP and active on start-up. The second is in an expansion slot and is eth1. It is a Linksys NC 100 Network Everywhere Fast Ethernet 10/100 card. It also is set up DHCP and active. I called comcast (no linux support) and they said I should be DHCP. The cable modem is a Motorola Surfboard SB5100.
 
Old 01-06-2007, 12:39 PM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
What is the output of ifconfig (you may have to be root for this command to work, depends on your distro)?
What happens if you try the following (as root):
ifdown eth0
dhclient eth0
ifconfig

If that doesn't work, try the same for eth1
 
Old 01-06-2007, 12:48 PM   #8
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Rep: Reputation: 15
i was geting the same error before...first delete ur ethernet card tat is detected whch is present in the hardware tab, then add the ethernet card again.. then select ur ethernet card.. then click "edit" button... then insert ur router ip then subnet mask as well as gateway.... now jus save n close... now try activating it..i did dis n got it working finally...
 
Old 01-07-2007, 05:19 AM   #9
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
If its done by dhcp then just type this as root

dhcpcd eth0


or if that dosent work

dhcpcd eth1

(dhcpcd is the most common used dhcp client, replace dhcpcd with the one that your distro uses)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
Network card not working? Cannot activate network device eth0 lifeonitsown Linux - Networking 1 11-17-2005 07:30 AM
switching between/activate network devices snow_bound Mandriva 3 06-04-2005 01:48 AM
Cannot activate network device faqs LinuxQuestions.org Member Intro 1 05-25-2004 04:29 PM
Cannot activate network device... denisec Linux - Networking 5 08-20-2003 10:28 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration