LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-23-2004, 09:40 PM   #1
Jeff_G_1974
LQ Newbie
 
Registered: Feb 2003
Location: Belleville, Ontario, Canada
Distribution: Fedora
Posts: 14

Rep: Reputation: 0
Help....Fedora doesn't like my DSL Connection


Greetings from Canada everyone. Ok, I'm such a newbie that I shouldn't be allowed to use Fedora or any flavour of Linux for that matter. Ok, here's the deal. I have DSL Internet Service with Bell Sympatico here in Ontario. I'm trying to get online and I can't. I followed the Internet Connection instructions in Fedora and I activated the connection. However, I cannot surf, I cannot ping anywhere and I'm not being assigned an IP Address. I've read the Linux for Dummies guide, but it is of no help right now. I'm currently running an AMD Athlon XP 1800+ on an MSI KT4V Ultra Motherboard with an onboard NIC (VIA Rhine II) and my modem is a Speed Stream that is utilized through the NIC. If anyone can help me out, it would be greatly appreciated.
 
Old 02-23-2004, 11:39 PM   #2
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Rep: Reputation: 30
DNS!

Make sure you have the DNS #'s entered
 
Old 02-23-2004, 11:41 PM   #3
SiriusAB
Member
 
Registered: Feb 2003
Location: S_AB
Distribution: FC4; FC3; RH 9.0; XP
Posts: 86

Rep: Reputation: 15
Let us begin

How about the output of:

# lspci -v

and

# ifconfig

Redact any unique self-identifying (self-specific) element, if you like.
 
Old 02-28-2004, 02:14 PM   #4
madliberator
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
Angry Problems here too

I installed fedora (new to linux) and can't get the dsl connection working either. I have:
static RFC 1483 ip
rented actiontec gateway dsl modem
d-link DFE-530TX+ NIC

The connection works in windows. I ran the "internet connection wizard"
I triple checked the DNS. When I try to go to "google.com" in mozilla I get the "cannot resolve host..." message. When I try the "http://192.168.0.1" in my modem installation guide, I get "connection refused when attempting to contact http://..."
During boot it says "bring up interface eth0" and then gives the "ok"
Fedora sees my NIC as "RTL8139 eth0"
I tried the commands above and bash said no such command...
Any ideas?
Thanks...
 
Old 02-28-2004, 04:49 PM   #5
SiriusAB
Member
 
Registered: Feb 2003
Location: S_AB
Distribution: FC4; FC3; RH 9.0; XP
Posts: 86

Rep: Reputation: 15
Did you enter the commands as "root" or as "user"?
 
Old 02-28-2004, 05:45 PM   #6
madliberator
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
I entered them as root...thanks for the reply
 
Old 02-29-2004, 01:42 AM   #7
madliberator
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
Red face newbie

So, I guess i needed the training wheels...
after a little investigating, I discovered fedora wanted the pathname...
#/sbin/ifconfig and
#/sbin/route -v

So, those outputs are...roughly...

#/sbin/ifconfig
eth0 link encap: Ethernet Hwaddr "some numbers"
inet addr: " my IP address" Bcast: "first three groups of my ip plus .255"
UP BROADCAST RUNNING MULTICAST MTU:1500 METRIC 1
RX packets 5268 " 0 for all these columns"
TX packets 867 "0 for all these columns"

lo Link encap: local loopback
inet addr: "not my ip" MAsk: " 255.0.0
UP LOOPBACK RUNNING
...also showing some RX and TX packages with no conflicts...

and...
#/sbin/route -v

Dest Gate Genmask Flags metric ref int
"almost my gateway..." "my netmask" u 0 0 0eth0
"random ip adress?" 255.255.0 u 0 0 0eth0
"random ip..." 255.0.0.0 u
default "my gateway" 000 ug 0 0 lo


I don't know if you can make since of this....
Do I have the right kind of connection settings (RFC 1483 bridged static ip)?
 
Old 02-29-2004, 10:53 AM   #8
Fufinache
LQ Newbie
 
Registered: Nov 2003
Posts: 9

Rep: Reputation: 0
Buy a NAT router. $50 canadian bucks gets you online with any OS and allows you to splice the DSL connection with a bunch of computers.

By the way, I have a sympatico too and you're in the Toronto area check out www.canadacomputers.com or www.factorydirect.ca.
 
Old 02-29-2004, 02:52 PM   #9
madliberator
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
I'd like to try to configure

Thanks for the info about the router. I would like to try to get it working without it, so does anybody have any info that can help? Thanks
 
Old 03-01-2004, 08:57 PM   #10
madliberator
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
Solution

Ok, just in case anybody else has this problem, heres how I solved it with the hardware I'm using (above)

Apparently, when I configured the Actiontec Gateway in Windows (same box) I used the default settings, which set it up for a dynamic ip. Those settings were stored, in the modem so when I went into linux, the Gateway was still acting like it wanted dynamic, so when I put the static settings in, it got confused and wouldn't work.
All I did was go into windows, dialed up the modem, and reentered the settings manually. When I rebooted in linux...well here I am...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DSL connection can't seem to get up jplev22 Linux - Hardware 5 09-12-2004 03:19 PM
Dsl connection defy Linux - General 5 08-08-2004 06:16 PM
DSL, PPPOE, Fedora, have connection but cannot access internet cfiles Linux - Networking 5 02-05-2004 07:46 PM
A little help with T-DSL Connection Gav Linux - Networking 3 01-05-2004 03:58 PM
dsl connection vile_deceit Linux - Newbie 9 07-21-2003 03:35 AM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration