LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2010, 11:42 AM   #1
RunMeDown
LQ Newbie
 
Registered: Nov 2008
Location: East Coast, USA
Distribution: Absolute
Posts: 12

Rep: Reputation: 0
Help Adding Screen Blanking Timeout For Xvesa


Howdy folks,

Aboard TinyCore 2.7 and opting to run without Xorg. I'm needing either a pointer or syntax example. Seems my monitor supports dpms after executing a quick one-two with:

$ xset s blank

$ xset s 150

Yet I'm unsure how it would look placed in Tinys .xsession:

Code:
Xvesa -br -screen 1024x768x32 -shadow -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 &
waitforX
"$DESKTOP" 2>/tmp/wm_errors &
export WM_PID=$!
[ -n "$THEME" ] && cp /opt/jwmThemes/"$THEME" .jwmrc-theme
if [ -n "$BACKGROUND" ]; then
  setbackground image /opt/backgrounds/"$BACKGROUND"
else
  [ -x ./.setbackground ] && ./.setbackground 
fi
[ "$ICONS" == "wbar" ] && /usr/bin/wbar.sh 
[ -x ./.mouse_config ] && ./.mouse_config &
[ $(which flit) ] && flit &
[ $(which watcher) ] && watcher -g +0-0 &

Thanks.
 
Old 01-15-2010, 02:58 PM   #2
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
I would try just adding them to the end of the file following the same structure as the other objects.
xset s blank &
xset s 150
 
Old 01-15-2010, 09:02 PM   #3
RunMeDown
LQ Newbie
 
Registered: Nov 2008
Location: East Coast, USA
Distribution: Absolute
Posts: 12

Original Poster
Rep: Reputation: 0
[SOLVED] Help Adding Screen Blanking Timeout For Xvesa

Hey Affinity, sorry to say it didn't workout. What you did instead was push me into another round of trial and error. Recalling Xvesa's cli options I went with what seemed logical, namely tossing in the v and s switches (screensaver blanking and timeout in minutes respectively). To note, these settings waitforX and wouldn't work placed in rc.local.

Code:
Xvesa -br -screen 1024x768x32 v -s 2 -shadow -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 &
waitforX
Thanks all the same.

Last edited by RunMeDown; 01-17-2010 at 08:01 AM. Reason: Adjust title
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
not screen-blanking in terminal - what sets the idle timeout on monitor for terminal stardotstar Linux - Hardware 2 08-14-2011 06:46 AM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
screen blanking nowonmai Linux - Software 2 08-15-2003 10:44 AM
Screen blanking ? ... phoeniXflame Linux - General 12 07-20-2003 06:41 PM
Screen Blanking bretthoward Linux - General 7 03-19-2001 06:50 AM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration