LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-08-2004, 03:25 PM   #1
stupidclese
LQ Newbie
 
Registered: Aug 2003
Location: Kansas City
Distribution: college linux
Posts: 23

Rep: Reputation: 15
Help a newbie configure sound and cdrom


I recently installed college linux on an old p3 box that was barely moving at all with windows 98. Now it moves with incredible speed with college linux. For some reason it was the only distro that would take. Not even knoppix would boot up! But I digress.
I can't seem to acsess the cdrom drive. When I put a cd in and try to mount a get an error message along the lines of "mount point iso9660 does not exist". Any ideas on how to fix this problem? I currently need root access to mount. Does anybody know how I can change that so I can do it as a regular user.
Also my sound isn't working at all. I can run mp3s and such, but no sound comes out. It recognized the card when I was installing it but now I get nothing at all? I've heard of programs called alsamixer and alsaconfig for slackware, but they don't seem to work on college linux (which is based on slackware). Somebody please help me!
 
Old 01-08-2004, 03:54 PM   #2
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
To make the cdrom mountable by user edit the /etc/fstab file (using nano /etc/fstab or pico /etc/fstab or any other editor) and add user to the 4th column over on the cdrom line....

Ex:
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro,user 0 0

To correct the mount point error.. do

mkdir /mnt/cdrom

Notice /mnt/cdrom matches the second column in the above example.

Sound is usually muted by default after install, you need to run a mixer like alsamixer, but those are not in your system you said, so try gamix or any other mixer program.

Last edited by Zero-0-Effect; 01-08-2004 at 04:47 PM.
 
Old 01-08-2004, 04:41 PM   #3
stupidclese
LQ Newbie
 
Registered: Aug 2003
Location: Kansas City
Distribution: college linux
Posts: 23

Original Poster
Rep: Reputation: 15
cannot create directory

When I try to make the directory, the shell is giving me an error "cannot create directory '/mnt/cdrom': File exists". Should I delete the old directory and then mkdir?
 
Old 01-08-2004, 04:44 PM   #4
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
/mnt/cdrom/ exists already then. Can you post your /etc/fstab file.
 
Old 01-08-2004, 05:15 PM   #5
stupidclese
LQ Newbie
 
Registered: Aug 2003
Location: Kansas City
Distribution: college linux
Posts: 23

Original Poster
Rep: Reputation: 15
okay

Okay I got that working. For some reason the first column was missing /dev/cdrom and I wasn't catching it. Now how do I mount my floppy and CDR drives? As far as mixers where can I find them for college linux.
 
Old 01-08-2004, 05:23 PM   #6
stupidclese
LQ Newbie
 
Registered: Aug 2003
Location: Kansas City
Distribution: college linux
Posts: 23

Original Poster
Rep: Reputation: 15
crazy additional problem

Okay this is wierd and maybe a stupid question now my disk drive won't open. Do I need to do something special to achieve this. Seems like a stupid question but hey, I'm a newbie.
Also is there any good p2p software for linux other than edonkey? Is there a version of emule for linux?
 
Old 01-08-2004, 05:25 PM   #7
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
Ahh..yes that makes since .... mount point iso9660 missing.. cant believe I didnt catch that either... anyway.. go to google and search for mixers for linux and as far as mounting flopoy its just mount /dev/fd0 or mount /dev/floppy depending on how its defined in /etc/fstab - remember to unmount floppys before removing them as that is when it writes to it.

By saying disk drive your referring to the cdrom correct... It has to be unmounted before it can be opened.

Xnap is a multi protocol multi source p2p program - requires java. Do a search through the forums on xnap and java.

Last edited by Zero-0-Effect; 01-08-2004 at 05:29 PM.
 
Old 01-08-2004, 07:02 PM   #8
stupidclese
LQ Newbie
 
Registered: Aug 2003
Location: Kansas City
Distribution: college linux
Posts: 23

Original Poster
Rep: Reputation: 15
almost there

Okay, I almost have everything the way I want it. The onaly problemis, when x starts and I log in as my user name, I can't mount the cdrom drive, and even if I go to root within the shell, I still can't do it. The error message I get is wrong fs type, bad option, bad super block on dev/cdrom/ or too many mounted file systems. However, If when X starts I log in as root I can acess everything. What causes this. My fstab and mtab files seem to be the same whether or not I'm logged in under root. What gives?
 
Old 01-09-2004, 09:08 AM   #9
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
Could you post your fstab file.
 
Old 01-09-2004, 01:51 PM   #10
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Re: almost there

Quote:
Originally posted by stupidclese
Okay, I almost have everything the way I want it. The onaly problemis, when x starts and I log in as my user name, I can't mount the cdrom drive, and even if I go to root within the shell, I still can't do it. The error message I get is wrong fs type, bad option, bad super block on dev/cdrom/ or too many mounted file systems. However, If when X starts I log in as root I can acess everything. What causes this. My fstab and mtab files seem to be the same whether or not I'm logged in under root. What gives?
try opening a terminal and typing:

ls -l /dev/cdrom

This will tell you what your permissions are. If they look like this:

r-xr--r--

then your root only has permission to work with the cdrom. If so, then type:

su -
<enter your root password>

chmod u+x /dev/cdrom

this will allow your user profiles to access as well. Also, what exactly are you typing to mount your cd-rom?

If it's a data cd, then you should be using:

mount -t iso9660 /dev/cdrom

If it's an audio cd, you can't mount it, but the permissions thing above would allow you to play them.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ltsp 4.1 how to configure cdrom and floppy support on ayuki Linux - Hardware 3 11-16-2004 05:59 AM
Linux Newbie --several questions- sound, cdrom, Lan speed, etc. ChaosReigns Linux - Newbie 13 09-06-2004 07:45 PM
gnome toaster locked trying to configure cdrom sirius57 Linux - General 2 08-24-2004 11:29 AM
Newbie Slackware CDROM & Sound Problems SML Slackware 4 02-18-2004 02:18 PM
How do I configure hardware like CDRom drives, sound cards, and modems? lorengd Slackware 2 09-19-2003 09:21 AM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration