LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2003, 10:34 PM   #16
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128

Joe,

I gotta take my girls to lunch now. We're at GMT +0800. Sorry I can't take you further now. You may want to write down that message and go to the Nvidia forum at http://www.nvnews.net/vbulletin/foru...?s=&forumid=14 and look through there and see if you find the answer. And of course, post your question there, also. In another post here on LQ someone mentioned refresh rates. Check that, also, though I doubt that's going to be much trouble if you have a CRT monitor. It is CRT and not LCD, right?

And just to tell you, I'd have to do these things to help you find an answer, as I run Debian and not RedHat, and have only installed one Nvidia driver in my life. Pray that some more experienced LQ guy comes along in the meantime. And by all means, search, search, search. Your problem has probably been addressed and answered already somewhere else. And do try www.google.com/linux while you're out there.

And keep a notebook and write down everything, as it will be invaluable to you later if you have to track down a problem, and also you may be able to help someone else in similar circumstances.

 
Old 10-30-2003, 12:33 AM   #17
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
At command line, login as root. Then issue this command:

xf86config

To edit /etc/X11/XF86Config file use vim, a command line text editor. Type "vi /etc/X11/XF86Config".
 
Old 10-30-2003, 12:36 AM   #18
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
i thought redhat 7+ uses XF86Config-4.
 
Old 10-30-2003, 12:51 AM   #19
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Yeah. You're right. The man page:

============================================

XFree86 uses a configuration file called XF86Config for its initial setup. This configuration file is searched for in the following places when the server is started as a normal user:

/etc/X11/<cmdline>
/usr/X11R6/etc/X11/<cmdline>
/etc/X11/$XF86CONFIG
/usr/X11R6/etc/X11/$XF86CONFIG
/etc/X11/XF86Config-4
/etc/X11/XF86Config
/etc/XF86Config
/usr/X11R6/etc/X11/XF86Config.<hostname>
/usr/X11R6/etc/X11/XF86Config-4
/usr/X11R6/etc/X11/XF86Config
/usr/X11R6/lib/X11/XF86Config.<hostname>
/usr/X11R6/lib/X11/XF86Config-4
/usr/X11R6/lib/X11/XF86Config

==================================

I cannot check the folder since I as using public computer with windows 2000.
 
Old 10-30-2003, 01:23 AM   #20
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by megaspaz
i thought redhat 7+ uses XF86Config-4.
Megaspaz,

Is there any way you can help Joe from here? I know you use RH and can probably take him through it like a cake walk. I'm busy on my Debian system now, and I don't understand the RH terminology. I'd just have to search at the places I marked for him, anyway. And I believe he'd need the correct command to configure X - something about xfreeserver86 but I can't remember right now.

 
Old 10-30-2003, 01:30 AM   #21
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well he's using rh 9 which i've never touched. but i can try. gonna have to start at post 1 though....
 
Old 10-30-2003, 01:40 AM   #22
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well for now he needs to run his XF86config utility which they changed in redhat.

the command is:

redhat-config-xfree86

i'm not sure how this works in 9 though. i can only say what i would do in 7.3.

basically for video card drivers choose vesa. monitor choose your monitor model if available. if not choose a generic monitor. when asked to probe for anything, don't probe. enter in manually the memory and choose the defaults for the rest. when you get to screen resolution and color depth, choose 1024x769 @ color depth of 16. you should be able to see a clean desktop on the test afterwords and be able to log in with gui. i'm not sure if nvidias drivers support your mx card though anymore, so you maybe stuck with unaccelerated graphics. you need to check out nvidia's site and maybe post in their forums to see if your card is still supported. i know my geforce2Go isn't supported anymore. so i'm stuck with an old kernel and old nvidia drivers.

Last edited by megaspaz; 10-30-2003 at 01:42 AM.
 
Old 10-30-2003, 01:59 AM   #23
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by megaspaz
well for now he needs to run his XF86config utility which they changed in redhat.

the command is:

redhat-config-xfree86

i'm not sure how this works in 9 though. i can only say what i would do in 7.3.

basically for video card drivers choose vesa. monitor choose your monitor model if available. if not choose a generic monitor. when asked to probe for anything, don't probe. enter in manually the memory and choose the defaults for the rest. when you get to screen resolution and color depth, choose 1024x769 @ color depth of 16. you should be able to see a clean desktop on the test afterwords and be able to log in with gui. i'm not sure if nvidias drivers support your mx card though anymore, so you maybe stuck with unaccelerated graphics. you need to check out nvidia's site and maybe post in their forums to see if your card is still supported. i know my geforce2Go isn't supported anymore. so i'm stuck with an old kernel and old nvidia drivers.
Hey Dude,

I don't mean to dispute you, but your card is supported by the latest and greatest Nvidia driver - and so his his card. And it installs easy as windblows stuff. I just double checked and Nvidia lists GeForce2 Go 0x0112 - do a cat /proc/pci and see if that isn't your card. If it is, go here http://www.nvidia.com/object/linux_d..._ia32_1.0-4496 and get the new driver.

As for Joe, I assume he's go the card installed correctly. I did a quick search here and Google Linux and no post that I found actually came up with an answer. Some more paths to follow, but no resolution.

He needn't choose vesa because he now has the Nvidia driver. The instructions at their site, if he followed them, would have him change the driver name to nvidia and then add and delete some other stuff. Unless he can't get it done I'm not reading RH instructions because that's not my distro and I'm busy as a one-legged man in a butt kicking contest trying to get my Debian system going on this PC.

Joe, he's on target but you gotta do it yourself cause we're not in front of your monitor. Just run the redhat-config-xfree86 command to reconfigure X, and write down everything it asks and you select. There are other things that can be causing this, but we'll keep on this path for now. And, Joe, did you post in the Nvidia forum and search there? They know more about their driver than do we, and they may understand what is causing this respawn issue.

Thanks megaspaz
 
Old 10-30-2003, 02:08 AM   #24
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well what it says as supported doesn't work for me and my laptop. if you search there forums, they have problems with the geforce2go where you install the drivers and you get nothing but blob of rotating colors. not cool. basically on windows they've stopped supporting my card with their drivers, so it doesn't seem too far fetched that it's the same in linux even though i've read their faq and it says it's supported. my guess is something like an old mx2 card won't be really supported either. he can try but i wouldn't hold my breath on it.
 
Old 10-30-2003, 02:14 AM   #25
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
anyway, i just saw the post where he installed it.

basically make sure these sections look the same-ish.

Code:
Section "Module"
#        Load  "GLcore"
        Load  "dbe"
        Load  "extmod"
	Load "fbdevhw"
#	Load "dri"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection
for this section below, you only need to change the Driver to "nvidia"
and i guess add the options

Code:
Section "Device"
	# no known options
	Identifier   "VESA driver (generic)"
        Driver       "nvidia"
        VendorName   "VESA driver (generic)"
        BoardName     "VESA driver (generic)"
	Option "NvAgp" "1"
	Option "NoLogo" "true"
        #BusID
EndSection
you should only need to change the display subsection to get your desired resolution and color depth

Code:
Section "Screen"
	Identifier   "Screen0"
        Device       "VESA driver (generic)"
        Monitor      "Monitor0"
	DefaultDepth	24

	Subsection "Display"
        	Depth       24
                Modes       "1400x1050" "1280x960" "1024x768" "800x600" "640x480"
	EndSubsection

EndSection
just comment out this section by putting "#" in front of every line.

Code:
#Section "DRI"
#	Mode 0666
#EndSection
 
Old 10-30-2003, 05:23 AM   #26
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by .::Jo3king::.
OK! The downloading and installation of the drivers went smoothe... So i rebooted and got the same 'Id "x" respawning too fast: disable for 5 minutes' message. So I guessed... well thats okay... I just need to XF86Config!

So I looked at MasterC's FaQ, and try hard to follow it, but he has written it for someone who has access to a GUI by the looks of it... I have never even SEEN my GUI... So what do I do from here to edit my XF86Config file in just text mode?

Thanks again for your time and efforts!

Joe

Joe,

I'm sorry but I don't know what advice to offer from this point. Since I don't run RH, and megaspaz has given you his RH information, I would follow that and see how it works. Remember to write down your present values before you change them, so that if the new ones don't work, you can at least get back to where you started. Document everything. I never thought to ask, but you said your friend installed RH and everything is just fine. Is there any chance that he has the same computer you have? If so, you should get these settings from his computer and duplicate them in yours. If not, it doesn't matter.

If this doesn't help, post a new thread, but this time give a more useful title. If you will read the forum rules, etc., Help... is probably suggested as a title you shouldn't use You may even want to browse our RH forum.

Perhaps something like 'Id "x" respawning too fast: disable for 5 minutes' would be more appropriate, and then you could post what you've done to get to this point. A fresh install of RH 9.0 and then an install of the latest driver from Nvidia and then put the exact name of that driver. And, did you ever do the cat /proc/pci as suggested, to be certain that is your card?

One other suggestion. You could download Knoppix http://www.knopper.net/knoppix/index-old-en.html and burn a CD and see what happens with it. Knoppix is a Linux Live CD that runs from your CD-ROM is ram memory, and never touches your hard drive. If everything works fine with Knoppix, you could check to see what drivers it's using, and then maybe duplicate that in RH. Or, if you're really impressed, you could install Knoppix to your hard drive and run it instead of RH. We have that running on the wife and daughter's PC, and it works really good. That's the one that I had to get the Nvidia driver for. Mind you, Knoppix may still need some work to get everything to work just right, but you'll have a whole lot of Linux setup and running without much effort.

 
Old 10-30-2003, 06:55 AM   #27
.::Jo3king::.
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks for all the intrest guys! Much appriciated!

Now... I'll post back soon with the results!
 
Old 10-30-2003, 07:31 AM   #28
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Now that's the attitude! I for one will be glad to see what you find out, so that I can learn, also. Good of you to post back so people who read this thread can learn what happens.
 
Old 10-30-2003, 08:21 AM   #29
.::Jo3king::.
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
Ok! My first tase of Vim! Not to hard.. bit different to MS word! lol.

I logged in as root and typed "XF86Config" but the command wasn't found so i guessed i was doing something wrong...

I then re-read everything and noticed "vi/etc/X11/XF86Config"

These are the sections you gave me to edit:
_____________________

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
End Section
_____________________

Section "Monitor"
Identifier "monitor0"
VendorName "MonitorVendor"
ModelName "UnprobedMonitor"
HorizontalSync "31.5-37.9"
VerticalRefresh "50.0-70.0"
Option "dpms"
End Section
_____________________

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard Vendor"
BoardName "NVIDIAGeForce2MX (generic)
VideoRam "65536
End Section
_____________________

Section "Screen"
Identifier "Screen0"
Device "VideoCard0"
Monitor "Monitor0"
DefaultDepth "24"
SubSection "Display"
Depth "24"
Modes "800x600" "640x480"
End Subsection
End Section
_____________________

Section "DRI"
Group "0"
Mode "0666"
_____________________

So before doing anything, i decided to look at MasterC's guide again... and it suddenly clicked in place! So i followed his guide to config my XF86Config.

So i commented out DRI in the module loading section.
I Had no GLCore to comment out.
I had a GLX and didn't comment it out.
I changed the driver loading "nv" module to "nvidia"
I saved the file (shift+zz) and rebooted.
I got the same error message:
ID "x" respawning to fast: disable for 5 minutes

So i re-read the info megaspaz gave about changing the drivers to VESA and the resolution and stuff...
But decided to post back here for opinions first.

Thanks again for your time!

Joe
 
Old 10-30-2003, 08:55 AM   #30
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
Joe,

Do you remember the Readme document from Nvidia? It says:

Quote:
If you already have an XF86Config file working with a different driver (such as the 'nv' or 'vesa' driver), then all you need to do is find the relevant Device section and replace the line:
Driver 'nv'
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to the XF86Config file to fine-tune the NVIDIA XFree86 driver. Please see Appendix D for a complete list of these options.

Blah blah blah...
You really should read all this stuff, especially the blah blah blah parts.

So, according to the Nvidia documentation, I would expect it should work with the nvidia driver and not the vesa driver. But, heh, you know how to change it and you can't get it to work "according to the Nvidia instructions," so I'd try what megaspaz says works on his comp, and give it a go. It doesn't display now, and it surely won't hurt to try.

Did you also look at the Nvidia forum for this problem? Did you post there?

And since no real expert has come to your aid, why don't you post the results of
cat /etc/inittab

And look at these threads and read them -> http://www.linuxquestions.org/questi...der=descending
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration