LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2004, 02:29 AM   #1
markjc
LQ Newbie
 
Registered: May 2004
Location: Chino HIlls, CA 91709
Distribution: Suse Personal 9.1
Posts: 13

Rep: Reputation: 0
Suse 9.0 Linksys WPS54GU2


I have 3 issues with my Suse 9.0 installation:
1) I use the Linksys WPS54GU2 printserver on two of my Win2000 boxes and it works fine.
Cam some one spoon feed me in how to setup the print server?
I have read arny's solution else where in this threads, but I it seems to be installation dependent, arny uses Fedora, and he got his printserver to work, but I have tried many times and I can not get it to work using Yast.

2) I also have a Belkin wireless PCI (F5D7000 802.11g) in this box (Suse 9.0) and I can not get it to work either.
I use Belkin Wireless Router (802.11g) connected to a Motorola cable modem. My ISP is Adelphia. The Internet wireless connection work fine with the PCs.

3) I have a problem with the monitor. After rebooting the monitor is all garbled up. I found out that if I press Ctrl Alt Backspace it gets corrected.
My video card is nVidia GeForce 4 MX440 AGP 8X and the monitor is a 20" Sony Multiscan 20 sf II.

My top priority is to get my printserver working. Can anyone help?

Thank you.

Mark

 
Old 06-03-2004, 04:31 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Welcome, markjc. I've moved your last post from the thread in Member Intro to this forum, as I think it's much better place to for it.
 
Old 06-05-2004, 03:03 AM   #3
markjc
LQ Newbie
 
Registered: May 2004
Location: Chino HIlls, CA 91709
Distribution: Suse Personal 9.1
Posts: 13

Original Poster
Rep: Reputation: 0
Thank you Mara,

Sorry, I don't even know where to place my questions

Mark
 
Old 06-05-2004, 06:25 AM   #4
amanjsingh
Member
 
Registered: Mar 2004
Location: New York, USA
Distribution: Debian, Ubuntu
Posts: 71

Rep: Reputation: 15
dear markjc
with all due respect to you, i would like to mention a small thing that you should take care while putting the title of the thread. shouldnt it seem more useful? m sorry if i hav offended you but these things make the problem solving a faster process.
thanking you
aman
 
Old 06-05-2004, 09:01 AM   #5
oldyas
Member
 
Registered: Jun 2004
Location: Bristol, UK
Distribution: SuSe
Posts: 53

Rep: Reputation: 15
I don't know anything about setting up printers, but I can help you with problem 3: your display setting are wrong for you monitor. Pressing ctrl-alt-backspace kills teh X server, and usually restarts it in a lower resolution.

Use Yast > Hardware > Graphics card and monitor, although this didn't work for me (using 3D hardware accelerated NVidia driver) and I had to boot into failsafe mode and run SaX2 manually.

Sorry I can't help with your other problems.
 
Old 06-05-2004, 09:03 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I've got an earlier version of your Linksys server and it works great with CUPS (Common Unix Print Server). First off, if CUPS isn't already installed in your system, you are going to want to find the Suse binary for it (believe me, this is one you don't want to compile from source). Once you've got CUPS installed and running, open your web browser and point it at localhost:631. This is the CUPS web interface. Start setting up a printer and when you get to the place where it asks how it is connected, select lpd. It will then ask you for an IP address, and this is where you need to enter it, but slightly altered:

lpd://1.2.3.4/P1

Where 1.2.3.4 would be replaced by the real IP of the print server. Note that /P1. That is your print queue. If your server has more than one printer port, the second would be /P2, the third would be /P3.......

As for your wireless card, have you seen this thread ? In reading around it looks as if people have had success with linuxant or ndiswrapper .

If your monitor is goofy, you may have the settings wrong. I'd find the manual, check the settings and run xf86config again.
 
Old 06-09-2004, 07:49 PM   #7
markjc
LQ Newbie
 
Registered: May 2004
Location: Chino HIlls, CA 91709
Distribution: Suse Personal 9.1
Posts: 13

Original Poster
Rep: Reputation: 0
Hangdog42,

Thank you for your help, but I need more help because I could not get the printer to work.

Localhost:631 has many options; I setup the printer to the best of my guesses. At the end localhost:631 said that the printer setup was successful, but I request a print test and nothing happened.
I then logon to the printer server with Konqueror web browser:
http://192.168.2.5
And it asked me for the server user name and password, (i.e., name: printserver1, somepasswd)
Please note. Localhost:631 never asked me for the print server user name or password.
Then I could see the print server with all of its options on the browser.
I then proceed to request a print test, and the strange thing it did, and this is what it printed:

Hardware ID: 04C04D955C
Firmware Version: 6032
Protocol ID: 807E
Default Name: LK95C473
Server Name: LK95C473
MAC Address: 000C4195C473

AppleTalk Info:
Printer Type:
LK95C473:LaserWriter
LK95C473_P2:LaserWriter

TCP/IP Info:
IP Address: 192.168.2.5
Gateway Address: 192.168.2.1
Subnet Mask: 255.255.255.0
Email Server IP Address: 0.0.0.0
Printing Account Name: N/A
Redirect Account Name: N/A

SMB Info:
Domain Name: domain

Wireless Info:
SSID: printserver1
BSSID:3C:1A:BF:C4:27:5A
Channel No:0
Network Type: Infrastructure
Primary Firmware:
Secondary Firmware:
Link Info. Tx:0 Rx:0

But still I can’t get the printer to print anything else such as from an editor or OpenOffice.

Monitor issue: I have changed the monitor settings to lower resolution and the problem persists. Later I will post the configuration file to see if I am doing something wrong.
 
Old 06-10-2004, 09:04 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I'll see if I can generate a step-by-step when I get home tonight....

Until then, there are a couple of things to look at. CUPS does keep logs of the printer jobs. You can access them through the CUPS web interface (localhost:631) or you can see them in /var/log/cups. I'd have a look in those and see if there is any specific complaining. CUPS does a pretty decent job with its error logs, so something ought to be there.


Quote:
Please note. Localhost:631 never asked me for the print server user name or password.
You're mixing apples and oranges here. Accessing your print server thorugh it's web interface needs a username and password so that somebody doesn't come along and just mess with its settings. Since it doesn't use the web interface to actually print, you don't need the username and password to print. In fact printing works on an entirely different port. Basically, CUPS and the print servers web interface are two different beasties and they don't interact. However,if you're not already running as root, when you configured CUPS through localhost:631, it should have asked you for root's password. If it didn't, then something may be screwy with CUPS or you weren't configuring CUPS the right way.
 
Old 06-10-2004, 06:57 PM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
OK, here is the step by step:

1) Fire up a browser and point it at localhost:631
2) Click on "Do Administration Tasks" (and log in as root when prompted)
3) Click on "Add Printer" then give a name, description and location (the values you put here are for your information only, they don't affect the printer at all). Click on "Continue"
4) From the Device drop down, select "LPD/LPR Host or Printer". Click on Continue
5) In the "Device URI" enter "lpd://1.2.3.4/P1" only replace the 1.2.3.4 with the IP address of the print server. If your printer is on a different print queue, change the P1 value to match the print queue number (mine only has one print queue so it is P1 by default). Click on continue
6) Select your printer maker (Apple in your case) and click Continue
7) Select your printer from the list.


If your printer isn't listed (and LaserWriters aren't on my installation of CUPS), you'll have to rummage around LinuxPrinting.org for more instructions. Since LaserWriters are PostScript devices, it shouldn't be hard to get it up and running.
 
Old 06-16-2004, 09:59 PM   #10
markjc
LQ Newbie
 
Registered: May 2004
Location: Chino HIlls, CA 91709
Distribution: Suse Personal 9.1
Posts: 13

Original Poster
Rep: Reputation: 0
Gary, (Hangdog42)

(Ref: Linksys WPS54GU2 Wireless printserver on SuSE 9.0 OS)

Thank you again for your help. I apologize for taking so long to respond.
I followed your instruction on how to set the printer on localhost:631 and unfortunately it did not print.
However your instructions were very helpful and I got the terms straitened out:

“Description and location (the values you put here are for your information only, they don't affect the printer at all).”

“From the Device drop down, select "LPD/LPR Host or Printer".”

“print queue as P1 or P2”

Now knowing some of the terminology I went back to YaST and started the printer installation and finally I got my Wireless Linksys WPS55GU2 printserver working.
I must say that for me it was a major achievement especially that I have been working on this problem for weeks. And I must confess that I was ready to dump SuSE in favor of Fedora. I had already downloaded the DVD ISO files from Red Hat.

I would like to share my experience with the forum:

I stated YaST from the start icon on the lower left screen, typed the root password.
Clicked on the Hardware icon and selected the Printer icon:
Configure Printer (EPSON Stylus CX5400)
Print via LPD_Style Network Server
Hostname of printer: 192.168.2.10
Name of remote queue: P2
(Note, it is P2 because the printer is connected to the printer server USB port and the printserver has two ports; a parallel and an USB)
Test remote LPD access, it responded: The printer is accessible.
Name of printing: StylusCX5400
Description: EPSON Stylus CX5400 Color Printer/Copier/Fax
Location: USB printer on Linksys WPS55GU2 printserver
Manufacturer and model of the printer:
EPSON - - > Stylus C80
(Note CX5400 was not available on the list of EPSON printer models)
Edit Configuration:
(Note: It defaulted to Epson Stylus C80 Foomatic/gimp/print (recommended) but it did not work)
So I selected the EPSON Stylus C80 CUPS+Gimp-Print v4.2.5 (stp/escp2-C80.ppd.gz)
And I clicked to test printer for text and then for graphics.
It worked for both tests and I was as happy as a kid on a candy store.

And this is how the printer edit configuration looks like:

Already installed printers and queues:
EPSON Stylus C80: Filtering forwarding queue to P2 on LPD
server 192.168.2.5
Configured as:
StylusCX5400 [test] - ready
Listen to remote CUPS servers to get comfortable access to
remote queues.

Thank you again,

Mark
 
Old 02-15-2005, 09:51 AM   #11
PeterKlancic
LQ Newbie
 
Registered: Nov 2004
Location: Near Reading (UK)
Distribution: Suse 9.2
Posts: 11

Rep: Reputation: 0
2nd Printer

I've set up a HP4 and I can do this two ways via Yast but cant get my USB port active with an Epson Printer. Everything gets directed to the HP!
 
Old 03-24-2006, 02:06 PM   #12
konrek
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
After struggeling for a while made this strange piece of hardware (WPS54GU2) work
(using cups-admin on http : // localhost:631 and static ip for the print server) with Suse 10 Linux:

Print Server Linksys WPS54GU2

on parallel: HP 930C
on usb: Brother HL-2030

(in BiAdmin Management Utility that comes with WPS54GU2)
set L1 to P1 (parallel)
set L2 to P2 (usb)

HP configured with:
(this forum wouldnt me allow to send urls so adapt without spaces)
socket : // 192.168.x.x:9100

to prevent Print Server sending everything to the parallel port (ipp didnt work either, send to P1 in infinite loop):

Brother HL-2030 (using driver Brother HL-2060 Foomatic/hl-1250):

lpd : // 192.168.x.x/L2

note the port-label L2!


See here for more information (havent tried that yet):

This forum wouldnt allow me to send the link: so figure out

on linksys homepage:

How do I setup a Linksys Print Server under Linux using LPR?

Last edited by konrek; 03-24-2006 at 02:12 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration