LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2005, 10:38 AM   #1
snakecreepsdown
Member
 
Registered: May 2005
Location: The Isle of Everywhere
Distribution: Slackware 10.1
Posts: 33

Rep: Reputation: 15
Angry Having trouble with K3B make


I am trying to *make* k3b
I apologise in advance for the bizarre
way in which the code is displaying... i just copy pasted from terminal?
The ./configure step appears to go OK but make results in:
Code:
T_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLAT                                                                                                  ION    -o libk3bdevice.la -rpath /opt/kde/lib -L/opt/kde/lib -L/usr/lib/qt/lib -                                                                                                  L/usr/X11/lib    -version-info 2:0:0 -no-undefined -Wl,--no-undefined -Wl,--allo                                                                                                  w-shlib-undefined k3bdevice.lo k3bscsicommand.lo k3btrack.lo k3btoc.lo k3bdevice                                                                                                  manager.lo k3bmsf.lo k3bdiskinfo.lo k3bdeviceglobals.lo k3bcrc.lo k3bcdtext.lo -                                                                                                  lkio
grep: /usr/X11R6/lib/libfontconfig.la: No such file or directory
/bin/sed: can't read /usr/X11R6/lib/libfontconfig.la: No such file or directory
libtool: link: `/usr/X11R6/lib/libfontconfig.la' is not a valid libtool archive
make[3]: *** [libk3bdevice.la] Error 1
make[3]: Leaving directory `/home/nyghtowl/k3b-0.11.23/src/device'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/nyghtowl/k3b-0.11.23/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nyghtowl/k3b-0.11.23'
make: *** [all] Error 2
nyghtowl@snake_creeps_down:~/k3b-0.11.23$
Slackware 10.1

and I haven't got a clue what this is about.

I would appreciate anyone throwing some light on
1)what has one wrong... I am having trouble googling any useful (to my newbieness) information , and
2)how can I correct the issue.

Thanks in advance

Last edited by snakecreepsdown; 05-11-2005 at 10:40 AM.
 
Old 05-11-2005, 11:23 AM   #2
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
it seems to be complaining about libfontconfig.la. not sure what that is but try google for a libfontconfig src package and install it.
 
Old 05-11-2005, 11:32 AM   #3
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
I had the sameish problem getting K3B to compile on RedHat 9. Only it was complaining on my machine about

libart_lgpl_2.a

in the exact same way it complains to you about your missing library. I checked and then found that I -DID- in fact have the libart.lgpl_2.so.2.3 -DYNAMIC- library. So what I did was to symlink
libart_lgpl_2.a to libart.lgpl_2.so.2.3 and restart the K3B make, after which K3B compiled and
now works prefectly on my Rh9 system.

What I suggest is that ou check your library directories (erm... /usr/lib and /usr/local/lib ? dunno) for the file that K3B's make complains about. Check if you do not in fact actually -have- that library, but maybe in its dynamic form. If you find a library with a similar name, try symlinking it to the name that K3B make complains about.

To find out how to symlink (i. e. link one filename to another so that if the symbolic one is called, the "actual" file is referencd) type man ln in an Xterm, or post here again.
 
Old 05-11-2005, 01:03 PM   #4
snakecreepsdown
Member
 
Registered: May 2005
Location: The Isle of Everywhere
Distribution: Slackware 10.1
Posts: 33

Original Poster
Rep: Reputation: 15
thanks very much both

I'll try this this evening
 
Old 05-11-2005, 04:31 PM   #5
snakecreepsdown
Member
 
Registered: May 2005
Location: The Isle of Everywhere
Distribution: Slackware 10.1
Posts: 33

Original Poster
Rep: Reputation: 15
wow!
What a tricky afternoon of reading / searching / and FINALLY downloading the correct package to allow me to install K3B

I actually needed:

fontconfig-2.2.1-i486-1.Firefly.tgz from

HERE

I also installed the devel package

I have not tested k3b yet but i have it MADE and INSTALLED WOOOOHOOOO (or should that be... errr... Maked ? hehe)


Big Thankyou to all who replied


EDIT:: IT WORKS! YEY!

Last edited by snakecreepsdown; 05-11-2005 at 04:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Really, really Weird trouble with make (make error 2) flyeater SUSE / openSUSE 5 06-20-2005 01:05 PM
Trying to make mod_ssl work - virtualhosts make trouble Belize Linux - Software 0 02-26-2005 09:30 PM
Trouble with k3b 0.11.14 danchiaperini Red Hat 1 11-21-2004 03:53 AM
k3b trouble buffed317 Linux - General 7 09-11-2004 12:45 PM
k3b trouble primal Linux - Software 2 01-21-2004 03:28 PM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration