LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2015, 04:00 PM   #1
RayLui20
LQ Newbie
 
Registered: Jul 2013
Posts: 15

Rep: Reputation: Disabled
having trouble getting Fabric to work


so I have this new server running on centos6.6 that I am trying to get fabric to work. In the past, I have another server that I installed fabric on, and it has worked for me since. I do not remember it giving me a problem in the past. Not sure if this is related to my pip-install

# fab --version
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/fabric/network.py", line 24, in <module>
import ssh
File "/usr/lib/python2.6/site-packages/ssh/__init__.py", line 62, in <module>
from transport import SecurityOptions, Transport
File "/usr/lib/python2.6/site-packages/ssh/transport.py", line 33, in <module>
from ssh import util
File "/usr/lib/python2.6/site-packages/ssh/util.py", line 33, in <module>
from ssh.common import *
File "/usr/lib/python2.6/site-packages/ssh/common.py", line 98, in <module>
from Crypto import Random
ImportError: cannot import name Random

There was a problem importing our SSH library (see traceback above).
Please make sure all dependencies are installed and importable.

I am running out of ideas.

The server is running with
Python 2.6.6
I believe I installed

paramiko.1.7.6-1
pycrypto-on-pypi
gcc libffi-devel python-devel openssl-devel

sorry if this doesn't make sense, will provide more information if need to
 
Old 07-09-2015, 01:26 PM   #2
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,307
Blog Entries: 2

Rep: Reputation: Disabled
Hi Ray

The most likely answer to your question is you have the wrong crypto module loaded.

Quote:
pycrypto-on-pypi
I might try this one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Python 2.6.6 or Fabric 1.8 question about arrays szboardstretcher Programming 1 02-11-2014 12:46 PM
LXer: Fabric: a System Administrator's Best Friend LXer Syndicated Linux News 0 04-10-2013 06:40 AM
having trouble getting a crontab to work mkesling Linux - Newbie 3 08-02-2012 02:33 PM
Trouble getting snmptrap to work Ratclaws Linux - Software 0 05-15-2006 04:02 PM
QLA2200 Fabric HBA not in Fabric mode phillip rill Linux - Hardware 0 02-11-2004 04:11 PM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration