LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-10-2004, 01:42 AM   #1
Ovalteen
Member
 
Registered: Jun 2004
Location: Australia
Distribution: Ubuntu 5.04
Posts: 55

Rep: Reputation: 15
Question Having problems with sessions: GUI gets all messed up.


Hello,

I'm fairly new to Linux (using Red Hat 8.0), and recently I've begun having a problem. When I log in as a certain user, instead of showing the KDE desktop and all that, I get a string of error boxes with no writing, the toolbar has no icons and is at the top of the screen, and all the menu items are just little full stops. Everything is also very small. The only way for me to get out of there is to Ctrl-Alt-F4 (I can still use the mouse but I can't tell what I'm clicking), then I'm back to command line. If I login as root and type "startx" I get some error message about XServer already running, and that if it's crashed to delete some file.

Funny thing is, if at the login menu I click "Sessions" at the bottom of the screen, and manually select KDE from the list, everything works fine. It only goes bad when it automatically tries to load the last session, and it only happens for one particular user.

Any assistance would be greatly appreciated.

Thanks

Ovalteen
 
Old 06-10-2004, 03:00 AM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Hmm...Well firstly, "startx" wont work because you are already in runlevel 5 and the X server is already running. Pressing Ctrl+Alt+F4 will just take you to another terminal, but to completely shut down the X server, login in the terminal as root, and type "/sbin/init 3" Now the X server is shut down. Try "startx" from here.

As far as the problem is concerned, it is indeed a very weird problem. There is a directory called ".kde" in the home directory of each and every user. (You wont be able to see it. Type "ls -a" in the home directory in a terminal to see these files beginning with a period)

The directories beginning with a period (like .xmms or .xchat) store the local settings of the users in their home directory. For example, .xmms will store all the skins, the preferences chosen by the user and all such things. Deleting such a directory will make the settings of its respective program to the default.

Since it is happening with only a particular user, I'd recommend this:
1) Go to the home directory of that user
2) Rename the ".kde" directory. (to create a backup as well as to prevent KDE from accessing that folder) WARNING: dont copy that file in another user's home, or his own ".kde" will get replaced.
3) login as the user.

Unfortunately, the user may lose his/her preferences.

I'm not really sure on this, because I use Gnome. But I hope it helps.

Last edited by akudewan; 06-10-2004 at 03:02 AM.
 
Old 06-10-2004, 03:16 AM   #3
Ovalteen
Member
 
Registered: Jun 2004
Location: Australia
Distribution: Ubuntu 5.04
Posts: 55

Original Poster
Rep: Reputation: 15
Thanks for the tips akudewan, I'll give it a shot .

Cheers

Ovalteen
 
Old 06-10-2004, 03:44 AM   #4
Ovalteen
Member
 
Registered: Jun 2004
Location: Australia
Distribution: Ubuntu 5.04
Posts: 55

Original Poster
Rep: Reputation: 15
Well, I gave it a shot, no dice. However, thanks to akudewan's advice I didn't need to restart the computer to get things working again .

I made progress though. When the strange desktop came up, I pressed Ctrl-Alt-F1 to get the command line terminal (thanks akudewan) and there was an error message there. I said something like:
nautilus:3975
Something about gconf error
Something about not being able to contact configuration server, might need to fix my TCP/IP settings, or NFS somethings.
*path to my home directory*/.gconfd/lock/ior not openned successfully or not located.

GConf, that's GNOME, right? I'm going to do some more testing. If anybody has any ideas, they are greatly appreciated .

Cheers

Ovalteen
 
Old 06-10-2004, 03:57 AM   #5
Ovalteen
Member
 
Registered: Jun 2004
Location: Australia
Distribution: Ubuntu 5.04
Posts: 55

Original Poster
Rep: Reputation: 15
Well, it's official: my GNOME settings are buggered. If I choose a GNOME session on the login window the same problem happens. I didn't think it would be a GNOME problem though, because I always use KDE and it's my default (I think, how do I check?).

Anyway, I'm going to go rename all the GNOME files and see what happens.

Cheers

Ovalteen
 
Old 06-10-2004, 04:14 AM   #6
Ovalteen
Member
 
Registered: Jun 2004
Location: Australia
Distribution: Ubuntu 5.04
Posts: 55

Original Poster
Rep: Reputation: 15
It worked! It's fixed!

I renamed all the gnome crap, and go to log in without choosing a session. It works! No error messages, but for some reason I lost my settings. Oh well. Anyway, I log back out and select KDE as the session. It asks me if I want to make if default from now on, I said yes, then changed all my settings back. From now on when I log in, I get KDE and my settings, just how I want, without having to click anything. No error messages.

Yippee!

Thanks for your help akudewan.

Cheers

Ovalteen
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
php sessions problems MaestroC SUSE / openSUSE 2 12-06-2005 09:06 AM
I messed up the FC2 login GUI areswargod03 Red Hat 1 11-13-2005 01:42 AM
after reboot ....gui got all messed up luna6 SUSE / openSUSE 15 05-20-2005 12:42 PM
I think I messed up Soundcard problems. gplacek Linux - Hardware 1 04-24-2005 03:39 PM
Java GUI via command line sessions? Giles Linux - General 2 09-28-2004 10:03 AM


All times are GMT -5. The time now is 09:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration