LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-02-2004, 03:43 PM   #1
brynjarh
Member
 
Registered: May 2004
Location: Iceland
Distribution: Ubuntu Dapper Drake
Posts: 172

Rep: Reputation: 30
Having problems mounting hd. (mount: you must specify the filesystem type)


I used fdisk to delete all partition of hdb and create a new one.

Disk /dev/hdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 9729 78148161 83 Linux


----------------------------------------------------------------------------

---Starting--- ----Ending---- Start Number of
# Flags Head Sect Cyl ID Head Sect Cyl Sector Sectors
-- ----- ---- ---- ---- ---- ---- ---- ---- ------- ---------
1 0x00 1 1 0 0x83 254 63 1023 63 156296322
2 0x00 0 0 0 0x00 0 0 0 0 0
3 0x00 0 0 0 0x00 0 0 0 0 0
4 0x00 0 0 0 0x00 0 0 0 0 0



When I do 'mount /dev/hdb1 /mnt/hdb1' I get 'mount: you must specify the filesystem type'. I don't get that becous it already says in cfdisk and fdisk that the system is Linux(id 83).
This is what it says in /var/log/messages about it:
Jun 2 20:42:17 localhost kernel: FAT: bogus number of reserved sectors
Jun 2 20:42:17 localhost kernel: VFS: Can't find a valid FAT filesystem on dev hdb1.


PLEASE help me fix this, I can't continue anything untill I have gotten this hd to work properly.
 
Old 06-02-2004, 03:54 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,743
Blog Entries: 4

Rep: Reputation: 76
Creating the partition is not enough to use it, you need to put a filesystem on it. ie:

Code:
mkfs.ext3 /dev/hdb1
Then you can mount it using
Code:
mount -t ext3 /dev/hdb1 /mnt/hdb1
 
1 members found this post helpful.
Old 06-02-2004, 04:05 PM   #3
brynjarh
Member
 
Registered: May 2004
Location: Iceland
Distribution: Ubuntu Dapper Drake
Posts: 172

Original Poster
Rep: Reputation: 30
Cool, it worked!
Thanks bulliver.
 
Old 01-11-2008, 01:23 AM   #4
mr805newbie
Member
 
Registered: Aug 2004
Posts: 78

Rep: Reputation: 15
This worked for me too! You guys rock!
 
Old 02-09-2010, 11:39 PM   #5
xxchrisxx111
LQ Newbie
 
Registered: Feb 2010
Posts: 5

Rep: Reputation: 0
Thumbs up Worked

Haha worked for me too!! You the man !
 
Old 01-05-2011, 01:45 AM   #6
ivannasrudin
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
can i do it on my root "/" directory?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
mount: unknown filesystem type 'NTFS' jnorcal Slackware 8 09-07-2005 06:18 PM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 04:02 PM
how to mount without the filesystem type mascon Linux - General 7 05-01-2004 05:20 AM
New 2.6 mount options make VFAT filesystem mounting saner TheOneKEA LinuxQuestions.org Member Success Stories 0 11-19-2003 12:05 PM


All times are GMT -5. The time now is 01:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration