LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-09-2004, 06:01 PM   #1
untoldone
LQ Newbie
 
Registered: Nov 2003
Location: near DC, USA
Distribution: Slackware 9.1
Posts: 14

Rep: Reputation: 0
having issues with 2.6 and console framebuffer ?


well, im not quite sure where to start. Ive been trying to get the console working correctly with the 2.6.3 kernel. I started off by first compiling with: most of the frame buffer devices including VESA and VGA16, as well as 3dfx for my voodoo banshee. I also used framebuffer_console and video select. After that I boot with the new kernel set to 1024x768x256 and after lilo the screen went blank. However the machine continued to load and after 30 sec i typed in my user and password (without being able to see the screen) and then 'startx' .. that came up fine despite not being able to see the console. The second time i compiled I choose all the same stuff except except framebuffer_console. That worked fine on boot and i selected 80x50 or somthin like that. I could see all the consoles fine. I then ran startx and that worked fine as well ... but when it came to switching to a console from startx or shuting x down to return to the console, i would get a full screen of random charatures in random colors and I could do nothing to recover except restart. Everything worked fine with 2.4 so im assuming its not hardware + i had the same problem after i switched my banshee with a S3 somthingorother. any ideas?

thanks for your time
 
Old 03-09-2004, 07:22 PM   #2
untoldone
LQ Newbie
 
Registered: Nov 2003
Location: near DC, USA
Distribution: Slackware 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
well, i took a look at the /proc/config.gz file and i aparently didnt framebuffer_console the first time ... i tried the kernel with it and it worked fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Console Framebuffer darkarcon2015 Slackware 9 07-16-2005 05:24 PM
2.6.1 alsa, framebuffer console and eciadsl issues fasta Slackware 4 02-02-2004 04:43 PM
Framebuffer Console Help Crazed123 Linux - Software 5 07-29-2003 02:10 PM
Framebuffer Console jspenguin Linux - General 3 02-28-2003 08:21 AM
Framebuffer Console Jesus Slackware 6 05-02-2002 12:55 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration