LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-16-2004, 06:37 PM   #1
asim_s2000
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
Having boot loader problems.


Hi. This is my first post. I've been sitting here 4 days straight trying to get my harddrive to use windows xp and linux of any kind.

After reading all over the internet i'm being told that the problem lies somewhere in the bios and harddrive.

My bios does not allow just LBA so it causing some problems. And my harddrive is also 120gb and i've heard that linux is unable to boot after like the 1024 cylinder or something like that.

Anyway the real problem is this. I install windows, works fine. I then install linux on the other half of the harddrive, I tell it to install the boot loader on the mbr. Ok reboot and it hangs, says L in top left corner with a blinkin dash.

So after alot more reading I realise i can edit the boot.ini so that I dont have to use the linux boot loader, which is great cause then i can get into windows no problem. But the only thing is the linux wont load up. When i try click the linux it goes to a blank screen with a flashin _

I'm hoping someone can provide me with some help.

I'd like to keep my boot.ini and allow it to point to the bootsect.lnx file that i took from the linux boot partition and stuck on c: drive.

But i believe the bootsect.lnx maybe be screwed, or the lilo.conf maybe having some problems.


Any help would be great.

Using mandrake 9.2 to try get this to work at the moment, I've had some serious issues with every distribution when it comes to the boot loader.
 
Old 10-16-2004, 09:34 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
What happend when you ran /sbin/lilo?
 
Old 10-17-2004, 04:35 AM   #3
asim_s2000
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Sorry. Had to go to bed.


Anyway. Ive run lilo.conf to change the boot from /dev/fd0 to /dev/hda5 which is the root partition.
I saved the file

Then i do /sbin/lilo and it says directory not found.

Am i running it wrong?
 
Old 10-17-2004, 05:10 AM   #4
asim_s2000
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Ok so i got the lilo thing to work but its the same problem even when using the windows boot loader to get to lilo once u click on it. Lilo hangs at a blank screen with an L an a flashing cursor


Is there anyway that i can jus delete lilo and get the windows boot loader to boot straight into linux?
 
Old 10-17-2004, 06:17 AM   #5
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
I don't use mandrake but it sounds like you installed lilo to the mbr and then reinstalled windows boot loader.If you wanted to use windows boot loader you need to install lilo to mandrakes root partition.Boot up the mandrake CD and a:reenstall lilo to the MBR and use lilo to boot both window and mandrake or b:boot up the mandrake cd and install lilo to use the windows boot loader.Use google to see how to do b.For a always run lilo or /sbin/lilo when you make changes to lilo.conf.

Last edited by comprookie2000; 10-17-2004 at 06:18 AM.
 
Old 12-06-2004, 05:29 AM   #6
dslboy
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Slackware -current
Posts: 157

Rep: Reputation: 30
Actually, just go into cfdisk, and make hda1 bootable, if its already bootable, remove it, and set it, then write, and it should now have taken over the bootprocess, the you can add windows to the boot...
if you dont want to edit lilo.conf, run liloconfig and it will detect your windows partition, and add it good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot loader causing problems booting CDs DownloadTHIS Fedora 1 05-27-2005 01:37 PM
Boot Loader Problems (install with Windows) neorion Fedora - Installation 1 08-11-2004 10:46 PM
Boot loader problems TheOtaku Linux - Newbie 4 06-16-2004 05:19 PM
dual boot problems, now no boot loader after fixmbr mipia Debian 2 04-04-2004 09:43 PM
Kernel update boot problems, no boot loader StaticSage Red Hat 2 01-09-2004 06:05 AM


All times are GMT -5. The time now is 10:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration