LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-27-2009, 12:52 PM   #1
crathm
LQ Newbie
 
Registered: Nov 2008
Posts: 13

Rep: Reputation: 0
Having an issue in regards mounting a file system to a logical volume in RHEL5


Hey folks,

I'm currently having an issue trying to mount a newly created logical volume named privatelv.


what i've done so far was this;

lvcreate -L 500M -n privatelv -v rootvg

I didn't see any errors and when i typed ls /dev/rootvg/

I can see that the privatelv is sitting in the directory with the rest of my volumes.

I then tried to append a file system to the volume by issuing the following command:

mkfs -c -L privatelv -T ext3 /dev/rootvg/privatelv

with no errors given i then tried to mount the file system to a directory by issuing the mount command:

mount -t ext3 /dev/rootvg/privatelv /private

and i get the following error

Code:
mount: wrong fs type, bad option, bad superblock on /dev/rootvg/privatelv,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
when i issue the dmesg | tail, i get the following error

ext3: No journal on filesystem on dm-9

i'm currently not getting any luck with my search to the solution but if anyone has any ideas i'm open to suggestions.

Kind Regards
 
Old 01-28-2009, 06:02 AM   #2
Matey
Member
 
Registered: Jan 2009
Posts: 108

Rep: Reputation: 17
I think you have to have an LVM partition before you can create an LVM volume? do fdisk -l and see
if you do have the patrtition 8e ( I think) and if it is for instance on hda4
then create a physical volume first;
pvcreate /dev/hda4
then a volume group
vgcreate privatelv (or whatever you want to name the folder) /dev/hda4


also after you have created the LVM volume you have to do this;
mkfs.ext3 /dev/privatelv (or whatever u named the folder)/privatelv
but I am pretty sure you have to activate it by;
mkfs.ext3 /dev/privatelv
even if you didnt create a group or a directory under /dev/

I have done this may be 2ice before so I am no expert at all...
may be this link or some one else can help;


http://ds9a.nl/lvm-howto/HOWTO/cvs/l...lvm-howto.html
 
Old 01-28-2009, 06:04 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Quote:
mkfs -c -L privatelv -T ext3 /dev/rootvg/privatelv
Isnt this should have been

mkfs -c -l privatelv -t ext3 /dev/rootvg/privatelv

Saw the man page for mkfs and there was small t and l
 
Old 01-28-2009, 12:51 PM   #4
crathm
LQ Newbie
 
Registered: Nov 2008
Posts: 13

Original Poster
Rep: Reputation: 0
actually that was an input error on my behalf... I did it all via remote and i was unable to scroll back pages so i went by memory..

I deleted the volume via lvremove command and tried again;

Code:
lvcreate -L 512M -n privlv -v rootvg
    Setting logging type to disk
    Finding volume group "rootvg"
  /dev/cdrom: open failed: Read-only file system
  Rounding up size to full physical extent 512.00 MB
    Archiving volume group "rootvg" metadata (seqno 17).
    Creating logical volume privlv
    Creating volume group backup "/etc/lvm/backup/rootvg" (seqno 18).
    Found volume group "rootvg"
    Creating rootvg-privlv
    Loading rootvg-privlv table
    Resuming rootvg-privlv (253:9)
    Clearing start of logical volume "privlv"
    Creating volume group backup "/etc/lvm/backup/rootvg" (seqno 18).
  Logical volume "privlv" created
I do see a cd rom error but I have an active cd in my drive so I assume that is a normal error.
you are right about the small letters, the problem was I wasn't thinking and I used the "mke2fs" command which is exactly like the "mkfs" but designed for only ext2/3 file systems and the mk2fs command uses capital letters.
below is the result of my command:
Code:
# mke2fs -c -L privlv -T ext3 /dev/rootvg/privlv
mke2fs 1.39 (29-May-2006)
Filesystem label=privlv
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
65536 inodes, 131072 blocks
6553 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=134217728
4 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks: 
        32768, 98304

Checking for bad blocks (read-only test): done                                
Writing inode tables: done                            
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 37 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
------------------------------------------------------------------------

after trying to mount:
Code:
 mount -t ext3 /dev/rootvg/privlv /private
mount: wrong fs type, bad option, bad superblock on /dev/rootvg/privlv,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
---------------------------------------------------------------------------

dmesg | tail

ext3: No journal on filesystem on dm-9


any ideas?

Last edited by crathm; 01-28-2009 at 12:53 PM.
 
Old 01-28-2009, 01:41 PM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 3,328

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
I think you also need -j on the mke2fs line to create the journal.
 
Old 01-28-2009, 02:35 PM   #6
crathm
LQ Newbie
 
Registered: Nov 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks GazL

You were right. I had to add journal to the filesystem.

I did so by using the default journal settings with the tune command;

tune2fs -j /dev/rootvg/privlv

Thanks again all for the assistance.
 
Old 01-28-2009, 04:51 PM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,328

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
You're welcome.

I use lvm + jfs myself. I think I'll give ext4 just a little while longer to settle down and then I might give that a try instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install reiserfs file system on my RHEL5 hshzh359 Linux - Server 7 12-21-2008 06:02 PM
RHEL5.1: Issue on creating OR loading file > 2GB using C/C++ tcnew1 Linux - Enterprise 0 08-03-2008 10:31 AM
Mounting logical volume? jdege Linux - General 3 12-15-2007 05:39 PM
Problem mounting a logical volume with JFS sumta Linux - General 3 10-05-2006 11:49 AM
cloning both partitions, dual boot system, master boot record, logical volume manager saranga2000 Linux - Hardware 3 01-10-2005 11:04 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration