LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2009, 03:08 PM   #1
africa4444
LQ Newbie
 
Registered: Jul 2009
Posts: 7

Rep: Reputation: 0
Question Having a problem with xinetd and trying to get R-1 to work


I am really not very experienced with linux and have only just started working off the command line in windows as well
I know the basics but I am trying to install R-1 and I was having a lot of difficulties and figured out that it was that xinetd was not running
so I tried to run it
service xinetd start

and it said unecognized service
so then I installed xinetd and there was already a xinetd.d directory with all of the processes i needed with the .conf file but so when i run
xinetd -d
Code:
09/7/8@19:47:36: ERROR: 18196 {find_next_entry} missing service keyword [file=/etc/xinetd.conf] [line=5]
09/7/8@19:47:36: ERROR: 18196 {handle_includedir} Unable to read included directory:  [file=/etc/xinetd.conf] [line=16]
09/7/8@19:47:36: ERROR: 18196 {find_next_entry} missing service keyword [file=/etc/xinetd.conf] [line=18]
09/7/8@19:47:36: WARNING: 18196 {skip_entry} missing } in last service entry [file=/etc/xinetd.conf] [line=18]
Service defaults
        Bind = All addresses.
        Only from: All sites
        No access: No blocked sites
        No logging

09/7/8@19:47:36: DEBUG: 18196 {cnf_start_services} mask_max = 0, services_started = 0
09/7/8@19:47:36: CRITICAL: 18196 {init_services} no services. Exiting...
my xinetd.conf file looks like this:
Code:
# Begin /etc/xinetd
# Configuration file for xinetd
#

defaults
{
      instances       = 60
      log_type        = SYSLOG daemon
      log_on_success  = HOST PID USERID
      log_on_failure  = HOST USERID
      cps             = 25 30
}

# All service files are stored in the /etc/xinetd.d directory
#
includedir /etc/xinetd.d
# End /etc/xinetd
EOF

this is what one of the files in xinetd.d looks like

Code:
# default: off
# description: The kerberized rlogin server accepts BSD-style rlogin sessions, \
#              but uses Kerberos 5 authentication.
service klogin
{
        flags           = REUSE
        socket_type     = stream
        wait            = no
        user            = root
        server          = /usr/kerberos/sbin/klogind
        server_args     = -5
        disable         = yes
}
I really dont no what im doing but I need to get xinetd running so that i can finish installing R-1 Thanks for the help
 
Old 07-08-2009, 04:27 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,736

Rep: Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585
Open /etc/xinetd.conf with vi and look for any weird characters, because other than that the file looks OK.
Then try to enable a service, for example for the rlogin xinetd.d control file you've posted, use "disable = no" and see if xinetd works.
 
Old 07-08-2009, 05:56 PM   #3
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
xinetd is a service in itself. Enable the service, instead of manually starting the xinetd program. One way you can check if it is running with `ps -u root | grep xinet'. You can also use the `service' command or if your distro has it `chkconfig'. Most distro's also have a GUI configuration utility to enable or disable services, and determine for which run levels to enable a service.

There are two flavors of linux that differ somewhat in how services are started, and the commands you can use. How the run levels used differ as well. You may want to indicate which distro you have installed.

Also look in your distro's configuration tools. You should be able to enable both xinetd and the service that xinetd handles, and let it deal with details. The "disable=no" line you posted is for the individual klogin service. There is a line like this for each service given in /etc/xinetd.d/*.
 
Old 07-09-2009, 12:42 PM   #4
africa4444
LQ Newbie
 
Registered: Jul 2009
Posts: 7

Original Poster
Rep: Reputation: 0
none of that worked
I looked at the xinetd.conf file it looked fine in vi
i changed the disable to no in klogin
however I cant don anything with the service command because for klogin and xinetd it says unrecognized service and they didnt appear in the list when i did
service --status-all
and im using red hat linux i guess that what you're are looking for.
I think my problem is in the install maybe
but i did run
./configure
make
make install

and then i moved my xinetd.conf file to where it wanted is there perhaps something I need to do to make xinetd recognized as a service? I do have chkconfig for what its worth but im not sure what i should do with that and then I don't know how to get at a that GUI if it exists. Does it make a difference that i am doing the install remotely through putty?
 
Old 07-09-2009, 12:58 PM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,736

Rep: Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585
Why didn't you install xinetd from a rpm package? That's why "service xinetd" does not work.
 
Old 07-09-2009, 01:16 PM   #6
africa4444
LQ Newbie
 
Registered: Jul 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the help I didnt do that because I dont know what an rpm package is.
I'll work on finding that out now and let you no how it goes.
 
Old 07-09-2009, 01:54 PM   #7
africa4444
LQ Newbie
 
Registered: Jul 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for your help I got xinetd working unfortunately R-1 isnt working still but I am getting help from their tech support
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xinetd doesn't work properly yzhong Linux - Newbie 2 02-03-2009 03:29 PM
sshd doesnt work with tcp wrapper(xinetd)... seagley Linux - Security 4 12-24-2005 09:05 PM
wierd scanner on slack that I got to work on mdk with xinetd Quercus ruber Slackware 2 02-16-2005 08:09 AM
xinetd problem? gimbal Linux - General 2 10-25-2003 02:46 AM
SENDMAIL - Why does it not work when i shutdown xinetd adamrau Linux - Software 2 10-22-2001 10:36 AM


All times are GMT -5. The time now is 12:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration