LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2013, 11:28 AM   #1
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Slackware; Crunchbang.
Posts: 409
Blog Entries: 2

Rep: Reputation: 98
Have To Keep Pavucontrol Open In Order For Sound To Work


Hey Everyone!

So....I installed a new PCI sound card to fix a hardware problem. It played perfectly after install. Then it stopped! I opened up pavucontrol to check adjustments- with pavucontrol open, the sound played perfectly. When I close pavu, the sound stops after a few seconds. Open...plays perfectly. What is going on and how do I fix it?

My OS is Crunchbang (essentially a minimal Debian) on a 3Ghz P4 PC with 2GB RAM.

I also have Debian dual-booted. Can't get sound at all when booted into Debian- but I suspect that is because Debian may not support a driver for this card, but Crunchbang does (and my card is recognized, and listed properly in pavucontrol and alsamixer on Crunchbang)

Last edited by Sumguy; 10-30-2013 at 11:30 AM.
 
Old 10-30-2013, 09:18 PM   #2
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Slackware; Crunchbang.
Posts: 409
Blog Entries: 2

Original Poster
Rep: Reputation: 98
Guys? Anyone??

Could this have something to do with my problems- aplay -l shows the same card listed 3 times.....WTH?
Quote:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738 [C-Media PCI DAC/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738 [C-Media PCI IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 01-23-2014, 05:03 PM   #3
dckemble
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
So I actually had these exact symptoms using a USB DAC on SolydX, a Debian based distro. It turned out my solution was to comment out "load-module module-suspend-on-idle" in /etc/pulse/default.pa, the default pulseaudio config file for my system.

I had serious troubles finding a solution online, though I kept stumbling onto this thread, so I wanted to give a potential solution to anyone else in a similar boat.

I ended up running pulseaudio in verbose mode while opening and closing pavucontrol with an mp3 file playing in vlc to debug this issue. I noticed messages like this:

"I: [pulseaudio] module-suspend-on-idle.c: Source alsa_input.usb-FiiO_DigiHug_USB_Audio-01-Audio.iec958-stereo idle for too long, suspending ..."

I had already tried all sorts of different settings in pavucontrol to no avail, and noted that my DAC only worked if using a profile that had both input and output (Analog Stereo Duplex for example). With this knowledge, I figured that my DAC needed it's input stream active to give me sound. That combined with the fact that it was reading as idle and getting killed off by pulseaudio, led me to my eventual solution.

It's worth noting that I did not have this issue on my desktop PC using the same DAC and OS. I believe this is likely due to pulseaudio enabling different modules by default based on system hardware differences, but have no clue. It's also worth noting that I disabled my onboard sound by using pavucontrol to set it's profile to "Off". This step may also be necessary for some people, though defaulting the DAC in output devices tab may also have the same effect.

Hope this helps someone Sorry for any post formatting faux pas, this would be my first here.
 
Old 03-29-2014, 11:53 AM   #4
Dr_Evil
LQ Newbie
 
Registered: Mar 2014
Posts: 2

Rep: Reputation: Disabled
Here's a quick fix that I found looking around for my S/PDIF that kept disconnecting when I closed pavucontrol. I'm betting this would work in this case too.

From : https://wiki.archlinux.org/index.php/PulseAudio

To disable loading of the module-suspend-on-idle module, comment out the following line in the configuration file in use (~/.config/pulse/default.pa or /etc/pulse/default.pa):

### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle

Finally restart PulseAudio to apply the changes.
 
Old 03-29-2014, 12:57 PM   #5
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Slackware; Crunchbang.
Posts: 409
Blog Entries: 2

Original Poster
Rep: Reputation: 98
Holy frijole! Dr_Evil and DCKemble! IT WORKED!!!!

Funny thing, I THOUGHT that I had already tried this, based on some Google searches- but I figgered[sic] I'd double check. Turns out, for some reason, when I had tried doing it in the past, instead of saving it to the "default.pa" file, it had somehow created another file.

So I fixed that, and appended the real file...and VIOLA[sic]!

I was really worried, when none of the gurus could seem to help....

Woo-hoo!

Thanks so much, guys!!!!

Last edited by Sumguy; 03-29-2014 at 12:59 PM.
 
Old 03-29-2014, 04:23 PM   #6
Dr_Evil
LQ Newbie
 
Registered: Mar 2014
Posts: 2

Rep: Reputation: Disabled
Glad I could help

Have fun with your sound system
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pavucontrol will not show applications for audio adjustment. Gumboherpy Slackware 3 05-13-2013 10:12 PM
pavucontrol and alsamixer pwabrahams Linux - Software 4 05-09-2011 02:02 PM
pavucontrol connection refused johnh10000 Linux - Newbie 3 04-24-2011 03:11 PM
open suse 10.3 work but no sound agussuwarso Linux - Newbie 1 03-16-2008 08:10 AM
Loading sound modules in order ia64processor Red Hat 3 01-22-2004 09:21 AM


All times are GMT -5. The time now is 05:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration