LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-03-2010, 11:47 AM   #1
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Rep: Reputation: 0
Question -have read stickies and tutorials no no avail- configuring nvidia 8800gt


I am brand new to linux, and i just installed ubuntu for the first time yesterday after getting tired of my windows. I have a good amount of computing experience, just not much programming or scripting exp.

I got in, got most things working, but when i try to play World of Warcraft on Wine im getting about 1/5 of the fps as i should. When I use the code "glxinfo | grep rendering" I get one line of text, saying:
"Error: unable to open display." I have installed the nvidia 185 driver, recommended by Hardware Drivers. I have the correct desktop resolution, I dont get lag scrolling up and down web pages, but i am assuming DRI is not enabled which is leading to poor performance.

My specs are:
Amd Athlon 64 X2 6000+
Nvidia GeForce 8800GT 512MB
4 gb Patriot Raptor 1066mhz ddr2
500gb corsair black edition hd

I tried to include as much relevant information as I could. I did try searching for this first but had no luck, and the other posts containing 8800GT gfx cards did not help me.

Any information or assistance would be greatly appreciated!

(again, I do not know my way around Ubuntu yet. If you have instructions for me to follow please be very specific. Thanks!)

Last edited by cbruffin; 03-03-2010 at 11:58 AM. Reason: changing title to include additional relevant information.
 
Old 03-03-2010, 11:49 AM   #2
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
I have also seen things said about modules and "compiling the kernal"

I have absolutely no idea what this means.
 
Old 03-03-2010, 12:45 PM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
How to install Nvidia drivers in Ubuntu - http://www.psychocats.net/ubuntu/nvidia

BinaryDriverHowto/Nvidia - Community Ubuntu Documentation - https://help.ubuntu.com/community/Bi...erHowto/Nvidia
 
Old 03-03-2010, 02:43 PM   #4
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,727

Rep: Reputation: 195Reputation: 195
Stickies and tutorials...

Did you see this one too? It is for v.3.2, but there is one for v.3.0

http://appdb.winehq.org/objectManage...sion&iId=17421

The command to check on rendering seems to be this.
Quote:
glxinfo | grep "direct rendering"
You might try again. Have you tried what is mentioned in Step 2: Configuring?

Last edited by thorkelljarl; 03-03-2010 at 02:58 PM.
 
Old 03-03-2010, 03:49 PM   #5
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by craigevil View Post
How to install Nvidia drivers in Ubuntu - http://www.psychocats.net/ubuntu/nvidia

BinaryDriverHowto/Nvidia - Community Ubuntu Documentation - https://help.ubuntu.com/community/Bi...erHowto/Nvidia
This was the first thing I did. The error I posted previously is with the version 185 recommended driver installed. It appears to me that "dri" is somehow not enabled.

Thanks for the reply

Last edited by cbruffin; 03-03-2010 at 03:49 PM. Reason: add driver name
 
Old 03-03-2010, 03:51 PM   #6
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Just to make sure, I am supposed to be entering this code into the text terminal that i reach with <ctrl><alt><f1>, correct?
 
Old 03-03-2010, 03:59 PM   #7
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
NVIDIA/ATI: Make sure you have the proprietary driver for your video card installed, or WoW will not run. Once they are installed, check to see if Direct Rendering is enabled by typing

glxinfo | grep "direct rendering"

Into terminal. If it returns direct rendering: Yes, you're good to go!
This is from the winehq world of warcraft sticky. The problem is it does not tell me how to enable dri if it returns an error or a different message. It just skips to the next steps to take if successful.

Quote:
You might try again. Have you tried what is mentioned in Step 2: Configuring?
I also did this. While this gave me a noticeable fps jump, I am still at about half of the fps I played at on windows 7, and DRI still does not show up as enabled.

Also, is it just me or do graphics look different with opengl enabled?
 
Old 03-03-2010, 07:00 PM   #8
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Bump. Does anyone know a solution to this problem? :/
 
Old 03-04-2010, 02:03 PM   #9
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Bump.

Again any help at all would be greatly apprciated. Surely someone knows how to enable dri?
 
Old 03-05-2010, 11:57 AM   #10
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Bump
 
Old 03-08-2010, 10:57 AM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
You should not be running glxinfo from a console. You should be running it from a terminal inside of your X session.
 
Old 03-08-2010, 01:09 PM   #12
cbruffin
LQ Newbie
 
Registered: Mar 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by adamk75 View Post
You should not be running glxinfo from a console. You should be running it from a terminal inside of your X session.
Thank you for your reply. What exactly does this mean?
 
Old 03-08-2010, 01:42 PM   #13
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I think cbruffin is simply confusing terms; no doubt he used console to refer to the terminal.

Try this from the terminal: sudo nvidia-xconfig, then log out
 
Old 03-08-2010, 02:03 PM   #14
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,727

Rep: Reputation: 195Reputation: 195
What it means...

From the desktop, open a terminal, in KDE it is Konsole, and type glxgears to see the show and read the data. The terminal is running under the X window system and a window manager.

In console mode, entered using the command "init 3" in a terminal after becoming "su", and X is stopped. You will see a black screen with white text and a login prompt.
 
Old 03-08-2010, 02:36 PM   #15
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Originally Posted by jay73 View Post
I think cbruffin is simply confusing terms; no doubt he used console to refer to the terminal.

Try this from the terminal: sudo nvidia-xconfig, then log out
Considering he said:

Quote:
Just to make sure, I am supposed to be entering this code into the text terminal that i reach with <ctrl><alt><f1>, correct?
I do not doubt that he is using the console, and not a terminal in X :-)

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem related about glxinfo direct rendering asinghpu Linux - Newbie 6 03-06-2010 08:23 AM
nvidia xorg.conf OR X windows xorg.conf? machines Slackware 3 04-06-2008 02:10 PM
Configuring xorg.conf galliar Ubuntu 2 09-20-2007 01:01 PM
Direct rendering enabled in Xorg log, disabled in glxinfo alexbaretta Linux - Software 1 06-23-2006 11:04 AM
XFree86 DRI : glxinfo -> Direct rendering : No Muzzy Linux - Hardware 20 05-24-2004 07:03 AM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration