LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2013, 01:15 AM   #1
wdhpr
Member
 
Registered: May 2009
Location: North Coast
Distribution: Ubuntu 10.10
Posts: 32

Rep: Reputation: 1
Lightbulb Has anyone successfully installed Directx 9?


I have never been able to successfully install Directx 9. To be clear I have installed Directx using the line command and Wine Tricks. All the correct files including the .dll files are installed into the .wine windows directories. When I try to execute the dxdiag.exe file found in wine -> drive_c -> windows -> system32 nothing happens.

I have tried several tutorials including the one offered by Dedoimedo How to install DirectX in Linux using Wine . Same results, anyway my games seem to run the same with or without Directx but I may need it when I began to play some of the higher end games on steam although these games will most likely be ported specifically for Linux and wont need Directx installed
 
Old 06-21-2013, 02:39 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,990

Rep: Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448
Only on a old windows OS

Quote:
When I try to execute the dxdiag.exe file found in wine -> drive_c -> windows -> system32 nothing happens
how about using the terminal and finding out what the error is

Code:
wine dxdiag.exe
 
Old 06-21-2013, 03:16 AM   #3
wdhpr
Member
 
Registered: May 2009
Location: North Coast
Distribution: Ubuntu 10.10
Posts: 32

Original Poster
Rep: Reputation: 1
Thank you here is what I got

fixme:win:EnumDisplayDevicesW ((null),0,0x33d6d4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33d5f4,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a760-90c8-11d0-bd43-00a0c911ce86} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {33d9a761-90c8-11d0-bd43-00a0c911ce86} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb41-f175-11d1-a392-00e0291f3959} not found
fixme:devenum:DEVENUM_ICreateDevEnum_CreateClassEnumerator Category {cc7bfb46-f175-11d1-a392-00e0291f3959} not found
fixme:dxdiag:wWinMain Information dialog is not implemented

Last edited by wdhpr; 06-21-2013 at 03:18 AM.
 
Old 06-21-2013, 03:25 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,990

Rep: Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448
what is your 3d card and driver
wine uses openGL2.2+ to software render DirectX
 
Old 06-21-2013, 10:29 PM   #5
wdhpr
Member
 
Registered: May 2009
Location: North Coast
Distribution: Ubuntu 10.10
Posts: 32

Original Poster
Rep: Reputation: 1
This is what I have by way of SIW:

Video Adapter NVIDIA GeForce 210
Code Name GT218
Video Processor GeForce 210
Technology 40 nm
Adapter DAC Type Integrated RAMDAC
PCI ID 0x10DE / 0x0A65 - NVIDIA Corporation / GT218 [GeForce 210]
PCI sub ID 0x3842 / 0x1210 - eVga.com. Corp.
Memory 512 MBytes
Dedicated Video Memory 466 MB (489160704)
Dedicated System Memory 0 MB (0)
Shared System Memory 1783 MB (1870329856)

Thank You
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to know new gcc version installed successfully? chintan_gaurav8 Linux - General 3 06-11-2010 11:13 AM
Has anyone successfully installed and used GnoMenu in Debian? xiqtem Debian 3 11-14-2009 06:10 AM
is it a error , have I successfully installed ust Linux - Software 1 08-12-2008 12:13 AM
xvid installed successfully but xine ... g-string 3 Linux - Software 2 08-16-2005 11:32 AM
Successfully Installed Rhythmbox! THX75 Fedora 10 03-03-2005 03:28 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration