LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2003, 11:05 PM   #1
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Rep: Reputation: 15
Hardware... in Slackware


Hello every1

I m newbie using RH9 desktop. I have just installed Slackware9.1 on my other HDD.. but cant get a hold of things yet....
I don't konw...

1) how to cnfigure my soundcard (Creative SB live 5.1)
RH9 used 2 detect my sound car during installation automatically....

2) how to configure my modem (Connextent chip)
I have the a driver for this but i would still appreciate more advice

3) how to configure my NIC(Realtek chip) and setup IP address and change hostname
RedHat9 had a nice GUI for seting up hostname and IP; it also gave u an option to setup Hostname and IP at very biginning of installation.... but i cant seem to find any such thing in Slackware9.1.

Thanks
 
Old 11-04-2003, 11:59 PM   #2
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
try netconfig for your net card (i think thats it, its been a while since i used slack) as far as your sound card tell us what it is, you have to modprobe for it or else recompile your kernel and what are you having problems with for your driver please be more specific and add a link to the driver/install instructions
 
Old 11-05-2003, 11:43 PM   #3
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello every1
I can't get my three button, single wheel, A4 TECH(PS/2) optical mouse 2 work... well actually it works, except for the scroll wheel. i edited the following lines in xf86config file under the Section "InputDevice"

1) Option "Protocol" "PS/2" to-----------> Option "Protocol" "ImPS/2"

2) I also added the following line...which caused my Xserver not 2 start..... and so i had 2 remove it using vi editor and now it's working fine again but no wheel again........ the line is

Option "ZAxisMapping" "4 5"

So what did i do wrong this time......??

Thanks....
 
Old 11-08-2003, 10:19 AM   #4
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
are you sure you added it in the right spot? could you post the relevant mouse section of your xf86config?
 
Old 11-12-2003, 08:09 PM   #5
exkor5000
Member
 
Registered: Nov 2003
Distribution: Slackware
Posts: 51

Rep: Reputation: 16
so how did you solve the problem with ur SB Live??

im having the same problem under Slack9, and have no idea what to do!!!
but im going crazy here withouth music!! (<- it forces me to login to Windows and play my mp3s from there heh)

Also what and where do u add, to enable the mouse wheel??

about the NetAdapter -> try 'netconfig'.
if you are using ADSL u might have some problems with DNS resolving. in that case goto '/etc/resolve.conf' and add the servers manually.

thnx for ur time.
 
Old 11-12-2003, 11:28 PM   #6
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello X-Core...

Thanks for the advice on ADSL, but....alas! i m not that lucky 2 have ADSL, thanks anyway though :-)

Well the SB Live!

It was a silly mistake on my behalf (u will soon understand what i m talking about).... u c by defautl the volumes r turned down... so all u have 2 do is (i m using KDE desktop) goto "Kmenu->Multimedia->KMix" and u will get a nice Sound Mixer on ur desktop which is pretty similar 2 Windows volume control manager. In Kmix goto "Settings-> Configure Kmix" make sure there is a cross mark placed on the boxes beside 1)show tickmarks, 2)show lables, and press "OK". Now all u have 2 do is raise the VOLUME bar(1st from left) & PCM bar(4th from left). Turn tem up as high as 90%(just 2 make sure that they r working). that should do it..... but befor u exit KMix goto "File-> Save Current Volumes as default" ....if u don't do that then the volumes will b back to their default zero mark, once u restart the PC.

After u r done with this.....

U can also do this.... "right klick on the panel->Add->Applet->KMix Applet" & u should notice a minature colourful version of kmix in ur panel wthi lot of colourful bars... u can u can raise or lower any of them as u like and u can also right-click on a bar and chose to hide it...... u may want to hide all the bars except for VOUME, PCM,MICROPHONE...... but that's upto u....

Let me know if this helped.... i m tired of typing today.... we talk about the mouse
some other time ok-la? :-)
 
Old 11-12-2003, 11:58 PM   #7
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello guys... it's me again.. couldn't resist helping u (X-Core).. :-)

here is another thread the i started before this one it might b helpful...

http://www.linuxquestions.org/questi...5&pagenumber=1

These guys able to fix my mouse... but still im posting an extract from that thread... it might help

*************************
These settings are defined in /etc/X11/XF86Config. The KDE also has a graphical X configuration program, but it will re-create your entire XF86Config file... perhaps you want to create a backup first

Here is my mouse section, I think you'll find something useful in it. Please note that I've changed the identifier.. (it should correspond with the value used in the ServerLayout section!)

code:Section "InputDevice"
Identifier "Wheel_Mouse"
Driver "mouse"

Option "Protocol" "ImPS/2" # PS/2 with wheel ("auto" is supported too)
Option "ZAxisMapping" "4 5" # wheel mouse
Option "Device" "/dev/mouse" # device file

Option "Resolution" "256"

# Option "Protocol" "Xqueue"
# Option "BaudRate" "9600" # Logitech
# Option "SampleRate" "150" # Logitech

Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
# Option "ChordMiddle" # Logitech
EndSection


( type /mouse to search for text in vim, and use "n" to go to the next match.. type :set ignorecase, or :set ic for an incase-sensitive search )

change the mouse protocol version in /etc/rc.d/rc.gpm too. Using two different mouse protocols for the same mouse causes your mouse to jump across the screen. (ImPS/2 and PS/2 really differ) rc.gpm is the bootscript that enables your mouse in the console.
*****************************
enjoy......
 
Old 11-13-2003, 10:37 AM   #8
exkor5000
Member
 
Registered: Nov 2003
Distribution: Slackware
Posts: 51

Rep: Reputation: 16
thnx for the info. i'll try setting my mouse as soon as i'll get to my home computer.

about the SBLive. im having a different problem. i dont think that it was installed during the Slack installation. cause whenever i do something that is related to sound, it says that there is nothing in '/dev/dsp'.

if i'll try to configure the IO manually via the Control Center it keeps telling me that the IO is null and brings me back to noSound.

maybe i'll haveta recompile my Kernel, which i have no idea how to do!!


however thnx for the info. i'll let ya know how the mouse worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware and hardware.... Basslord1124 Slackware 3 03-17-2005 08:50 PM
slackware 10 hardware questions vrln Slackware 4 07-02-2004 01:28 PM
how to see hardware in slackware salahuddin_66 Slackware 9 05-25-2004 03:15 AM
Slackware and hardware configuration c31c Slackware 7 03-10-2004 01:45 PM
will slackware support this hardware? leeman_s Slackware 3 01-19-2003 11:00 PM


All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration