LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2012, 09:33 PM   #1
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Harddrive errors (DRDY abort - I/O error, dev sda, sector 4086)and relevent OS issue


This is 2 questions, but I am pretty sure they are both related:

Q1.) Ubuntu 11.10 all of a sudden stopped loading, The errors it gave on attempting to start where:
Code:
ascupsd not configured, make sure ISCONFIGURED at /etc/default/apcupsd
saned not enabled ---- SANED
                    ..... saned not enabled - /etc/default/saned
rebooted using root shell, and did
$: cd /etc/default/
ls -a

apcupsd was there but wouldn't let me open it: Permission denied - You do not have the permission to use this file.
Same result with saned.

At the same time, Occasionally when I started, Just after the main bios diagnostic it would say:
Broadcom found ...
NO DISKDRIVE DETECTED

A restart would stop that.

Since Ubuntu wouldn't even get to the boot screen I said **** it ... Put in a mint live CD, and formatted and installed that on the whole drive.

Q2.)
Mint starts 1 out of 4 times ... it also is giving me errors:
1.) DRDY error - abort
2.) I/O ERROR, dev sda, sector 4086
3.) ata1.00 - error (I dunno what comes after this I am not quick enough to write it down) ... This error flashes page by page FAST before moving on
4.)Device not found, Did you wait long enough for drive to respond?
5.) Did you wait long enough for root device?


These errors appear at a majority of my startups. However; When I CAN get to mint, I do SMART test (From GUI not command line), and the drive shows as healthy as can be ... 0 errors.

Despite what smart says ... I am thinking it is a HDD issue, if anyone has any ideas I would love to hear them, I'm too broke right now to replace the drive.

Fujitsu lifebook S-series 6240
Code:
uname -a
Linux lifebook 2.6.32-5-686 #1 SMP Wed Jan 12 04:01:41 UTC 2011 i686 GNU/Linux

#This next part is excerpts I figure may be useful from
 dmesg | less
cat /proc/cpuinfo
cat /proc/meminfo
cat /proc/interrupts
cat /proc/ioports #
-----------------------

[    2.667448] ata_piix 0000:00:1f.1: version 2.13
[    2.667472] ata_piix 0000:00:1f.1: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    2.667519] ata_piix 0000:00:1f.1: setting latency timer to 64
[    2.667612] usbcore: registered new device driver usb
[    2.667776] scsi0 : ata_piix
[    2.667938] scsi1 : ata_piix
[    2.668803] ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1410 irq 14
[    2.668807] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1418 irq 15
[    2.668847] ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[    2.668853] ata_piix 0000:00:1f.2: MAP [ P0 P2 -- -- ]
[    2.674684] ata2: port disabled. ignoring.
[    2.852432] ata1.00: configured for UDMA/33
[    3.163779] ata3.00: ATA-7: FUJITSU MHV2060AT PL, 000000A0, max UDMA/100
[    3.163784] ata3.00: 117210240 sectors, multi 16: LBA 
[    3.163800] ata3.00: applying bridge limits
[    3.176428] ata3.00: configured for UDMA/100
[    3.176548] scsi 2:0:0:0: Direct-Access     ATA      FUJITSU MHV2060A 0000 PQ


lspci

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit Ethernet PCI Express (rev 21)
06:03.0 CardBus bridge: O2 Micro, Inc. OZ711MP1/MS1 MemoryCardBus Controller (rev 20)
06:03.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller
06:03.3 Bridge: O2 Micro, Inc. Integrated MS/xD Controller
06:05.0 Network controller: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection (rev 05)
06:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
Anything else that is needed, Don't hesitate to ask.

Last edited by Hevithan; 01-14-2012 at 09:35 PM.
 
Old 01-15-2012, 03:22 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Sounds like your disk is dying. Download the manufacturers diagnosis tool and test the disk.
 
1 members found this post helpful.
Old 01-15-2012, 04:41 PM   #3
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
I downloaded 'Windows Diagnostic Tool Ver. 1.12
(For IDE/ATA/SATA Hard Drives)
', and opened with WINE ... But the drive is not showing. Is that a bad sign, or does it have to do with wine?
 
Old 01-15-2012, 04:46 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
I think that this is an issue with Wine. You should be able to use the DOS version with FreeDOS.
If that doesn't work I would recommend to use the Hitachi Drive Fitness Test, it comes as a bootable ISO and can test drives from all manufacturers.
 
Old 01-15-2012, 04:47 PM   #5
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
Cool, I'll get on that and post back ... Thanks for the help (and the link ... Bookmarked! )
 
Old 01-15-2012, 05:12 PM   #6
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
I right click the .EXE and open with appropriate program ... all I get is:
Code:
Insufficient memory for FJDT program
C:\>


edit: Got the Hitachi tool, Will find a CD to get that onto and post back.

Last edited by Hevithan; 01-15-2012 at 05:14 PM.
 
Old 01-15-2012, 05:14 PM   #7
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Where exactly do you have the program saved at, and how much RAM do you have?
 
Old 01-15-2012, 05:28 PM   #8
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
the fjdt.exe is saved and extracted in downloads.
Dosemu is the program I am running it with. I used package manager to get it.
RAM is 512MB.
 
Old 01-15-2012, 05:31 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
You need to run that on a native system, not an emulator. Neither Wine nor DosEmu/DosBox will work. If you need a native DOS environment you can use FreeDOS for that. <or just use the Hitachi tool, it has DOS already included.
 
Old 01-15-2012, 05:54 PM   #10
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
TobiSGD beat me to it.... You just run it by itself, not within a separate "container," so to speak.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error fsyncing/closing/dev/sda: Input/output error Petalocsta Linux - Laptop and Netbook 2 11-07-2011 06:40 PM
Problem:: end_request: i/o error, dev sda, sector 3285303 NM04 Linux - Newbie 3 02-08-2011 07:37 AM
Can't install: end_request: I/O error, dev sda, sector.... tnandy Linux - Newbie 4 11-26-2007 01:12 PM
I/O error, dev sda, sector 37110615 yashwantpinge Linux - Hardware 1 06-02-2006 07:45 AM
Maxtor Usb harddrive. Buffer I/O error on device sda. sfumato Linux - Hardware 3 12-26-2005 12:38 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration