LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2008, 11:06 AM   #1
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Rep: Reputation: 30
hard drive installed, formated, but won't show up when browsing?


Wow, every time I think I am making progress....

So I got the hard drive installed, Partition Manager sees it, I format it to ext3, close PM, try to browse "places" and can not find it anywhere. Tried to use command line to mount it, tells me can't find it.

I can't figure out how to paste an image (screenshot), so all I can do is try and describe the messages I get.

In Partition Manager I can select /dev/sdb. Then in the window it shows the rectangle, bordered in blue, as /dev/sdb5.

Below that, it shows /dev/sdb1 with a blue box, and states "extended". When I click the arrow, it shows underneath that, /dev/sdb5 with a dark blue box and ext3. So far so good. Under the "partition" menu, "unmount" is gray, so I try to mount the volume.

Open terminal, and try this:

mike@mike-desktop:~$ mount /dev/sdb5
mount: can't find /dev/sdb5 in /etc/fstab or /etc/mtab
mike@mike-desktop:~$ mount /dev/sdb1
mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab
mike@mike-desktop:~$

Man, I think I am starting to understand a little bit of Linux, and I get humbled again.

Anyone tell me what step I am missing here?

Thanks for your time.
 
Old 09-21-2008, 11:11 AM   #2
crabboy
Senior Member
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Try adding a location to mount the file system:

# mount /dev/sdb5 /mnt

without a location mount assumes that you have an entry for it in the fstab.
 
Old 09-21-2008, 11:22 AM   #3
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
Thank You.

It now tells me the volume is mounted,

mike@mike-desktop:~$ sudo mount /dev/sdb5
mount: /dev/sdb5 already mounted or /mnt busy
mount: according to mtab, /dev/sdb5 is already mounted on /mnt
mike@mike-desktop:~$

However, I still can not find the partition to use it.

What to do next?

Much appreciated.
 
Old 09-21-2008, 11:34 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Have you looked at /mnt?
 
Old 09-21-2008, 11:49 AM   #5
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
In filesystem/mnt/lost+found I have a folder with an X through it. I try to open and says I am not the owner (if I am not the owner, who the heck is?), and can not change permissions.

This folder properties show a size of 178.7, which is close to the size of the hard drive.

So is this a permissions/owner issue? Back to the command line?

Thanks for the help!
 
Old 09-21-2008, 11:50 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
root will be the owner.
 
Old 09-21-2008, 12:03 PM   #7
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
Add what exactly is root? Or how do I "access" root?

When I installed I attempted to set my password, and my password works for administrative tasks. So who/what is root?

How do I get Ubuntu to recognize this hard drive and let me use it?

Thanks for the help.
 
Old 09-21-2008, 12:13 PM   #8
Bolsak
LQ Newbie
 
Registered: Sep 2008
Location: United Kingdom
Distribution: Slackware 12.0
Posts: 13

Rep: Reputation: 0
Ubuntu doesn't really have a "root" like normal distros, you have to use the sudo command for everything.
If you mounted the filesystem on /mnt, then that's where all the files should be in your filesystem. Just go to /mnt.
 
Old 09-21-2008, 12:23 PM   #9
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
Please see my post #5. When I go to the mnt folder, it has a folder that I can not open.

Am I supposed to be looking at mnt in the command line and doing something from there?

Thanks for the reply.
 
Old 09-21-2008, 12:29 PM   #10
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 88
The lost+found folder is always owned and accessible only by root, whatever the permissions of the directory containing it. What happens if you try to write to the directiory? e.g.:

touch /mnt/testfile
mkdir /mnt/testdir

Edited to add:
By the way:

root is the Linux-equivalent of Administrator in Windows. As already said, you access root when you type sudo ..., which allows an authorised user to execute a command as root. Ubuntu does not let you log in as root, which is a good thing (seriously) for security reasons.

It also might be helpful to look at the output of df -k which shows the usage of all mounted filesystems.

Last edited by Robhogg; 09-21-2008 at 12:33 PM.
 
Old 09-21-2008, 12:35 PM   #11
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
Those commands worked. Created directory and file in the mnt directory, but still not within the hard drive I can not access.

Thanks for the reply.
 
Old 09-21-2008, 12:38 PM   #12
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by mhg View Post
Those commands worked. Created directory and file in the mnt directory, but still not within the hard drive I can not access
I'm confused, because you appear to contradict yourself. Is the partition mounted on /mnt? Can you post the output of "mount" and "ls -l / | grep mnt" please?
 
Old 09-21-2008, 12:39 PM   #13
Bolsak
LQ Newbie
 
Registered: Sep 2008
Location: United Kingdom
Distribution: Slackware 12.0
Posts: 13

Rep: Reputation: 0
If it's in the directory, it's on the drive. Try unmounting the partition and checking to see if the files are still in /mnt, and then remount it and check again.
 
Old 09-21-2008, 12:47 PM   #14
mhg
Member
 
Registered: Apr 2007
Location: Utah
Distribution: BodhiLinux
Posts: 205

Original Poster
Rep: Reputation: 30
I can not unmount the partition. The partition is displayed in Partition Manager, and has /dev/sdb5 on it. When I select it, and go to the "partition" drop down menu, unmount is grayed out, can not be used.

This leads me to believe this drive is still not mounted.

The folder and file I created using the posted commands, are not within this hard drive. They are on the hard drive that the OS is on. The partition I can not access, is a separate hard drive.

Thanks for the help.
 
Old 09-21-2008, 12:49 PM   #15
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Again I would ask you to post the output of (at least) mount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu: Installed to external hard drive; boot to primary hard drive gives error 22 dcorb62 Linux - General 7 09-05-2007 12:28 AM
Formated hard drive karolyta Linux - Hardware 1 03-25-2006 06:55 AM
So i formated my linux hard drive and tried to reinstall slackware but i get an error gbdavidx Linux - General 10 11-09-2004 05:29 PM
How to I check a Linux formated hard drive for bad sectors NewtoLinuxWorld Linux - Hardware 1 02-27-2004 04:46 AM
Second hard drive doesn't show up GreenerLinux Libranet 4 11-17-2003 05:12 PM


All times are GMT -5. The time now is 06:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration