LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 06-07-2004, 06:41 PM   #1
wrat
Member
 
Registered: May 2004
Posts: 245

Rep: Reputation: 30
hard drive access problem


My 2nd hd was originally ntfs and I could not write to it in linux so I repartitioned it to half ntfs and half ext3 now only root has complete read write access to the ext3 partition. I can access it to read as my user BUT not to write..I tried adding umask=0222 to fstab but then as a user it wont even mount it gives me the error too many mounted file systems..what do I need to do to give my user complete read write access??
 
Old 06-07-2004, 07:44 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
add user to the permissions, and mount it as a user.
 
Old 06-07-2004, 10:23 PM   #3
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
did that but its still mounting the drive as read only for user??? even for folders on the drive that user created
 
Old 06-08-2004, 07:50 AM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
add to the options rw. Also try chmod the files and directories to what ever permissions you want i.e.

chmod -R 766 /mnt/thedisk/
 
Old 06-08-2004, 08:51 AM   #5
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
The problem is your UMASK Value!!

The umask option in mount tells which Bits should *NOT* be set => Inverse Logic.

So umask=0222 means do *not* set the write acess bit for Owner/Group/Other.

In other words: With umask=0222 *no one* is allowed to write.

Try umask =0000 (Allow write access to anyone).

The best would be:

Group all users allowed to access the partition in one group (e.g. users) and then

gid=users umask=0002

So owner and Group members can read/write and others not write

or you may use
gid= users umask=0007

Others can not access the partition at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
user ntfs hard drive access problem Th3_J3st3R Slackware 4 08-28-2005 09:59 PM
Hard Drive Access numbersix Linux - Hardware 4 02-13-2005 03:30 AM
only access 13 gb out of 40 gb hard drive from rh 9.0 shobhit Linux - Hardware 2 08-14-2004 01:39 PM
Grub to access new hard drive and old multi os hard drive ? gedi1 Linux - Hardware 0 06-03-2004 12:01 PM
How Do I Access My New Hard Drive luv5speed Linux - General 11 02-17-2004 05:34 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration