LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-25-2015, 09:23 AM   #1
steinc69
LQ Newbie
 
Registered: Nov 2015
Posts: 3

Rep: Reputation: Disabled
Hard crash after boot message "Error for wireless request "Set Nickname" (8B1C)"


I am writing as a newbie in that this is my first question on this forum, but I have used Slackware since v9.

I recently installed 13.37 on two machines. In one machine I get a hard crash when booting, after it has been set up for wifi. (It was ok before that). The error message is:

Error for wireless request "Set Nickname" (8B1C): SET failed on device wlan0: Operation not supported.

The only place where I found a reference to "Nickname" was in rc.wireless and rc.wireless.conf. I renamed rc.wireless.conf, and I deleted the lines with "Nickname" in them in rc.wireless, but I still get the same error and the crash.

On the second machine, the error also appears during booting, but the boot process goes to completion after the message: wlan0 no private ioctls. The two machines have identical rc.inet1.conf and wpa_supplicant.conf files, following the instructions at

http://alien.slackbook.org/dokuwiki/...reless_network

There is a suggestion in

http://www.linuxquestions.org/questi...1-conf-800035/

to bring up wlan0 manually, without using rc.inet1.conf, which I have not tried yet. Do you have any other suggestions?

Thank you.
 
Old 11-29-2015, 07:12 AM   #2
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Rep: Reputation: 40
On looking around the internet for this error it appears to be quite a common occurance and also quite benign.

are there any other error messages accompanying this one? i can't for the life of me imagine a linux system hanging because it can't give a wifi interface a nickname
 
Old 12-02-2015, 09:44 AM   #3
steinc69
LQ Newbie
 
Registered: Nov 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
Well, I have looked around also, and in my case the error is not benign.

Here are excerpts of the messages from the two machines:

The machines which connects to wifi:
-----------------------------------
Nov 24 15:32:56 N&Bmatsci kernel: [ 24.645784] lp0: using parport0 (interrupt-driven).
Nov 24 15:32:56 N&Bmatsci kernel: [ 24.645873] lp0: console ready
Nov 24 15:32:57 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/ifconfig lo 127.0.0.1
Nov 24 15:32:57 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 mode Managed
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 nick N&Bmatsci
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 channel auto
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 rate 54M auto
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 essid "XXXXXXXX"
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: '/sbin/iwpriv wlan0 set AuthMode=WPAPSK'
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: '/sbin/iwpriv wlan0 set EncrypType=TKIP'
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: '/sbin/iwpriv wlan0 set WPAPSK=XXXXXXXX'
Nov 24 15:33:01 N&Bmatsci logger: /etc/rc.d/rc.M: wpa_supplicant -B -c/etc/wpa_supplicant.conf -Dwext -iwlan0
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.110657] cfg80211: Calling CRDA for country: US
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118967] cfg80211: Regulatory domain changed to country: US
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118976] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118980] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118985] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118989] (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118992] (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.118996] (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 24 15:33:04 N&Bmatsci kernel: [ 37.119000] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Nov 24 15:33:08 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/dhcpcd -t 10 -h Netgear3m wlan0
Nov 24 15:33:08 N&Bmatsci dhcpcd[1558]: version 5.2.11 starting
Nov 24 15:33:08 N&Bmatsci dhcpcd[1558]: wlan0: broadcasting for a lease
Nov 24 15:33:09 N&Bmatsci dhcpcd[1558]: wlan0: offered 192.168.1.4 from 192.168.1.1
Nov 24 15:33:09 N&Bmatsci dhcpcd[1558]: wlan0: acknowledged 192.168.1.4 from 192.168.1.1
Nov 24 15:33:09 N&Bmatsci dhcpcd[1558]: wlan0: checking for 192.168.1.4
Nov 24 15:33:15 N&Bmatsci dhcpcd[1558]: wlan0: leased 192.168.1.4 for 86400 seconds
Nov 24 15:33:15 N&Bmatsci dhcpcd[1558]: forked to background, child pid 1587
Nov 24 15:33:15 N&Bmatsci kernel: [ 48.147124] NET: Registered protocol family 10
Nov 24 15:33:15 N&Bmatsci kernel: [ 48.147434] lo: Disabled Privacy Extensions
Nov 24 15:33:15 N&Bmatsci sshd[1618]: Server listening on 0.0.0.0 port 22.
Nov 24 15:33:15 N&Bmatsci sshd[1618]: Server listening on :: port 22.


The machine which does not connect to wifi:
------------------------------------------
Dec 1 08:53:04 N&Bmatsci kernel: [ 85.144833] lp0: using parport0 (polling).
Dec 1 08:53:04 N&Bmatsci kernel: [ 85.144933] lp0: console ready
Dec 1 08:53:04 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/ifconfig lo 127.0.0.1
Dec 1 08:53:04 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
Dec 1 08:53:07 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.1.1 metric 1
Dec 1 08:53:07 N&Bmatsci logger: SIOCADDRT: No such process
Dec 1 08:53:08 N&Bmatsci kernel: [ 93.249261] NET: Registered protocol family 10
Dec 1 08:53:08 N&Bmatsci kernel: [ 93.250106] lo: Disabled Privacy Extensions
Dec 1 08:53:08 N&Bmatsci sshd[1457]: Server listening on 0.0.0.0 port 22.
Dec 1 08:53:08 N&Bmatsci sshd[1457]: Server listening on :: port 22.
Dec 1 09:04:46 N&Bmatsci shutdown[1619]: shutting down for system reboot
Dec 1 09:04:46 N&Bmatsci init: Switching to runlevel: 6
Dec 1 09:04:53 N&Bmatsci sshd[1457]: Received signal 15; terminating.
Dec 1 09:04:53 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/dhcpcd -k -d wlan0
Dec 1 09:04:54 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/ifconfig lo down
Dec 1 09:04:54 N&Bmatsci exiting on signal 15
 
Old 12-05-2015, 10:46 PM   #4
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Rep: Reputation: 40
This looks like it could be your main offender here, it's complaining that it's unable to set the default gateway because it doesn't know where that gateway is yet, it doesn't have an IP address for context

Code:
Dec 1 08:53:07 N&Bmatsci logger: /etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.1.1 metric 1
Dec 1 08:53:07 N&Bmatsci logger: SIOCADDRT: No such process
try changing the order of the lines in your /etc/rc.d/rc.inet1 script from
Code:
/sbin/route add default gw 192.168.1.1 metric 1
/sbin/dhcpcd -k -d wlan0
to

Code:
#/sbin/route add default gw 192.168.1.1 metric 1
/sbin/dhcpcd -k -d wlan0
EDIT: On further consideration dhcpcd should automatically add the default route, so the default route command is redundant unless you're setting a static IP

EDIT2: On the machine that's not connecting, there's no wireless negotiation with wpa_supplicant before running dhcpcd, so dhcpcd is going to fail outright because the link is not active

Last edited by Person_1873; 12-05-2015 at 10:56 PM.
 
Old 12-12-2015, 10:29 AM   #5
steinc69
LQ Newbie
 
Registered: Nov 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. I also noticed that wpa_supplicant does not get run from the rc.inet1 script. Moreover, I am uable to run wpa_supplicant manually. At this point, I don't know what to do other than a reinstall, hoping that it will all work after that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error for wireless request "Set Nickname" (8B1C) flokofcgulls Slackware 6 05-15-2013 04:29 PM
Error for wireless request "Set Nickname" (8B1C) -- /etc/rc.d/rc.inet1.conf hellbillyJoker Linux - Networking 1 04-06-2010 07:24 PM
Fedora 10 iwconfig error: Error for wireless request "Set Encode" (8B2A) :SET failed mishkind Linux - Laptop and Netbook 2 05-10-2009 02:43 PM
Error for wireless request "Set Nickname" robogymnast Linux - Wireless Networking 5 09-23-2008 07:26 AM
Wireless autoconnect (error for wireless request "set Nickname" (8B1C)) hellasyoda Slackware 7 05-19-2008 01:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration