LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   haproxy (http://www.linuxquestions.org/questions/linux-newbie-8/haproxy-814649/)

agarwalpranay 06-17-2010 02:18 AM

haproxy
 
Hi, I am using haproxy for the first time.I downloaded the latest version 1.4.7 and then unpacked it.then opened the terminal and wrote the command
$make -f Makefile.bsd REGEX=pcre DEBUG= COPTS.generic="-Os -fomit-frame-pointer -mgnu"
After which an executable haproxy file was created which I copied to /usr/local/sbin.
then i wrote $sudo make install
then I make a configuration file in /etc/haproxy.cfg which is as follows

global
maxconn 4096
pidfile /var/run/haproxy.pid
daemon

defaults
mode http
retries 3
option redispatch
maxconn 2000
contimeout 5000
clitimeout 50000
srvtimeout 50000

listen GALAXY 192.168.63.51:8080
mode http
cookie GALAXY insert
balance roundrobin
option httpclose
option forwardfor
stats enable
stats auth myuser:mypass
server EARTH 192.168.63.52:7634 cookie GALAXY_SERVER_01 check
server MOON 192.168.63.53 :7634 cookie GALAXY_SERVER_02 check
But it's not working it is various kind of errors intially it was showing "cannot bind to socket" so tried changing the port number but didn't help
I also used command like $sudo sysctl net.ipv4.ip_nonlocal_bind=1 But didn't help.
Please Help!!!

centosboy 06-17-2010 09:41 AM

Quote:

Originally Posted by agarwalpranay (Post 4006235)
Hi, I am using haproxy for the first time.I downloaded the latest version 1.4.7 and then unpacked it.then opened the terminal and wrote the command
$make -f Makefile.bsd REGEX=pcre DEBUG= COPTS.generic="-Os -fomit-frame-pointer -mgnu"
After which an executable haproxy file was created which I copied to /usr/local/sbin.
then i wrote $sudo make install
then I make a configuration file in /etc/haproxy.cfg which is as follows

global
maxconn 4096
pidfile /var/run/haproxy.pid
daemon

defaults
mode http
retries 3
option redispatch
maxconn 2000
contimeout 5000
clitimeout 50000
srvtimeout 50000

listen GALAXY 192.168.63.51:8080
mode http
cookie GALAXY insert
balance roundrobin
option httpclose
option forwardfor
stats enable
stats auth myuser:mypass
server EARTH 192.168.63.52:7634 cookie GALAXY_SERVER_01 check
server MOON 192.168.63.53 :7634 cookie GALAXY_SERVER_02 check
But it's not working it is various kind of errors intially it was showing "cannot bind to socket" so tried changing the port number but didn't help
I also used command like $sudo sysctl net.ipv4.ip_nonlocal_bind=1 But didn't help.
Please Help!!!


are these ports (7634) listening on the local hosts?
What you have to make sure is that all specified ports are open and listening, and do not already have another service using them..

Can you try and paste some more errors here too...?

agarwalpranay 06-18-2010 12:42 AM

haproxy
 
[ALERT] 168/111156 (28897) : parsing [/etc/haproxy.cfg:24] : server MOON only supports options 'backup', 'cookie', 'redir', 'observer', 'on-error', 'error-limit', 'check', 'disabled', 'track', 'id', 'inter', 'fastinter', 'downinter', 'rise', 'fall', 'addr', 'port', 'source', 'minconn', 'maxconn', 'maxqueue', 'slowstart' and 'weight'.
[ALERT] 168/111156 (28897) : Error(s) found in configuration file : /etc/haproxy.cfg
[ALERT] 168/111156 (28897) : Fatal errors found in configuration.

agarwalpranay 06-18-2010 12:44 AM

I have posted above the errors it is currently showing..but it was showing some other erros too earlier like
System proxy GALAXY :cannot bind to the socket.

I also tried changing the port several times but was of no help.
How to make sure the port I am using is not used by some other services!

centosboy 06-19-2010 01:31 AM

Quote:

Originally Posted by agarwalpranay (Post 4007184)
I have posted above the errors it is currently showing..but it was showing some other erros too earlier like
System proxy GALAXY :cannot bind to the socket.

I also tried changing the port several times but was of no help.
How to make sure the port I am using is not used by some other services!

Code:

Netstat -plant
Or telnet to the port and check response


All times are GMT -5. The time now is 11:30 PM.