LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Had apache working, then set up vsftpd, now apache is refusing my connections (http://www.linuxquestions.org/questions/linux-newbie-8/had-apache-working-then-set-up-vsftpd-now-apache-is-refusing-my-connections-406082/)

beetle_boy66 01-21-2006 03:59 AM

Had apache working, then set up vsftpd, now apache is refusing my connections
 
Let me start by declaring I am a big-time Linux newbie.

I am an amateur self-taught Perl programmer, and I have written several Perl scripts that I use at work to format troubleshooting test results into a format that is convenient to paste into tech support toubleshooting notes.

I have been using Lycos/Tripod's public cgi hosting services to host my scripts, but have recently had need to make use of Perl libraries that Tripod won't allow to execute on their servers.

So, I built myself a simple Linux based PC so I could host the scripts myself and run whatever Perl libraries I wish.

I downloaded Fedora Core 4, installed it on the PC I built, managed to get Apache up and running, and was able to sucessfully call and execute my Perl scripts over the web from work. All fine and dandy.

Then I decided to get fancy and set up vsftpd so I could modify my scripts and my html remotely from work. This is where my problems began.

Now before y'all rip me apart, remember I am a newbie to Linux..

I set up two users:
a user with a home directory of /var/www/cgi-bin/foobar,
a user with a home directory of /var/www/html/foobar

After I set up these two users, I chroot'ed them to their home directories.

At this point I discovered that Apache would no longer serve any web documents, telling me that "The connection was refused while attempting to connect to..."

At this point I got desperate and stupid and in a fit of ignorance, deleted the users I created and changed all the file ownerships and file permissions back to what I thought they should be.

I went on a Google frenzy looking for information of how to correct the problem, and tried several solutions, changing file permissions and ownerships like a wild man, but I still can't get Apatche to serve any documents. Now it's messed up so bad I don't have a CLUE what they need to be to fix the issue with Apache.

What should the /var/www directories have set for file permissions, and what should the /var/www file ownerships be set to, and what group and owner should Apache be set to in order to allow Apache to operate again?

I have tried to telnet to "localhost 80", connection refused.
I have tried to browse to localhost and 127.0.0.1, connection refused.

I know I did something stupid (feel free to tell me so..) but how can I fix it?

beetle_boy66

saman007uk 01-21-2006 04:04 AM

Post your logs please. The logs are normally in /var/log/apache or /var/log/httpd.

You should not use terlnet, but SSH v2 as telent has huge security risks.

My feeling is that the chrooting is what caused the problem. How did you exactly "chroot" the users to their homedirectories? More information is needed on exactly what file premissions you used, etc.

beetle_boy66 01-22-2006 04:02 AM

Quote:

Originally Posted by saman007uk
You should not use telnet, but SSH v2 as telnet has huge security risks.

I wasn't trying to access the web server via telnet, I was just using the connection to test whether or not Apache was up and running. My test verified that it was indeed running, and it wasn't accepting users from port 23 either. And I was on the host machine... is there a sequrity risk using telnet from localhost?



Quote:

Originally Posted by saman007uk
My feeling is that the chrooting is what caused the problem. How did you exactly "chroot" the users to their homedirectories? More information is needed on exactly what file premissions you used, etc.

I attempted to "jail" the two users I created into their home directories by adding the lines below to the vsftp.conf file:

<B><I>code snippet:
</B>chroot_list_file=/etc/vsftpd.chroot_list</I>

vsftpd.chroot_list:
watts_cgi
watts_html

I set up two users:
a user with a home directory of /var/www/cgi-bin/watts.9,
a user with a home directory of /var/www/html

And when I created the users, those directories got their ownership changed so they owned the directories serving as their home directories




Quote:

Originally Posted by saman007uk
Post your logs please. The logs are normally in /var/log/apache or /var/log/httpd.

Here are my configuration and log files:

vsftp.conf
##########
# =========================================================================
# base configuration
# -------------------------------------------------------------------------
anonymous_enable=YES
#chroot_local_user=YES

chroot_list_file=/etc/vsftpd.chroot_list # Here is where I specified the users to be chroot'ed
# to their respective home directories
guest_enable=YES
guest_username=ftp
hide_ids=YES
listen=YES
listen_address=192.168.0.1
local_enable=YES
max_clients=100
max_per_ip=1
nopriv_user=ftp
pam_service_name=ftp
pasv_max_port=65535
pasv_min_port=64000
session_support=NO
use_localtime=YES
user_config_dir=/etc/vsftpd/users
userlist_enable=YES
userlist_file=/etc/vsftpd/denied_users
virtual_use_local_privs=YES
xferlog_enable=YES
# -------------------------------------------------------------------------


# =========================================================================
# ftp settings
# -------------------------------------------------------------------------
async_abor_enable=YES
connect_from_port_20=YES
dirlist_enable=NO
download_enable=NO
local_umask=0027
# =========================================================================



vsftpd.chroot_list.conf
####################### This is a file containing the users to be "jailed"
watts_cgi
watts_html


httpd error_log.1
#################
[Wed Jan 18 05:13:26 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Wed Jan 18 05:13:26 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Wed Jan 18 05:14:02 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Wed Jan 18 06:12:02 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl
[Wed Jan 18 06:12:03 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?
[Wed Jan 18 06:12:13 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl
[Wed Jan 18 06:12:15 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?
[Wed Jan 18 06:12:16 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl
[Wed Jan 18 06:12:20 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?
[Wed Jan 18 06:12:33 2006] [error] [client 24.145.140.16] Invalid URI in request GET /../images/watts.9/calltech.jpg HTTP/1.1, referer: http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl
[Wed Jan 18 06:13:51 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/images/watts.9/calltech.jpg">
#
#
#
#
#
#
#
#
[Wed Jan 18 06:46:22 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Wed Jan 18 23:41:39 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/awstats
[Wed Jan 18 23:41:40 2006] [error] [client 200.41.104.87] script not found or unable to stat: /var/www/cgi-bin/awstats.pl
[Wed Jan 18 23:41:41 2006] [error] [client 200.41.104.87] script not found or unable to stat: /var/www/cgi-bin/awstats
[client 200.41.104.87] script '/var/www/html/xmlrpc.php' not found or unable to stat
[Wed Jan 18 23:41:44 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/blog
[Wed Jan 18 23:41:45 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/blog
[Wed Jan 18 23:41:47 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/blogs
[Wed Jan 18 23:41:48 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/drupal
[Wed Jan 18 23:41:49 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/phpgroupware
[Wed Jan 18 23:41:50 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/wordpress
[client 200.41.104.87] script '/var/www/html/xmlrpc.php' not found or unable to stat
[Wed Jan 18 23:41:53 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/xmlrpc
[Wed Jan 18 23:41:54 2006] [error] [client 200.41.104.87] File does not exist: /var/www/html/xmlsrv
[Thu Jan 19 02:01:26 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Thu Jan 19 02:01:26 2006] [error] [client 24.145.140.16] File does not exist: /var/www/html/favicon.ico
[Thu Jan 19 03:37:53 2006] [warn] child process 3524 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3525 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3526 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3527 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3528 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3529 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3530 still did not exit, sending a SIGTERM
[Thu Jan 19 03:37:53 2006] [warn] child process 3531 still did not exit, sending a SIGTERM




















httpd access_log.1

24.145.140.16 - - [18/Jan/2006:05:13:26 -0500] "GET /icons/apache_pb2.gif HTTP/1.1" 304 - "http://24.145.140.16/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:05:13:26 -0500] "GET /icons/powered_by_fedora.png HTTP/1.1" 304 - "http://24.145.140.16/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:05:13:26 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:05:13:26 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
#
#
#
#
# <I>(Edited for length)
# This whole section is just a bunch of calls to
# the server while i was getting all my files set up.</I>
#
#
#
#
#
#
#
24.145.140.16 - - [18/Jan/2006:06:24:03 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
82.158.133.215 - - [18/Jan/2006:06:24:13 -0500] "GET / HTTP/1.0" 200 2249 "-" "-"
24.145.140.16 - - [18/Jan/2006:06:30:59 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1665 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:31:01 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 304 - "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:31:01 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:31:44 -0500] "GET /../images/watts.9/calltech.jpg HTTP/1.1" 400 335 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
24.145.140.16 - - [18/Jan/2006:06:31:46 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1665 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
24.145.140.16 - - [18/Jan/2006:06:31:46 -0500] "GET /../../images/watts.9/calltech.jpg HTTP/1.1" 400 335 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
#
#
#
# <I>Here is when everything was set up and I was calling my perl scripts from Firefox, using
# my ISP assigned IP. I wanted to be sure my router's virtual server was correctly serving
# calls to port 80 to my Linux box.</I>
#
#
#
24.145.140.16 - - [18/Jan/2006:06:35:37 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 500 643 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:35:39 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:03 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1672 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:04 -0500] "GET /cgi-bin/watts.9/24.145.140.16/images/watts.9/calltech.jpg HTTP/1.1" 404 364 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:05 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:53 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 304 - "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:58 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1672 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:36:59 -0500] "GET /cgi-bin/watts.9/24.145.140.16/images/watts.9/calltech.jpg HTTP/1.1" 404 364 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:37:00 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:37:21 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1679 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:37:22 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 304 - "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:37:23 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [18/Jan/2006:06:38:57 -0500] "GET / HTTP/1.1" 200 2249 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
24.145.140.16 - - [18/Jan/2006:06:38:57 -0500] "GET /icons/powered_by_fedora.png HTTP/1.1" 200 2243 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
24.145.140.16 - - [18/Jan/2006:06:38:57 -0500] "GET /icons/apache_pb2.gif HTTP/1.1" 200 2414 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
24.145.140.16 - - [18/Jan/2006:06:38:59 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1679 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
#
#
#
# <I> Below is where I was accessing my web server from work</I>
#
#

216.69.223.203 - - [18/Jan/2006:15:58:29 -0500] "GET / HTTP/1.1" 200 2249 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:58:30 -0500] "GET /icons/apache_pb2.gif HTTP/1.1" 200 2414 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:58:30 -0500] "GET /icons/powered_by_fedora.png HTTP/1.1" 200 2243 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:58:37 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl HTTP/1.1" 200 1679 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:58:39 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 200 8192 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:59:01 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2274 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:15:59:04 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
24.219.55.170 - - [18/Jan/2006:16:00:42 -0500] "GET / HTTP/1.0" 200 2249 "-" "-"
24.81.145.114 - - [18/Jan/2006:16:11:44 -0500] "GET / HTTP/1.0" 200 2249 "-" "-"
216.69.223.203 - - [18/Jan/2006:16:20:50 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2359 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:16:40:47 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:16:40:49 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:16:44:57 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:16:47:05 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:16:47:08 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:05:16 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2471 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:05:19 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:22:06 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2401 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:22:09 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:53:49 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2401 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:17:59:22 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:18:28:49 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:18:49:44 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:18:49:45 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 200 8192 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:18:49:46 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
82.159.54.167 - - [18/Jan/2006:18:50:12 -0500] "GET / HTTP/1.0" 200 2249 "-" "-"
216.69.223.203 - - [18/Jan/2006:19:10:46 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:19:10:47 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:00:28 -0500] "GET / HTTP/1.1" 200 2249 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:00:28 -0500] "GET /icons/apache_pb2.gif HTTP/1.1" 200 2414 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:00:28 -0500] "GET /icons/powered_by_fedora.png HTTP/1.1" 200 2243 "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:18:06 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:18:07 -0500] "GET /images/watts.9/calltech.jpg HTTP/1.1" 200 8192 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:18:09 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2401 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:21:41 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:21:42 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:41:50 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:41:52 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:21:41:54 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:22:03:42 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2366 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:22:03:44 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:22:51:30 -0500] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:22:51:30 -0500] "GET /icons/apache_pb2.gif HTTP/1.1" 304 - "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:22:51:30 -0500] "GET /icons/powered_by_fedora.png HTTP/1.1" 304 - "http://24.145.140.16/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:23:04:00 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1" 200 2471 "http://24.145.140.16/cgi-bin/watts.9/input_nxtt.pl?" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:23:13:55 -0500] "GET /cgi-bin/watts.9/input_nxtt.pl? HTTP/1.1" 200 1679 "http://24.145.140.16/cgi-bin/watts.9/format_nxtt.pl" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)"
216.69.223.203 - - [18/Jan/2006:23:13:57 -0500] "POST /cgi-bin/watts.9/format_nxtt.pl HTTP/1.1"
24.4.252.29 - - [19/Jan/2006:00:56:20 -0500] "GET / HTTP/1.0" 200 2249 "-" "-"
#
#
#
#

# <I>Back home that night</I>
#
24.145.140.16 - - [19/Jan/2006:02:01:25 -0500] "GET / HTTP/1.1" 304 - "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [19/Jan/2006:02:01:26 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
24.145.140.16 - - [19/Jan/2006:02:01:26 -0500] "GET /favicon.ico HTTP/1.1" 404 318 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4"
#
#
# And that was it. It didn't work after this.
# Calls to apache don't even make
# to the logs ever since I killed it.

btmiller 01-22-2006 11:39 AM

If you're getting connection refused when telneting to port 80, then chances are that Apache has stopped running. Try doing "service httpd restart" and see if it starts up OK.

beetle_boy66 01-25-2006 08:57 PM

Quote:

Originally Posted by btmiller
Try doing "service httpd restart" and see if it starts up OK.

That was all it was! All the time and energy I spent... And Apache wasn't even running..

I'm not sure how the service got turned off, but I turned it back on in the Gnome based services panel, and now it's up and running again.

Thanks!


All times are GMT -5. The time now is 03:37 PM.