LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-13-2008, 03:04 PM   #1
aio85
LQ Newbie
 
Registered: Jan 2008
Posts: 2

Rep: Reputation: 0
Gutsy wireless connection does not work/ wired works


Hello, I'm new to Linux. I just installed the Ubuntu Gutsy distro.

I'm having Trouble accessing my wireless internet connection even though my wired connection works fine. At the top right corner, I can view my SSID but cannot connect wirelessly. Linux tries connecting wirelessly, then ultimately settles on the wired connection (which seems to work).

I've tried physically disconnecting my wired connection because I've heard there might be issues having a wired and wireless connection. Also I've tried to manually connect to the wireless connection by accessing System > Administration > Network

In the 'Connections' tab, I've selected 'Wireless Connection' and clicked 'Properties.' Under WIRELESS SETTINGS> I've set my ESSID to NETGEAR; set password type to WPA personal; left the password field empty because I do not have a WPA security-enabled network. Under CONNECTION SETTINGS> Automatic Configuration DHCP

Some relevant info:

PC: Dell Dimension 4600
wireless card: DWL G510
02:01.0 Ethernet controller: Atheros Communications, Inc. AR2413 802.11bg NIC (rev 01)
02:02.0 Modem: Broadcom Corporation BCM4212 v.90 56k modem (rev 02)
02:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)


----------- ROUTER CONFIGURATION SETTINGS ------------

Netgear Wireless Router
ESSID: NETGEAR
REGION: CANADA
CHANNEL: 11

Wireless Access Point
[x] Enable Access Point
[x] Allow Broadcast of Name (SSID)

Wireless Card Access List
MAC Address of wireless card has been inputted

Security Encryption WEP
Authentication Type: Automatic
Encryption Strength: Disable

-------------------------------------------

Code:
aio85@milkyway:~$ ifconfig
ath0      Link encap:Ethernet  HWaddr 00:13:46:E8:F1:36  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:4257 (4.1 KB)

ath0:avah Link encap:Ethernet  HWaddr 00:13:46:E8:F1:36  
          inet addr:169.254.8.42  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth0      Link encap:Ethernet  HWaddr 00:07:E9:4D:93:64  
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::207:e9ff:fe4d:9364/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:19924 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8780 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7101397 (6.7 MB)  TX bytes:1618571 (1.5 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10597 (10.3 KB)  TX bytes:10597 (10.3 KB)

wifi0     Link encap:UNSPEC  HWaddr 00-13-46-E8-F1-36-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:68535 errors:0 dropped:0 overruns:0 frame:8102
          TX packets:2028 errors:10 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:5152072 (4.9 MB)  TX bytes:97465 (95.1 KB)
          Interrupt:22

-------------------------------------------

Code:
aio85@milkyway:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"NETGEAR"  Nickname:""
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:18 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/70  Signal level=-85 dBm  Noise level=-85 dBm
          Rx invalid nwid:65801  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Information posted in madwifi on the DWL G510

Last edited by aio85; 01-13-2008 at 03:37 PM.
 
Old 01-13-2008, 05:23 PM   #2
wildcat22
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu
Posts: 102

Rep: Reputation: 15
If you aren't using a WPA protected network, then you probably shouldn't be setting the password type to WPA personal. There should be a "None" option. Try using that instead. Unless I'm remembering wrong...
 
Old 01-13-2008, 09:50 PM   #3
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
I'd unplug the wired Ethernet connection if you're trying to get the wireless to work. Using two NICs to access the same subnet can cause problems.
 
Old 01-13-2008, 10:46 PM   #4
aio85
LQ Newbie
 
Registered: Jan 2008
Posts: 2

Original Poster
Rep: Reputation: 0
hey wildcat22, there is no 'none' selection under password type.

pentode, i tried to physically disconnect my lan cable from the socket and tried subsequently to connect to the SSID wireless network (which ironically is found).

anyone have any ideas? this is critical.

Last edited by aio85; 01-13-2008 at 10:47 PM.
 
Old 01-14-2008, 11:52 AM   #5
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Run the commands (as root) ifconfig and iwconfig again and post the results. I'd leave the Ethernet port unplugged until you get wireless working.

Can you turn off security on the router temporarily?
 
Old 01-14-2008, 01:14 PM   #6
wildcat22
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu
Posts: 102

Rep: Reputation: 15
Have you checked out Ubuntu's Docs to look for ideas there?

Check this for starters: https://help.ubuntu.com/community/WifiDocs/WiFiHowTo
And there are links for cards similar to yours here: https://help.ubuntu.com/community/TitleIndex under Wifi/DWL

I agree with pentode, as a sanity check, turn off the security on the router, and/or try different combinations of authentication/encryption.

You also might try completely disabling the wired connection, rather than just unplugging it, just to make sure.

That's all I have at the moment...
 
  


Reply

Tags
connection, gutsy, networking, router, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 06:55 PM
Unable to connect to internet via wireless OR wired connection frznchckn Linux - Wireless Networking 5 06-19-2008 02:12 PM
Wired Linksys router - works...wireless-g no go. mynameshagop Linux - Newbie 11 01-11-2006 06:10 AM
suse 9.3 no (wired or wireless) intrernet connection k0rson Linux - Wireless Networking 2 11-14-2005 06:45 PM
Wireless vs wired connection on same laptop rps63ifid Fedora 7 02-02-2005 10:38 PM


All times are GMT -5. The time now is 10:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration