LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2014, 04:01 PM   #1
JeremyBoden
Member
 
Registered: Nov 2011
Posts: 939

Rep: Reputation: 174Reputation: 174
Wink GUI shutdown from XFCE (Debian) does not work


Shutdown button (and logout too) ignored on Debian+XFCE on ancient laptop.

Workround of
Code:
gksu init 0
gives a clean shutdown, but other family users would not be able to cope with this.
 
Old 07-02-2014, 04:01 PM   #2
Germany_chris
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 1,021

Rep: Reputation: 479Reputation: 479Reputation: 479Reputation: 479Reputation: 479
did you add yourself to the power group?
 
Old 07-02-2014, 06:10 PM   #3
JeremyBoden
Member
 
Registered: Nov 2011
Posts: 939

Original Poster
Rep: Reputation: 174Reputation: 174
I didn't have a power group, so I created one
Code:
groupadd -g 2000 power
(on second thoughts, I'm probably not allowed to choose my own gid).
I added myself with
Code:
usermod -a -G power jeremy
and removed any group password with
Code:
gpasswd -r power
Final result is
Code:
~$ id jeremy
uid=1000(jeremy) gid=1000(jeremy) groups=1000(jeremy),27(sudo),2000(power)
But shutdown etc still doesn't work.
 
Old 07-02-2014, 08:02 PM   #4
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 517

Rep: Reputation: 177Reputation: 177
Try adding acpi=force as a kernel command line parameter.

link - bottom of page.
 
Old 07-03-2014, 09:46 AM   #5
JeremyBoden
Member
 
Registered: Nov 2011
Posts: 939

Original Poster
Rep: Reputation: 174Reputation: 174
Sad to say, this didn't work.

I altered the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub from
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
to
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=force"
and ran update-grub (and rebooted).

acpi appears to be running on the laptop:-
Code:
jeremy@dalek:~$ acpi -V
Battery 0: Charging, 95%, charging at zero rate - will never fully charge.
Battery 0: design capacity 2000 mAh, last full capacity 2000 mAh = 100%
Adapter 0: on-line
Cooling 0: Processor 0 of 0
Perhaps I should just write a suid script?

Last edited by JeremyBoden; 07-03-2014 at 09:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] XFCE 4.6 Cannot shutdown, reboot or suspend system from XFCE lpallard Slackware 17 11-04-2012 07:17 PM
logout before shutdown with shutdown button in XFCE ta0kira Ubuntu 2 06-25-2011 05:57 AM
No GUI after Debian-xfce install navy80 Linux - Newbie 18 04-13-2009 07:25 PM
User shutdown - 'cp -i -p shutdown /usr/sbin/shutdown2 - why does this not work, can? mitchellray Linux - Desktop 4 03-20-2009 10:31 PM
xfce panel stopped to work. Debian lenny kaz2100 Debian 3 11-11-2008 10:51 PM


All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration