LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2004, 06:41 PM   #1
eddieman
LQ Newbie
 
Registered: Dec 2003
Distribution: Mandrake 9.2
Posts: 28

Rep: Reputation: 15
GUI Problems In VectorLinux


Well I sucessfully installed VectorLinux...install was easy enough...and it's being dual boot with XP.

Here is where the problem starts. After logging in as root, and making a root pw, I ran VASM to configure the options.

When I try to set up X-Windows...all the options I choose I don't think it's accepting. My wheel mouse and keyboard get set up fine, but the monitor settings and graphic card settings doesn't seem to be taking effect.

When I type "startx", the resolution gets resized to 640*480 and it's in 256 colours. Everythings looks SO CRAPPY!!! It's such a turn off to work in. Then why I load up Firebird and type in a web address you can barely see the text.

I find this odd since in the setup my graphic card is apparently supported. As for monitor, I know mine can do a max of 1280*1024 at 60hz, so I chose that option. I chose 24 bit as my colour depth.
One thing I find puzzling, is when it asks you to choose a resolution. There is already in X inside 640*480, but I move over to the 1024*768 one and push enter. I hope that's right, unless there is some other button I should push.

Why won't it apply any of my options? HELP!!! Sooner I can get this working...sooner I can start learning Linux more.

If my hardware specs help:

Daytek 17in 77A Monitor (Max resolution 1280*1024)
NVidia GeForce 4 Ti 4200 (8x AGP)
 
Old 01-02-2004, 06:47 PM   #2
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
can you post your /etc/X11/XF86-config file (im assuming thats where that file is located on your system) here, in case you cant fix the problem by modifying that file?

oh yeah, youll need root permission to modify that file
 
Old 01-02-2004, 06:49 PM   #3
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
hi ^^
post /etc/X11/XF86Config
to let us know whats going on....
or....
get the official linux drivers from http://www.nvidia.com/object/linux.html
compile the kernel interface, edit XF86Config according to their instructions....
this sometimes helps....
note: don't do it if you have kernel 2.6.0 running....
or....
just try to edit your XF86Config and replace theese lines in your Screen Section with the following:
Code:
    DefaultDepth 16

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
and see if it works

Last edited by poison; 01-02-2004 at 07:01 PM.
 
Old 01-02-2004, 06:52 PM   #4
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
Quote:
Originally posted by poison
note: don't do it if you have kernel 2.6.0 running.... [/B]
hey poison, i hope you know that you can get it working on 2.6 using the patches from minion?
 
Old 01-02-2004, 06:54 PM   #5
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
Quote:
hey poison, i hope you know that you can get it working on 2.6 using the patches from minion?
yes...I can....but I made some _really_ bad experienced regarding stability ^^
 
Old 01-02-2004, 07:02 PM   #6
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
really? it seems to be working fine for me so far (its been a while now).
i have ONE niggling problem (but it was there even on 2.4). no text console on F1..F6. its reallly a big problem for me.
 
Old 01-02-2004, 07:06 PM   #7
eddieman
LQ Newbie
 
Registered: Dec 2003
Distribution: Mandrake 9.2
Posts: 28

Original Poster
Rep: Reputation: 15
How would I get access to that file to post it?

I know that sounds like a really newbie question...but...I'm COMPLETELY new to linux...heh...I managed to sucessfully partition and install it without much worries...as for being familar with it...not yet

If someone can give me a rundown of what to do I'll be happy to post it
 
Old 01-02-2004, 07:17 PM   #8
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
1. open up your terminal.
2. become root (if you aren't already) by typing in "su", and then the password.
3. goto that directory by typing in "cd /etc/X11"
4. when you do a "ls", you'll see the file that we mentioned (XF86whatever)
5. copy that file out into your user directory by typing in "cp XF86whatever /home/userdir"
6. goto your user dir (/home/userdir) by typing in "cd /home/userdir"
7. give yourself permissions to it by typing in "chmod 755 XF86whatever"
8. get out of root by typing "exit".

this will leavethat file in your home dir and will let you open it for reading, which you can do with your browser or whatever and post here.

of course, XF85whatever will be the actual name of the file you see in the /etc/X11 folder and userdir is your actual home dir

Last edited by h/w; 01-02-2004 at 10:07 PM.
 
Old 01-02-2004, 07:25 PM   #9
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
Quote:
i have ONE niggling problem (but it was there even on 2.4). no text console on F1..F6. its reallly a big problem for me.
do you boot into runlevel 4 ? ^^
change /etc/inittab
 
Old 01-02-2004, 07:28 PM   #10
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
Quote:
Originally posted by poison
do you boot into runlevel 4 ? ^^
change /etc/inittab
nope, im on runlevel 2. if you have those consoles while using the nvidia drivers, could you also post your xf86config file for me? (sorry to meddle in your thread eddieman)
 
Old 01-02-2004, 07:42 PM   #11
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
also sorry eddieman ^^
sorry....runlevels seem to be used very different accross distris....
I don't think my XF86Config will be of any use to get you extra terminals....since the agettys should be started by init...
I can post you my /etc/inittab, but I assume _you know_ you can't just copy it to yours...
I boot into runlevel 3 (multiuser mode / standard console getties, 12 of them ^^)
Code:
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Version:      @(#)inittab             2.04    17/05/93        MvS
#                                       2.10    02/10/95        PV
#                                       3.00    02/06/1999      PV
#                                       4.00    04/10/2002      PV
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by:  Patrick J. Volkerding, <volkerdi@slackware.com>
#

# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6

# What to do when power fails.
pf::powerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg::powerokwait:/sbin/genpowerfail stop

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:1235:respawn:/sbin/agetty 38400 tty6 linux
c7:1235:respawn:/sbin/agetty 38400 tty7 linux
c8:1235:respawn:/sbin/agetty 38400 tty8 linux
c9:1235:respawn:/sbin/agetty 38400 tty9 linux
c10:1235:respawn:/sbin/agetty 38400 tty10 linux
c11:1235:respawn:/sbin/agetty 38400 tty11 linux
c12:12345:respawn:/sbin/agetty 38400 tty12 linux

# Runlevel 4 used to be for an X window only system, until we discovered
# that it throws init into a loop that keeps your load avg at least 1 all
# the time. Thus, there is now one getty opened on tty6. Hopefully no one
# will notice. ;^)
# It might not be bad to have one text console anyway, in case something
# happens to X.
x1:4:wait:/etc/rc.d/rc.4

# End of /etc/inittab
notice the line:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux

the getty on tty1 is active in the runlevels 1,2,3,5

I hope you get it ^^

sorry....I forgot to mention: you know you have to press ctrl+alt+F* when under X to reach those consoles instead of just alt+F*

Last edited by poison; 01-02-2004 at 07:51 PM.
 
Old 01-02-2004, 07:47 PM   #12
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
thanks poison.
hmm, cant make much out of that. reason i asked bout the xf86config was to see if you had enabled/disabled any driver-specific options in it. if you havent, cool.
 
Old 01-02-2004, 08:17 PM   #13
eddieman
LQ Newbie
 
Registered: Dec 2003
Distribution: Mandrake 9.2
Posts: 28

Original Poster
Rep: Reputation: 15
okay I'm in linux right now and it's so hard to read anything. The screen keeps messing up colours and everything. ARGH!!!

Okay well when I boot linux it goes to console, and I login as root (i've yet to make a normal user account). Then I startx, and now I'm on my desktop with Fluxbox.

This is so horribley messed up, all these cruddy graphics makes me want to hurt things. Okay well I'm in xterm now, now what? I typed in "su" and nothing happens, and if i type in the directory address yields nothing.

I will conquer you linux, one day at a time.
 
Old 01-02-2004, 08:34 PM   #14
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
since you already logged in as root, you dont need to su ^^
just do what h/w said... ^^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xfce and vectorlinux warpman Slackware 2 04-07-2005 04:28 PM
Slackware vs. Vectorlinux GATTACA Linux - Distributions 11 11-22-2004 12:50 PM
Vectorlinux - Won't Boot mr_vocab Linux - Newbie 2 01-30-2004 09:17 PM
Problem with VectorLinux? Gerardoj Linux - Software 1 11-23-2003 02:53 PM
Trying VectorLinux 40 mymojo VectorLinux 1 11-16-2003 03:24 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration