LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2002, 01:31 PM   #1
Travis86
Member
 
Registered: Dec 2002
Location: The land of GMT -6
Distribution: OS X, PS2 Linux, Ubuntu, IRIX 6.5
Posts: 399

Rep: Reputation: 31
GUI crawls like doesn't have any RAM


Post Numero Uno:

When I use the GUI it takes f-o-r-e-v-e-r to do anything. Every time I do anything the hard drive works so hard it sounds like it's going to break. It takes about five seconds to get a right-click menu!

The computer is a HP Pavilion with a 300mhz AMD K6 chip. It had no problem running Windows ME.

My guess is there is something wrong with the RAM. The hard drive goes into overdrive for everything. Just a guess.

Also, in addition to telling me what the problem is, it would help if you could tell me how to fix it.

Thanks.
 
Old 12-21-2002, 01:42 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
How much RAM do you have? How much swap?

Also, although it will take an hour and half to open up, you might want to open an xterm and run 'top' while trying to do anything. See how much resources are being used for each task, and maybe kill some of the higher ones.

Another option is to use a lighter wm (wm = window manager).

Cool
 
Old 12-21-2002, 06:02 PM   #3
Travis86
Member
 
Registered: Dec 2002
Location: The land of GMT -6
Distribution: OS X, PS2 Linux, Ubuntu, IRIX 6.5
Posts: 399

Original Poster
Rep: Reputation: 31
/proc/meminfo says I've got 64Mb of RAM and 170Mb of swap.

When I run "top" it says I'm using just about all of my RAM (672k free) and about 21Mb of swap. I suppose this means I need more ram, but does it really need ~85MB of ram just to run?

Please tell me if my deductions are correct before I go buy more ram.

Also, I notice that the disk works amost constantly. It sounds like it does when it boots up. It even does this when I'm in terminal mode and not doing anything. Surely this isn't a memory problem. Or is this normal?

Thanks
 
Old 12-21-2002, 06:21 PM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Is this forever, or is it possibly just running ALOT of cronjobs at startup, and maybe failing some (which would make your system run slow)?

I prefer 'free' to show me info about my memory, it's a little more in depth.

~85MB to run some of the Desktop Environments, like KDE might be scrapin by. Switch to something ALOT lighter, XFCE, Fluxbox, Blackbox, twm Or whatever, just something lighter.
That will help, and you should be seeing some improvement with just this.

If the disc is constantly "Cranking" then you might also wanna check out what's going on. Check your log files, usually located in /var/log or very close by.

/var/log/messages is your startup log file and that might also reveal something. I'd say you might wanna cut down on some services running.

So, summary:
Cut down running services you don't need, switch to a lighter wm (XFCE even claims to be Cholesterol Free ), and read your log files to see if something is REALLY slowing it down (due to long timeouts or whatever).

Cool
 
Old 12-21-2002, 07:31 PM   #5
Travis86
Member
 
Registered: Dec 2002
Location: The land of GMT -6
Distribution: OS X, PS2 Linux, Ubuntu, IRIX 6.5
Posts: 399

Original Poster
Rep: Reputation: 31
I checked the log files. Just a couple of my failed logins.
It said I didn't have any of the wm's except twm. Is that some kind of inside joke wm? I'd rather use the command line!

I guess the answer to my question is ultimately: get more ram.

Thanks for helping me get to the bottom of that.
 
Old 12-21-2002, 07:48 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
ha ha ha, Nah it's not really a joke. I believe xfree86 built that. It's as basic as they come.

No frills whatsoever.

BTW, I missed my civic duties:
Welcome to LQ!

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Latitude LM P166 40Mb Ram-will any distros with a GUI work? newtwolinux Linux - Laptop and Netbook 3 09-29-2005 11:25 AM
Skype crawls and fails to connect.... help me guys.I need this. byen Linux - Software 5 07-18-2005 04:57 AM
X crawls when downloading web page using Galeon stodge Linux - Software 1 08-26-2004 02:51 AM
My Compaq Armada110 laptop crawls totte Linux - Newbie 6 05-17-2004 07:19 AM
linux crawls on mercury 810DMST gokul Linux - General 0 06-17-2002 10:58 AM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration