LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2016, 04:25 PM   #1
DarkLogix
LQ Newbie
 
Registered: Jul 2013
Posts: 16

Rep: Reputation: Disabled
Guacamole+CentOS7+Tomcat8+APR


So I'm looking to setup a CentOS 7 VM on my home ESXi server but I want to do it what I consider "right".

I want to use CentOS 7 because it's pretty much RHEL 7 so anything I do I could replicate in a work environment line for line. Also i want to use the latest version of the OS.

I want to use tomcat 8 because it's the latest version of tomcat, though even using the epel repos only tomcat 7 gets installed (even with the SUI repo added yum list doesn't show any but ver 7) So is there a repo that would give me tomcat 8 and apply updates as the repo get updated? (kinda want to avoid custom built components as much as possible.)

I want to use the APR listener because it has better SSL support (IE you can fix the ciphers better with it.)

Also I want to use LDAP for auth and something else for storing the connections, because I have a MS AD running at home.

would someone be willing to help me?
 
Old 01-18-2016, 07:26 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
So is there a repo that would give me tomcat 8 and apply updates as the repo get updated? (kinda want to avoid custom built components as much as possible.)
If there is a repo with tomcat 8 in it I'm not sure which repo it would be in.
There are 4 different repo's that I know of.
RPMForge is now RepoForge. Aside from that there is Epel, Remi and Atrpms repositories.

Have you tried yum install tomcat8?

I could only find tomcat 8 as a direct Download.
https://tomcat.apache.org/download-80.cgi
http://tecadmin.net/install-tomcat-8...el-and-ubuntu/

Quote:
Also i want to use the latest version of the OS.
When you perform a fresh installation of CentOS and you run the first update the os should be comptlely up-to-date.

I not on a server so I won't be much help there.
 
Old 01-18-2016, 07:28 PM   #3
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
https://www.digitalocean.com/communi...-8-on-centos-7
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error: APR could not be located. Please use the --with-apr option. TheIndependentAquarius Linux - Software 1 02-14-2013 07:54 AM
LXer: A taste of Guacamole on Linux LXer Syndicated Linux News 0 01-19-2013 09:50 AM
Move apr & apr-util install locations? jbennett Linux - Newbie 3 04-20-2012 11:02 AM
APR-util with APR - configure error on Linux nicky77 Linux - Software 1 03-10-2010 11:25 AM
Did I configure apr, apr-util, and subversion correctly? Quip11 Linux - Server 2 06-11-2009 09:38 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration