checking for BASE_DEPENDENCIES.. configure: error: Package requirements
(glib-2.0 >= 2.17.6 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6)
were not met:
What you are trying to do, is to compile a gtk2 so new, that it
depends on libs not installed on your system.
" >= " means : this version or better. So if doable, you would
have to start with glib-2.0, atk, pango, cairo.
Try this : # 'dpkg -r gtk2.0-0' and the terminal window text will
tell that 200 packages are depending on it. So building and installing
newer versions of gtk2 and it's dependencies will probably make your
It would be much easier to build firefox 3 from source with the
libs you have on your system.'libgtk2.0-0 (2.12.11-4)' will do.
( If you think, iceweasel (3.0.5-1) can't do what you want. )