LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2009, 12:48 AM   #1
phasma
LQ Newbie
 
Registered: Jan 2009
Location: Pennsylvania
Distribution: Debian
Posts: 4

Rep: Reputation: 0
GTK+ Installation Help!


Hey I am quite new to this forum and pretty excited I found it, but I'll cut to the chase. I am running Debian and I want to install GTK+ so I can use Firefox and QuickSynergy. But every time I try ./configure in the GTK directory I get this error.

Code:
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.17.6    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6) were not met:

Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
I've tried using the "apt-get install" package installer to get the missing packages but I still get this error. I honestly cannot figure this out, I've been at it for days now. I really need some help here. If any more information is needed feel free to ask! Thanks!
 
Old 01-18-2009, 01:03 AM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 32
Try installing the libgtk2.0-dev or libgtk1.2-dev packages.
 
Old 01-18-2009, 01:10 AM   #3
phasma
LQ Newbie
 
Registered: Jan 2009
Location: Pennsylvania
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Xian View Post
Try installing the libgtk2.0-dev or libgtk1.2-dev packages.
I just tried that and both of them were supposedly up-to-date. Then I tried ./configure in GTK and got the same error from above.
 
Old 01-18-2009, 07:18 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Quote:
checking for BASE_DEPENDENCIES.. configure: error: Package requirements
(glib-2.0 >= 2.17.6 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6)
were not met:
What you are trying to do, is to compile a gtk2 so new, that it
depends on libs not installed on your system.
" >= " means : this version or better. So if doable, you would
have to start with glib-2.0, atk, pango, cairo.

Try this : # 'dpkg -r gtk2.0-0' and the terminal window text will
tell that 200 packages are depending on it. So building and installing
newer versions of gtk2 and it's dependencies will probably make your
system unusable.

It would be much easier to build firefox 3 from source with the
libs you have on your system.'libgtk2.0-0 (2.12.11-4)' will do.
( If you think, iceweasel (3.0.5-1) can't do what you want. )
....

Last edited by knudfl; 01-18-2009 at 10:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK+ 2.12 Installation The_Beast Slackware 6 06-20-2008 12:56 PM
gtk+- 2.6.10 installation vnutheti Linux - Newbie 2 03-30-2006 01:28 PM
GTK+2 Installation secureoffice SUSE / openSUSE 9 10-10-2005 02:25 PM
Gtk Installation Elbryan Fedora 1 02-23-2005 07:47 PM
GTK installation miskiw Linux - Software 2 04-24-2004 11:26 AM


All times are GMT -5. The time now is 07:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration