LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2005, 08:21 PM   #1
Brian031168
LQ Newbie
 
Registered: Mar 2005
Location: Mexico
Distribution: Ubuntu 5.10
Posts: 16

Rep: Reputation: 0
GTK+ installation - error message


Trying to install GTK+-2.6.4

After running./configure command I get the following error message

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pan
go >= 1.8.0> not met; consider adjusting the PKG_CONFIG_PATH environment variable
if your libraries are in a nonstandard prefix so pkg-config can find them.

Can anyone tell me what I need to do now.

TIA
 
Old 04-01-2005, 04:37 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,587

Rep: Reputation: 121Reputation: 121
You seem to need newer versions of the mentioned libs to build the gtk+ 2.6.4 library. If you look on your system you will see, that Mandrake 9.0 probably ships with older versions.
You would have build/install them too, to get gtk2 working. Can't you find a repository for this, does someone still maintain Mandrake 9.0?
If you have the mentioned libs (in the error output) on your system write here again, I'm sure you will get other responses then.
 
Old 04-01-2005, 05:35 AM   #3
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you have to install the prerequisites first ( read the README). also, you probably don't want to do ./configure, make, make install - it's fine if you do, but you will have to set up all of your environmental paths manually and Mandrake ships with them in /usr so it's best to put them back there ( remove the old libs first).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CD installation error message zillah Mandriva 10 03-20-2005 02:25 AM
Slackware error message after Installation atko Slackware - Installation 6 06-09-2004 04:14 PM
Error Message during UT2003 installation dipodo Linux - Games 1 01-16-2004 02:15 PM
error message on installation kiru Linux - General 4 04-08-2003 03:19 PM
LT Winmodem installation error message jburns_99 Linux - Software 6 08-21-2001 09:36 AM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration